]> git.pld-linux.org Git - packages/geninitrd.git/commitdiff
- rel 3; load font at initrd auto/th/geninitrd-12736-3
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 9 Jun 2014 17:23:36 +0000 (19:23 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 9 Jun 2014 17:23:36 +0000 (19:23 +0200)
geninitrd-git.patch
geninitrd.spec

index 706c2640976f95cc52e171117d2d909ee1dfa4be..59fae927726639c5f9b6c6f325c06d747aaa5e4b 100644 (file)
@@ -17,3 +17,47 @@ index dbb7c53..6e3008d 100644
        # initrd dedicated rules
        inst_rules 01-ignore.rules 59-persistent-storage.rules 61-persistent-storage.rules 11-dm.rules
  
+commit ff9aded51db8fa19316dde7864ec193f5fdf22b6
+Author: Arkadiusz Miśkiewicz <arekm@maven.pl>
+Date:   Mon Jun 9 11:19:10 2014 +0200
+
+    Load configured font and do it early.
+
+diff --git a/geninitrd b/geninitrd
+index 2478063..f31f00d 100755
+--- a/geninitrd
++++ b/geninitrd
+@@ -202,6 +202,25 @@ mount_dev() {
+       EOF
+ }
++# load font
++load_font() {
++      local font
++      [ ! -r /etc/sysconfig/console ] && return
++      . /etc/sysconfig/console
++      if [ -n "$CONSOLEFONT" ]; then
++              font=$(ls -1 /lib/kbd/consolefonts/${CONSOLEFONT}*.gz 2> /dev/null)
++              if [ -n "$font" ]; then
++                      verbose "Loading font $font"
++                      busybox_applet loadfont
++                      inst_d "/lib/kbd/consolefonts"
++                      cp -a "$font" "$DESTDIR/lib/kbd/consolefonts/"
++                      gunzip ${DESTDIR}/lib/kbd/consolefonts/${CONSOLEFONT}*.gz
++                      font=${font%.gz}
++                      echo "loadfont < $font" | add_linuxrc
++              fi
++      fi
++}
++
+ # generate code to mount /proc on initrd
+ # can be called multiple times
+ mount_proc() {
+@@ -1478,6 +1497,7 @@ add_linuxrc <<EOF
+ # on $(LC_ALL=C date)
+ EOF
++load_font
+ mount_proc
+ kmsg "geninitrd/$VERSION starting"
index 3241f578227764e21d5ebcc9af4213e4134e381a..6005d3dd3d9aeba05762c04f78437db16f145d98 100644 (file)
@@ -7,7 +7,7 @@ Summary:        Creates an initial ramdisk image for preloading modules
 Summary(pl.UTF-8):     Narzędzie do tworzenia inicjalnego ramdysku używanego przy starcie systemu
 Name:          geninitrd
 Version:       12736
-Release:       2
+Release:       3
 License:       GPL
 Group:         Applications/System
 Source0:       %{name}-%{version}.tar.gz
@@ -17,7 +17,7 @@ URL:          http://git.pld-linux.org/?p=projects/geninitrd.git
 BuildRequires: xmlto >= 0:0.0.18-1
 Requires:      /usr/bin/ldd
 Requires:      awk
-Requires:      busybox-initrd >= 1.12.2-2
+Requires:      busybox-initrd >= 1.22.1-2
 Requires:      coreutils
 Requires:      cpio
 Requires:      fileutils
This page took 0.171056 seconds and 4 git commands to generate.