]> git.pld-linux.org Git - packages/gengetopt.git/blob - gengetopt.spec
19ee94e3c188be7e027561c905e865d056d3ad39
[packages/gengetopt.git] / gengetopt.spec
1 Summary:        C code generator that generates command line options parsers
2 Summary(pl.UTF-8):      Generator kodu C generujący analizatory opcji linii poleceń
3 Name:           gengetopt
4 Version:        2.22.6
5 Release:        1
6 License:        GPL v3+
7 Group:          Development/Tools
8 Source0:        http://ftp.gnu.org/gnu/gengetopt/%{name}-%{version}.tar.gz
9 # Source0-md5:  29749a48dda69277ab969c510597a14e
10 Patch0:         %{name}-info.patch
11 Patch1:         %{name}-am.patch
12 URL:            http://www.gnu.org/software/gengetopt/
13 BuildRequires:  autoconf >= 2.58
14 BuildRequires:  automake
15 BuildRequires:  help2man
16 BuildRequires:  libstdc++-devel
17 BuildRequires:  libtool >= 2:1.5
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Gengetopt generates a C function that uses getopt_long function to
22 parse the command line options, to validate them and fills a struct.
23
24 %description -l pl.UTF-8
25 Gengetopt jest to narzędzie generujące kod w języku C, wykorzystujący
26 funkcję getopt_long do analizy opcji linii poleceń, sprawdzania ich
27 poprawności i umieszczania ich w strukturze.
28
29 %package examples
30 Summary:        gengetopt examples
31 Summary(pl.UTF-8):      Przykłady do gengetopt
32 Group:          Documentation
33 Requires:       %{name} = %{version}-%{release}
34
35 %description examples
36 Gengetopt examples.
37
38 %description examples -l pl.UTF-8
39 Przykłady do gengetopt.
40
41 %prep
42 %setup -q
43 %patch0 -p1
44 %patch1 -p1
45
46 %build
47 %{__libtoolize}
48 %{__aclocal} -I m4 -I gl/m4
49 %{__autoconf}
50 %{__autoheader}
51 %{__automake} --gnu
52 %configure
53 %{__make}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
58
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 cp -p doc/*.{c,cc,ggo,h} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
63 cp -p doc/README.example $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
64
65 # packaged as %doc
66 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/gengetopt
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %post   -p /sbin/postshell
72 -/usr/sbin/fix-info-dir -c %{_infodir}
73
74 %postun -p /sbin/postshell
75 -/usr/sbin/fix-info-dir -c %{_infodir}
76
77 %files
78 %defattr(644,root,root,755)
79 %doc AUTHORS ChangeLog LICENSE NEWS README THANKS TODO doc/{gengetopt,index}.html
80 %attr(755,root,root) %{_bindir}/gengetopt
81 %{_mandir}/man1/gengetopt.1*
82 %{_infodir}/gengetopt.info*
83 %{_datadir}/%{name}
84
85 %files examples
86 %defattr(644,root,root,755)
87 %{_examplesdir}/%{name}-%{version}
This page took 0.055557 seconds and 3 git commands to generate.