]> git.pld-linux.org Git - packages/gemrb.git/blob - gemrb.spec
upstream fix for crash with GLES backend
[packages/gemrb.git] / gemrb.spec
1 #
2 # Conditional build:
3 %bcond_with     gles    # build GLES backend
4
5 Summary:        Emulator of BioWare's Infinity game engine
6 Summary(pl.UTF-8):      Emulator silnika gier Infinity firmy BioWare
7 Name:           gemrb
8 Version:        0.8.7
9 Release:        0.1
10 License:        GPL v2+
11 Group:          Applications/Emulators
12 Source0:        https://downloads.sourceforge.net/gemrb/%{name}-%{version}-sources.tar.gz
13 # Source0-md5:  d1bf1dd8ca03ce9649b52240d363f357
14 Patch0:         %{name}-config_file.patch
15 Patch1:         %{name}-gles.patch
16 URL:            http://gemrb.sourceforge.net/
17 BuildRequires:  OpenAL-devel
18 %{!?with_gles:BuildRequires:    OpenGL-devel}
19 %{?with_gles:BuildRequires:     OpenGLESv2-devel}
20 BuildRequires:  SDL2-devel
21 BuildRequires:  SDL2_mixer-devel
22 BuildRequires:  cmake >= 3.1
23 BuildRequires:  freetype-devel
24 %{!?with_gles:BuildRequires:    glew-devel}
25 BuildRequires:  libpng-devel
26 BuildRequires:  libstdc++-devel >= 6:4.8.1
27 BuildRequires:  libvorbis-devel
28 BuildRequires:  pkgconfig
29 BuildRequires:  python-devel >= 1:2.3.0
30 BuildRequires:  python-modules
31 BuildRequires:  rpmbuild(macros) >= 1.605
32 BuildRequires:  vlc-devel
33 BuildRequires:  zlib-devel
34 Requires(post,postun):  desktop-file-utils
35 Requires(post,postun):  gtk-update-icon-cache
36 Requires(post,postun):  hicolor-icon-theme
37 Suggests:       synce-unshield
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 This Game Engine is a port of the original Infinity Engine (the one of
42 Baldur's Gate, Planescape: Torment, Icewind Dale) to Linux/Unix, MacOs
43 X and Windows with some Enhancements.
44
45 %description -l pl.UTF-8
46 Silnik ten jest portem oryginalnego silnika Infinity Engine (używanego
47 przez Baldur's Gate, Planescape: Torment, Icewind Dale) dla systemów
48 Linux/Unix, MacOS i Windows. Silnik posiada kilka ulepszeń.
49
50 %prep
51 %setup -q
52 %patch0 -p1
53 %patch1 -p1
54
55 %{__sed} -i -e '1s,/usr/bin/python$,%{__python},' admin/extend2da.py
56
57 %build
58 install -d build
59 cd build
60 %cmake .. \
61         -DBIN_DIR="%{_bindir}" \
62         -DSYSCONF_DIR="%{_sysconfdir}/gemrb" \
63         -DLIB_DIR="%{_libdir}" \
64         -DPLUGIN_DIR="%{_libdir}/gemrb/plugins" \
65         -DDATA_DIR="%{_datadir}/gemrb" \
66         -DMAN_DIR="%{_mandir}/man6" \
67         -DICON_DIR="%{_pixmapsdir}" \
68         -DSVG_DIR="%{_iconsdir}/hicolor/scalable/apps" \
69         -DMENU_DIR="%{_desktopdir}" \
70         -DOPENGL_BACKEND=%{!?with_gles:OpenGL}%{?with_gles:GLES} \
71         -DSDL_BACKEND=SDL2
72 %{__make}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76
77 %{__make} install -C build \
78         DESTDIR=$RPM_BUILD_ROOT
79
80 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}
81 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/gemrb/GemRB.cfg{.noinstall,}.sample
82 %{__mv} $RPM_BUILD_ROOT%{_sysconfdir}/gemrb/{GemRB.cfg,gemrb.cfg}
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %post
88 /sbin/ldconfig
89 %update_desktop_database_post
90 %update_icon_cache hicolor
91
92 %postun
93 /sbin/ldconfig
94 %update_desktop_database_postun
95 %update_icon_cache hicolor
96
97 %files
98 %defattr(644,root,root,755)
99 %doc AUTHORS CONTRIBUTING.md NEWS README.md %{name}/{docs/en/*.txt,GemRB.cfg*.sample}
100 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gemrb/gemrb.cfg
101 %attr(755,root,root) %{_bindir}/gemrb
102 %attr(755,root,root) %{_libdir}/libgemrb_core.so.*.*.*
103 %dir %{_libdir}/gemrb
104 %dir %{_libdir}/gemrb/plugins
105 %attr(755,root,root) %{_libdir}/gemrb/plugins/*.so
106 %{_datadir}/gemrb
107 %{_mandir}/man6/gemrb.6*
108 %{_desktopdir}/gemrb.desktop
109 %{_iconsdir}/hicolor/scalable/apps/gemrb.svg
110 %{_pixmapsdir}/gemrb.png
This page took 0.165841 seconds and 3 git commands to generate.