up to 0.11.3 auto/th/gem2rpm-0.11.3-1
authorElan Ruusamäe <glen@delfi.ee>
Mon, 23 May 2016 16:36:07 +0000 (19:36 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Mon, 23 May 2016 16:36:07 +0000 (19:36 +0300)
gem2rpm.spec
style.patch

index e761e4d..665302b 100644 (file)
@@ -4,12 +4,12 @@
 
 Summary:       Generate rpm specfiles from gems
 Name:          gem2rpm
-Version:       0.11.2
+Version:       0.11.3
 Release:       1
 License:       GPL v2+
 Group:         Development/Languages
 Source0:       https://github.com/fedora-ruby/gem2rpm/archive/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 80d6170dcfe7d0a840e8bf7149096d3a
+# Source0-md5: 5d81c9a3a9849f905819781fb61f86aa
 Source2:       pld.spec.erb
 Patch0:                gems.patch
 Patch1:                os-release-quotes.patch
index b30f968..ed73a15 100644 (file)
@@ -9,8 +9,8 @@
      end
  
      # Expands the not equal version operator '!=' into equivalent '<' and
---- gem2rpm-0.9.2/test/test_helpers.rb~        2013-04-23 10:58:32.000000000 +0300
-+++ gem2rpm-0.9.2/test/test_helpers.rb 2013-04-29 23:51:55.467457420 +0300
+--- gem2rpm-0.11.3/test/test_helpers.rb~       2016-05-23 19:34:28.000000000 +0300
++++ gem2rpm-0.11.3/test/test_helpers.rb        2016-05-23 19:35:00.032567329 +0300
 @@ -19,12 +19,12 @@
  
    def test_first_level_pessimistic_version_constraint
    end
  
    def test_pessimistic_version_constraint_with_trailing_text
-@@ -32,13 +32,13 @@
-     gem_version = Gem::Version.create(Gem::RubyGemsVersion)
-     if gem_version >= Gem::Version.create("1.3.2")
-       r = Gem::Requirement.new(["~> 1.2.3.beta.8"])
--      assert_equal(["=> 1.2.3.beta.8", "< 1.3"], Gem2Rpm::Helpers.requirement_versions_to_rpm(r))
-+      assert_equal([">= 1.2.3.beta.8", "< 1.3"], Gem2Rpm::Helpers.requirement_versions_to_rpm(r))
-     end
+@@ -33,12 +33,12 @@
+     return if gem_version >= Gem::Version.create("1.3.2")
+     r = Gem::Requirement.new(["~> 1.2.3.beta.8"])
+-    assert_equal(["=> 1.2.3.beta.8", "< 1.3"], Gem2Rpm::Helpers.requirement_versions_to_rpm(r))
++    assert_equal([">= 1.2.3.beta.8", "< 1.3"], Gem2Rpm::Helpers.requirement_versions_to_rpm(r))
    end
  
    def test_second_level_pessimistic_version_constraint_with_two_digit_version
This page took 0.081888 seconds and 4 git commands to generate.