]> git.pld-linux.org Git - packages/gem2rpm.git/commitdiff
use '>=' not '=>' in specs
authorElan Ruusamäe <glen@delfi.ee>
Mon, 29 Apr 2013 20:25:55 +0000 (23:25 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Mon, 29 Apr 2013 20:25:55 +0000 (23:25 +0300)
gem2rpm.spec
style.patch [new file with mode: 0644]

index 060c1fd4c042e783319945f5e5284c70af590ce7..03581e031a825aa08fe1ab9ea88e9524b6e78192 100644 (file)
@@ -13,6 +13,7 @@ Source1:      %{name}-%{version}-tests.tgz
 Source2:       pld.spec.erb
 Patch0:                gems.patch
 Patch1:                pld.patch
+Patch2:                style.patch
 URL:           https://github.com/lutter/gem2rpm/
 BuildRequires: rpm-rubyprov
 BuildRequires: rpmbuild(macros) >= 1.656
@@ -37,6 +38,7 @@ Documentation for %{name}.
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 cp -p %{SOURCE2} templates
 
 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
diff --git a/style.patch b/style.patch
new file mode 100644 (file)
index 0000000..af76178
--- /dev/null
@@ -0,0 +1,11 @@
+--- gem2rpm-0.8.1/lib/gem2rpm/helpers.rb~      2013-04-29 22:57:16.000000000 +0300
++++ gem2rpm-0.8.1/lib/gem2rpm/helpers.rb       2013-04-29 23:13:01.409116757 +0300
+@@ -12,7 +12,7 @@
+       requirements.inject([]) do |output, r|
+         if r.first == '~>'
+         next_version = Gem::Version.create(r.last).bump
+-        output << ['=>', r.last]
++        output << ['>=', r.last]
+         output << ['<', next_version]
+       else
+         output << r
This page took 0.030336 seconds and 4 git commands to generate.