add rubygems test, if required version specified
authorElan Ruusamäe <glen@delfi.ee>
Mon, 29 Apr 2013 21:17:49 +0000 (00:17 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Mon, 29 Apr 2013 21:17:49 +0000 (00:17 +0300)
pld.spec.erb

index 65ca1e5..09ff21f 100644 (file)
@@ -16,6 +16,9 @@ BuildRequires:        ruby-devel
 <% if ! spec.executables.empty? -%>
 BuildRequires: sed >= 4.0
 <% end -%>
+<% if ! spec.required_rubygems_version.empty? and ! spec.required_rubygems_version.first.empty? -%>
+Requires:      ruby-rubygems <%= spec.required_rubygems_version.first %>
+<% end -%>
 <% for d in spec.runtime_dependencies -%>
 <% for req in d.requirement -%>
 Requires:      ruby-<%= d.name %> <%= req %>
This page took 0.073934 seconds and 4 git commands to generate.