]> git.pld-linux.org Git - packages/gegl.git/commitdiff
- updated to 0.3.6 auto/th/gegl-0.3.6-1
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 21 Mar 2016 17:51:05 +0000 (18:51 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Mon, 21 Mar 2016 17:51:05 +0000 (18:51 +0100)
- updated format patch
- requires mrg with scroll events support

gegl-format.patch
gegl.spec

index 8d79cae26338545fcd2262b9950921bb80f6db95..bde7bcb21ac4549cf4463b93c539943106beec5f 100644 (file)
        goto cleanup;
      }
  
+--- gegl-0.3.6/operations/external/svg-load.c.orig     2016-02-12 16:06:15.000000000 +0100
++++ gegl-0.3.6/operations/external/svg-load.c  2016-03-20 22:24:31.911556257 +0100
+@@ -164,7 +164,7 @@
+       stream = gegl_gio_open_input_stream (o->uri, o->path, &p->file, &error);
+       if (stream == NULL)
+         {
+-          g_warning (error->message);
++          g_warning ("%s", error->message);
+           g_error_free (error);
+           cleanup (operation);
+           return;
+@@ -175,7 +175,7 @@
+                                                     NULL, &error);
+       if (p->handle == NULL)
+         {
+-          g_warning (error->message);
++          g_warning ("%s", error->message);
+           g_error_free (error);
+           cleanup (operation);
+           return;
+--- gegl-0.3.6/operations/external/jp2-load.c.orig     2016-02-12 16:04:50.000000000 +0100
++++ gegl-0.3.6/operations/external/jp2-load.c  2016-03-21 15:56:55.885572998 +0100
+@@ -88,7 +88,7 @@
+                                  NULL, &error);
+       if (read < 0)
+         {
+-          g_warning(error->message);
++          g_warning("%s", error->message);
+           g_error_free(error);
+           break;
+         }
+@@ -265,7 +265,7 @@
+       stream = gegl_gio_open_input_stream(o->uri, o->path, &p->file, &error);
+       if (stream == NULL)
+         {
+-          g_warning(error->message);
++          g_warning("%s", error->message);
+           g_error_free(error);
+           cleanup(operation);
+           return;
+--- gegl-0.3.6/operations/external/tiff-load.c.orig    2016-03-21 15:57:29.522238275 +0100
++++ gegl-0.3.6/operations/external/tiff-load.c 2016-03-21 16:21:50.918843615 +0100
+@@ -119,7 +119,7 @@
+   gchar *message;
+   g_vasprintf(&message, format, arguments);
+-  g_warning(message);
++  g_warning("%s", message);
+   g_free(message);
+ }
+@@ -132,7 +132,7 @@
+   gchar *message;
+   g_vasprintf(&message, format, arguments);
+-  g_message(message);
++  g_message("%s", message);
+   g_free(message);
+ }
+--- gegl-0.3.6/operations/external/tiff-save.c.orig    2016-03-21 16:22:13.188842681 +0100
++++ gegl-0.3.6/operations/external/tiff-save.c 2016-03-21 16:35:54.658808205 +0100
+@@ -94,7 +94,7 @@
+   gchar *message;
+   g_vasprintf(&message, format, arguments);
+-  g_warning(message);
++  g_warning("%s", message);
+   g_free(message);
+ }
+@@ -107,7 +107,7 @@
+   gchar *message;
+   g_vasprintf(&message, format, arguments);
+-  g_message(message);
++  g_message("%s", message);
+   g_free(message);
+ }
+--- gegl-0.3.6/operations/external/webp-load.c.orig    2016-02-12 16:05:43.000000000 +0100
++++ gegl-0.3.6/operations/external/webp-load.c 2016-03-21 17:11:10.675386077 +0100
+@@ -100,7 +100,7 @@
+                                      NULL, &error);
+   if (!success || error != NULL)
+     {
+-      g_warning (error->message);
++      g_warning ("%s", error->message);
+       g_error_free (error);
+       return -1;
+     }
+@@ -130,7 +130,7 @@
+                                          NULL, &error);
+       if (!success || error != NULL)
+         {
+-          g_warning (error->message);
++          g_warning ("%s", error->message);
+           g_error_free (error);
+           return -1;
+         }
+@@ -208,7 +208,7 @@
+       p->stream = gegl_gio_open_input_stream (o->uri, o->path, &p->file, &error);
+       if (p->stream == NULL)
+         {
+-          g_warning (error->message);
++          g_warning ("%s", error->message);
+           g_error_free (error);
+           cleanup (operation);
+           return;
index 15a5f4711917fcf875f9f16f0704d40554934148..674f2d332b11ce92555ea50a6e4dbcd19532e706 100644 (file)
--- a/gegl.spec
+++ b/gegl.spec
 Summary:       Generic image processing library
 Summary(pl.UTF-8):     Ogólna biblioteka przetwarzania obrazu
 Name:          gegl
-Version:       0.3.4
-Release:       3
+Version:       0.3.6
+Release:       1
 License:       LGPL v3+
 Group:         Libraries
 Source0:       http://ftp.gimp.org/pub/gegl/0.3/%{name}-%{version}.tar.bz2
-# Source0-md5: c19478321594d715a4cb324a0decda6f
+# Source0-md5: e6b4eb720ef541aab8c9b12b1a517a78
 Patch1:                %{name}-format.patch
 Patch2:                %{name}-ruby1.9.patch
 Patch3:                %{name}-build.patch
@@ -40,8 +40,8 @@ BuildRequires:        babl-devel >= 0.1.14
 BuildRequires: cairo-devel
 BuildRequires: enscript
 BuildRequires: exiv2-devel
-# libavformat >= 53.0.0, libavcodec >= 53.0.0
-BuildRequires: ffmpeg-devel >= 0.8
+# libavformat >= 55.48.100, libavcodec >= 55.69.100, libswscale >= 2.6.100
+BuildRequires: ffmpeg-devel >= 2.3
 BuildRequires: gdk-pixbuf2-devel >= 2.18.0
 BuildRequires: gettext-tools
 BuildRequires: gexiv2-devel
@@ -64,7 +64,7 @@ BuildRequires:        libtool >= 2:2.2
 BuildRequires: libv4l-devel >= 1.0.1
 BuildRequires: libwebp-devel
 BuildRequires: lua51-devel >= 5.1.5-2
-BuildRequires: mrg-devel
+BuildRequires: mrg-devel >= 0-0.20160310
 BuildRequires: pango-devel >= 1:1.10
 BuildRequires: perl-base
 BuildRequires: pkgconfig
@@ -83,6 +83,7 @@ Requires:     lensfun >= 0.2.5
 Requires:      libraw >= 0.15.4
 Requires:      librsvg >= 1:2.14.0
 Requires:      libtiff >= 4.0.0
+Requires:      mrg-libs >= 0-0.20160310
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
This page took 0.083829 seconds and 4 git commands to generate.