]> git.pld-linux.org Git - packages/gegl.git/blob - gegl.spec
c024f70b7527a3c48a225e096006a188b531f0a9
[packages/gegl.git] / gegl.spec
1 #
2 # Conditional build:
3 %bcond_with     mmx             # use MMX instructions
4 %bcond_with     sse             # use SSE instructions
5 %bcond_without  doc             # apidocs
6 %bcond_without  introspection   # API introspection
7 # reenable when new babl will arrive that actually is able to build
8 %bcond_with     vala            # Vala API
9 #
10 %ifarch %{x8664} athlon pentium3 pentium4
11 %define with_mmx        1
12 %endif
13 %ifarch %{x8664} pentium3 pentium4
14 %define with_sse        1
15 %endif
16 %if %{without introspection}
17 %undefine       with_vala
18 %endif
19 Summary:        Generic image processing library
20 Summary(pl.UTF-8):      Ogólna biblioteka przetwarzania obrazu
21 Name:           gegl
22 Version:        0.2.0
23 Release:        0.1
24 License:        LGPL v3+
25 Group:          Libraries
26 Source0:        ftp://ftp.gimp.org/pub/gegl/0.2/%{name}-%{version}.tar.bz2
27 # Source0-md5:  32b00002f1f1e316115c4ed922e1dec8
28 Patch0:         %{name}-lua.patch
29 Patch1:         %{name}-ffmpeg.patch
30 Patch2:         %{name}-ruby1.9.patch
31 Patch3:         %{name}-build.patch
32 Patch4:         %{name}-introspection.patch
33 URL:            http://www.gegl.org/
34 BuildRequires:  OpenEXR-devel
35 BuildRequires:  SDL-devel
36 BuildRequires:  UMFPACK-devel
37 BuildRequires:  asciidoc
38 BuildRequires:  autoconf >= 2.54
39 BuildRequires:  automake >= 1:1.11
40 BuildRequires:  babl-devel >= 0.1.10
41 %{?with_introspection:BuildRequires:    /usr/share/gir-1.0/Babl-0.1.gir}
42 BuildRequires:  cairo-devel
43 BuildRequires:  enscript
44 BuildRequires:  exiv2-devel
45 BuildRequires:  ffmpeg-devel >= 0.8
46 BuildRequires:  gdk-pixbuf2-devel >= 2.18.0
47 BuildRequires:  glib2-devel >= 1:2.28.0
48 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 0.10.0}
49 BuildRequires:  graphviz
50 BuildRequires:  gtk-doc >= 1.0
51 BuildRequires:  intltool >= 0.40.1
52 BuildRequires:  jasper-devel >= 1.900.1
53 BuildRequires:  lensfun-devel >= 0.2.5
54 BuildRequires:  libjpeg-devel
55 BuildRequires:  libopenraw-devel >= 0.0.5
56 BuildRequires:  libpng-devel
57 BuildRequires:  librsvg-devel >= 1:2.14.0
58 BuildRequires:  libspiro-devel
59 BuildRequires:  libtool >= 2:2.2
60 BuildRequires:  libv4l-devel
61 BuildRequires:  lua51-devel >= 5.1.0
62 BuildRequires:  pango-devel >= 1:1.10
63 BuildRequires:  perl-base
64 BuildRequires:  pkgconfig
65 BuildRequires:  ruby >= 1.9
66 %{?with_vala:BuildRequires:     vala}
67 Requires:       babl >= 0.1.10
68 Requires:       glib2 >= 1:2.28.0
69 Requires:       gdk-pixbuf2 >= 2.18.0
70 Requires:       jasper-libs >= 1.900.1
71 Requires:       lensfun >= 0.2.5
72 Requires:       libopenraw >= 0.0.5
73 Requires:       librsvg >= 1:2.14.0
74 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
76 %description
77 GEGL (Generic Graphics Library) is a graph based image processing
78 framework.
79
80 GEGL's original design was made to scratch GIMP's itches for a new
81 compositing and processing core. This core is being designed to have
82 minimal dependencies and a simple well defined API.
83
84 %description -l pl.UTF-8
85 GEGL (Generic Graphics Library) to oparty na grafice szkielet do
86 przetwarzania obrazu.
87
88 Pierwotny projekt biblioteki GEGL powstał z myślą o nowym rdzeniu do
89 składania i przetwarzania obrazu w GIMP-ie. Rdzeń ten jest
90 projektowany tak, by miał minimalne zależności i proste, dobrze
91 zdefiniowane API.
92
93 %package devel
94 Summary:        Header files for gegl library
95 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gegl
96 Group:          Development/Libraries
97 Requires:       %{name} = %{version}-%{release}
98 Requires:       babl-devel >= 0.1.10
99 Requires:       glib2-devel >= 1:2.28.0
100
101 %description devel
102 Header files for gegl library.
103
104 %description devel -l pl.UTF-8
105 Pliki nagłówkowe biblioteki gegl.
106
107 %package static
108 Summary:        Static gegl library
109 Summary(pl.UTF-8):      Statyczna biblioteka gegl
110 Group:          Development/Libraries
111 Requires:       %{name}-devel = %{version}-%{release}
112
113 %description static
114 Static gegl library.
115
116 %description static -l pl.UTF-8
117 Statyczna biblioteka gegl.
118
119 %package apidocs
120 Summary:        gegl library API documentation
121 Summary(pl.UTF-8):      Dokumentacja API biblioteki gegl
122 Group:          Documentation
123 Requires:       gtk-doc-common
124
125 %description apidocs
126 gegl library API documentation.
127
128 %description apidocs -l pl.UTF-8
129 Dokumentacja API biblioteki gegl.
130
131 %package -n vala-gegl
132 Summary:        Vala API for gegl library
133 Summary(pl.UTF-8):      API języka Vala dla biblioteki gegl
134 Group:          Development/Libraries
135 Requires:       %{name}-devel = %{version}-%{release}
136
137 %description -n vala-gegl
138 Vala API for gegl library.
139
140 %description -n vala-gegl -l pl.UTF-8
141 API języka Vala dla biblioteki gegl.
142
143 %prep
144 %setup -q
145 %patch0 -p1
146 %patch1 -p1
147 %patch2 -p1
148 %patch3 -p1
149 %patch4 -p1
150
151 %build
152 %{__libtoolize}
153 %{__aclocal} -I m4
154 %{__autoconf}
155 %{__autoheader}
156 %{__automake}
157 %configure \
158         CPPFLAGS="%{rpmcppflags} -I/usr/include/umfpack" \
159         --enable-docs%{!?with_doc:=no} \
160         %{?with_introspection:--enable-introspection} \
161         %{!?with_mmx:--disable-mmx} \
162         %{!?with_sse:--disable-sse} \
163         --disable-silent-rules \
164         --enable-static \
165         --with%{!?with_vala:out}-vala
166 %{__make}
167
168 %install
169 rm -rf $RPM_BUILD_ROOT
170
171 %{__make} install \
172         DESTDIR=$RPM_BUILD_ROOT \
173         gtkdochtmldir=%{_gtkdocdir}/gegl
174
175 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gegl-0.2/*.{a,la}
176
177 %find_lang %{name}-0.2
178
179 %clean
180 rm -rf $RPM_BUILD_ROOT
181
182 %post   -p /sbin/ldconfig
183 %postun -p /sbin/ldconfig
184
185 %files -f %{name}-0.2.lang
186 %defattr(644,root,root,755)
187 %doc AUTHORS ChangeLog NEWS README
188 %attr(755,root,root) %{_bindir}/gegl
189 %attr(755,root,root) %{_libdir}/libgegl-0.2.so.*.*.*
190 %attr(755,root,root) %ghost %{_libdir}/libgegl-0.2.so.0
191 %{?with_introspection:%{_libdir}/girepository-1.0/Gegl-0.2.typelib}
192 %dir %{_libdir}/gegl-0.2
193 %attr(755,root,root) %{_libdir}/gegl-0.2/*.so
194
195 %files devel
196 %defattr(644,root,root,755)
197 %attr(755,root,root) %{_libdir}/libgegl-0.2.so
198 %{_libdir}/libgegl-0.2.la
199 %{_includedir}/gegl-0.2
200 %{?with_introspection:%{_datadir}/gir-1.0/Gegl-0.2.gir}
201 %{_pkgconfigdir}/gegl-0.2.pc
202
203 %files static
204 %defattr(644,root,root,755)
205 %{_libdir}/libgegl-0.2.a
206
207 %if %{with doc}
208 %files apidocs
209 %defattr(644,root,root,755)
210 %{_gtkdocdir}/gegl
211 %endif
212
213 %if %{with vala}
214 %files -n vala-gegl
215 %defattr(644,root,root,755)
216 %{_datadir}/vala/vapi/gegl-0.2.vapi
217 %endif
This page took 0.02826 seconds and 2 git commands to generate.