]> git.pld-linux.org Git - packages/gef.git/blame - gef.spec
- initital version
[packages/gef.git] / gef.spec
CommitLineData
9ae2c242 1# TODO:
2# javadoc package
3Summary: A diagram editing framework
4Name: gef
5Version: 0.10.7
6Release: 0.1
7License: Apache License
8Source0: http://gef.tigris.org/files/documents/9/10445/GEF-%{version}-src.zip
9# Source0-md5: bb4c1f5e902bbe9ad882794e88994e4c
10Url: http://gef.tigris.org/
11Requires: jakarta-log4j
12BuildRequires: jakarta-ant
13BuildRequires: jakarta-commons-logging
14Group: Development/Languages/Java
15BuildArch: noarch
16BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18%description
19The goal of the GEF project is to build a graph editing library that
20can be used to construct many, high-quality graph editing appications.
21Some of GEF's features are:
22- A simple, concrete design that makes the framework easy to
23 understand and extend.
24- Node-Port-Edge graph model that is powerful enough for the vast
25 majority of connectied graph applications.
26- Model-View-Controller design based on the Swing Java UI library
27 makes GEF able to act as a UI to existing data structures, and also
28 minimizing learning time for developers familiar with Swing.
29- High-quality user interactions for moving, resizeing, reshaping,
30 etc. GEF also supports several novel interactions such as the broom
31 alignment tool and section-action-buttons.
32- Generic properties sheet based on JavaBeans introspection.
33- XML-based file formats based on the PGML standard (soon to support
34 SVG).
35
36%package doc
37Summary: Javadoc for %{name}
38Group: Documentation
39
40%description doc
41Javadoc for %{name}.
42
43%prep
44rm -rf $RPM_BUILD_ROOT
45%setup -q -c -T
46mkdir src
47cd src
48unzip -q %{SOURCE0}
49# remove binary files
50find . -name "*.jar" -exec rm -f {} \;
51
52%build
53cd src
54ant package
55
56%install
57rm -rf $RPM_BUILD_ROOT
58install -D lib/%{name}.jar $RPM_BUILD_ROOT%{_javadir}/%{name}-%{version}.jar
59ln -sf %{name}-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/%{name}.jar
60
61%clean
62rm -rf $RPM_BUILD_ROOT
63
64%files
65%defattr(644,root,root,755)
66%doc src/COPYRIGHT src/INSTALL.txt src/readme.txt
67%{_javadir}/*
This page took 0.12558 seconds and 4 git commands to generate.