]> git.pld-linux.org Git - packages/gef.git/blob - gef.spec
- initital version
[packages/gef.git] / gef.spec
1 # TODO:
2 # javadoc package
3 Summary:        A diagram editing framework
4 Name:           gef
5 Version:        0.10.7
6 Release:        0.1
7 License:        Apache License
8 Source0:        http://gef.tigris.org/files/documents/9/10445/GEF-%{version}-src.zip
9 # Source0-md5:  bb4c1f5e902bbe9ad882794e88994e4c
10 Url:            http://gef.tigris.org/
11 Requires:       jakarta-log4j
12 BuildRequires:  jakarta-ant
13 BuildRequires:  jakarta-commons-logging
14 Group:          Development/Languages/Java
15 BuildArch:      noarch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 The goal of the GEF project is to build a graph editing library that
20 can be used to construct many, high-quality graph editing appications.
21 Some of GEF's features are:
22 - A simple, concrete design that makes the framework easy to
23   understand and extend.
24 - Node-Port-Edge graph model that is powerful enough for the vast
25   majority of connectied graph applications.
26 - Model-View-Controller design based on the Swing Java UI library
27   makes GEF able to act as a UI to existing data structures, and also
28   minimizing learning time for developers familiar with Swing.
29 - High-quality user interactions for moving, resizeing, reshaping,
30   etc. GEF also supports several novel interactions such as the broom
31   alignment tool and section-action-buttons.
32 - Generic properties sheet based on JavaBeans introspection.
33 - XML-based file formats based on the PGML standard (soon to support
34   SVG).
35
36 %package        doc
37 Summary:        Javadoc for %{name}
38 Group:          Documentation
39
40 %description    doc
41 Javadoc for %{name}.
42
43 %prep
44 rm -rf $RPM_BUILD_ROOT
45 %setup -q -c -T
46 mkdir src
47 cd src
48 unzip -q %{SOURCE0}
49 # remove binary files
50 find . -name "*.jar" -exec rm -f {} \;
51
52 %build
53 cd src
54 ant package
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -D lib/%{name}.jar $RPM_BUILD_ROOT%{_javadir}/%{name}-%{version}.jar
59 ln -sf %{name}-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/%{name}.jar
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc src/COPYRIGHT src/INSTALL.txt src/readme.txt
67 %{_javadir}/*
This page took 0.057701 seconds and 3 git commands to generate.