]> git.pld-linux.org Git - packages/geary.git/commitdiff
- updated to 44.0 auto/th/geary-44.0-1
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 27 Jul 2023 20:31:30 +0000 (22:31 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Thu, 27 Jul 2023 20:31:30 +0000 (22:31 +0200)
geary-non-null.patch [deleted file]
geary-type-arguments.patch [deleted file]
geary.spec

diff --git a/geary-non-null.patch b/geary-non-null.patch
deleted file mode 100644 (file)
index fdd6bd2..0000000
+++ /dev/null
@@ -1,154 +0,0 @@
-From 10f9c133a2ad515127d65f3bba13a0d91b75f4af Mon Sep 17 00:00:00 2001
-From: Rico Tzschichholz <ricotz@ubuntu.com>
-Date: Fri, 14 Apr 2023 09:42:23 +0200
-Subject: [PATCH] vala-unit: Fix non-null build with newer vala
-
----
- .../vala-unit/src/collection-assertions.vala   | 12 ++++++------
- subprojects/vala-unit/src/mock-object.vala     |  6 +++---
- subprojects/vala-unit/src/test-assertions.vala | 18 +++++++++---------
- 3 files changed, 18 insertions(+), 18 deletions(-)
-
-diff --git a/subprojects/vala-unit/src/collection-assertions.vala b/subprojects/vala-unit/src/collection-assertions.vala
-index 3b34acda1..29223a0d4 100644
---- a/subprojects/vala-unit/src/collection-assertions.vala
-+++ b/subprojects/vala-unit/src/collection-assertions.vala
-@@ -256,7 +256,7 @@ internal class ValaUnit.ArrayCollectionAssertion<E> : GLib.Object,
-     public CollectionAssertions<E> contains(E expected)
-         throws GLib.Error {
--        E boxed_expected = box_value(expected);
-+        E? boxed_expected = box_value(expected);
-         bool found = false;
-         for (int i = 0; i < this.actual.length; i++) {
-             try {
-@@ -281,7 +281,7 @@ internal class ValaUnit.ArrayCollectionAssertion<E> : GLib.Object,
-     public CollectionAssertions<E> not_contains(E expected)
-         throws GLib.Error {
--        E boxed_expected = box_value(expected);
-+        E? boxed_expected = box_value(expected);
-         for (int i = 0; i < this.actual.length; i++) {
-             try {
-                 assert_equal(box_value(this.actual[i]), boxed_expected);
-@@ -312,8 +312,8 @@ internal class ValaUnit.ArrayCollectionAssertion<E> : GLib.Object,
-                 this.context
-             );
-         }
--        E boxed_actual = box_value(this.actual[index]);
--        E boxed_expected = box_value(expected);
-+        E? boxed_actual = box_value(this.actual[index]);
-+        E? boxed_expected = box_value(expected);
-         try {
-             assert_equal(boxed_actual, boxed_expected);
-         } catch (TestError.FAILED err) {
-@@ -453,8 +453,8 @@ internal class ValaUnit.GeeCollectionAssertion<E> :
-         for (int i = 0; i <= index; i++) {
-             iterator.next();
-         }
--        E boxed_actual = box_value(iterator.get());
--        E boxed_expected = box_value(expected);
-+        E? boxed_actual = box_value(iterator.get());
-+        E? boxed_expected = box_value(expected);
-         try {
-             assert_equal(boxed_actual, boxed_expected);
-         } catch (TestError.FAILED err) {
-diff --git a/subprojects/vala-unit/src/mock-object.vala b/subprojects/vala-unit/src/mock-object.vala
-index 766777a43..eb086e10c 100644
---- a/subprojects/vala-unit/src/mock-object.vala
-+++ b/subprojects/vala-unit/src/mock-object.vala
-@@ -138,7 +138,7 @@ public interface ValaUnit.MockObject : GLib.Object, TestAssertions {
-         throws GLib.Error {
-         assert_false(this.expected.is_empty, "Unexpected call: %s".printf(name));
--        ExpectedCall expected = this.expected.poll();
-+        ExpectedCall expected = (!) this.expected.poll();
-         assert_equal(name, expected.name, "Unexpected call");
-         if (expected.expected_args != null) {
-             assert_args(args, expected.expected_args, "Call %s".printf(name));
-@@ -229,7 +229,7 @@ public interface ValaUnit.MockObject : GLib.Object, TestAssertions {
-                                           R default_return)
-         throws GLib.Error {
-         check_for_exception(expected);
--        R? return_object = default_return;
-+        R return_object = default_return;
-         if (expected.return_object != null) {
-             return_object = (R) expected.return_object;
-         }
-@@ -243,7 +243,7 @@ public interface ValaUnit.MockObject : GLib.Object, TestAssertions {
-         if (expected.return_object == null) {
-             throw default_error;
-         }
--        return expected.return_object;
-+        return (!) expected.return_object;
-     }
-     private inline void check_for_exception(ExpectedCall expected)
-diff --git a/subprojects/vala-unit/src/test-assertions.vala b/subprojects/vala-unit/src/test-assertions.vala
-index 784dd9fdd..e61fdf82d 100644
---- a/subprojects/vala-unit/src/test-assertions.vala
-+++ b/subprojects/vala-unit/src/test-assertions.vala
-@@ -21,8 +21,8 @@ namespace ValaUnit {
-     }
--    internal inline void assert_equal<T>(T actual,
--                                         T expected,
-+    internal inline void assert_equal<T>(T? actual,
-+                                         T? expected,
-                                          string? context = null)
-         throws TestError {
-         if ((actual == null && expected != null) ||
-@@ -107,9 +107,9 @@ namespace ValaUnit {
-      *
-      * This will only work when the values are not already boxed.
-      */
--    internal T box_value<T>(T value) {
-+    internal T? box_value<T>(T value) {
-         var type = typeof(T);
--        T boxed = value;
-+        T? boxed = value;
-         if (type == typeof(int) || type.is_enum()) {
-             int actual = (int) value;
-@@ -133,7 +133,7 @@ namespace ValaUnit {
-         return boxed;
-     }
--    internal string to_display_string<T>(T value) {
-+    internal string to_display_string<T>(T? value) {
-         var type = typeof(T);
-         var display = "";
-@@ -191,8 +191,8 @@ namespace ValaUnit {
-         );
-     }
--    private void assert_equal_enum<T>(T actual,
--                                      T expected,
-+    private void assert_equal_enum<T>(T? actual,
-+                                      T? expected,
-                                       string? context)
-         throws TestError {
-         int actual_val = (int) ((int?) actual);
-@@ -342,7 +342,7 @@ public interface ValaUnit.TestAssertions : GLib.Object {
-     /** Asserts a value is null */
--    public void assert_non_null<T>(T actual, string? context = null)
-+    public void assert_non_null<T>(T? actual, string? context = null)
-         throws TestError {
-         if (actual == null) {
-             ValaUnit.assert(
-@@ -353,7 +353,7 @@ public interface ValaUnit.TestAssertions : GLib.Object {
-     }
-     /** Asserts a value is null */
--    public void assert_is_null<T>(T actual, string? context = null)
-+    public void assert_is_null<T>(T? actual, string? context = null)
-         throws TestError {
-         if (actual != null) {
-             ValaUnit.assert(
--- 
-GitLab
-
diff --git a/geary-type-arguments.patch b/geary-type-arguments.patch
deleted file mode 100644 (file)
index 02562e3..0000000
+++ /dev/null
@@ -1,58 +0,0 @@
-From 4a7ca820b1d3d6130fedf254dc5b4cd7efb58f2c Mon Sep 17 00:00:00 2001
-From: Rico Tzschichholz <ricotz@ubuntu.com>
-Date: Sat, 8 Apr 2023 13:06:50 +0200
-Subject: [PATCH] client: Add missing type-arguments for interfaces to fix
- build with newer vala
-
----
- src/client/accounts/accounts-editor-row.vala          | 2 +-
- src/client/accounts/accounts-editor-servers-pane.vala | 6 +++---
- 2 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/src/client/accounts/accounts-editor-row.vala b/src/client/accounts/accounts-editor-row.vala
-index 6e7ac2ab9..70223d717 100644
---- a/src/client/accounts/accounts-editor-row.vala
-+++ b/src/client/accounts/accounts-editor-row.vala
-@@ -386,7 +386,7 @@ private abstract class Accounts.ServiceRow<PaneType,V> : AccountRow<PaneType,V>
- /** Interface for rows that use a validator for editable values. */
--internal interface Accounts.ValidatingRow : EditorRow {
-+internal interface Accounts.ValidatingRow<PaneType> : EditorRow<PaneType> {
-     /** The row's validator */
-diff --git a/src/client/accounts/accounts-editor-servers-pane.vala b/src/client/accounts/accounts-editor-servers-pane.vala
-index 8bd9bde1f..982acd5cf 100644
---- a/src/client/accounts/accounts-editor-servers-pane.vala
-+++ b/src/client/accounts/accounts-editor-servers-pane.vala
-@@ -694,7 +694,7 @@ private class Accounts.SaveSentRow :
- private class Accounts.ServiceHostRow :
--    ServiceRow<EditorServersPane,Gtk.Entry>, ValidatingRow {
-+    ServiceRow<EditorServersPane,Gtk.Entry>, ValidatingRow<EditorServersPane> {
-     public Components.Validator validator {
-@@ -848,7 +848,7 @@ private class Accounts.ServiceSecurityRow :
- private class Accounts.ServiceLoginRow :
--    ServiceRow<EditorServersPane,Gtk.Entry>, ValidatingRow {
-+    ServiceRow<EditorServersPane,Gtk.Entry>, ValidatingRow<EditorServersPane> {
-     public Components.Validator validator {
-@@ -972,7 +972,7 @@ private class Accounts.ServiceLoginRow :
- private class Accounts.ServicePasswordRow :
--    ServiceRow<EditorServersPane,Gtk.Entry>, ValidatingRow {
-+    ServiceRow<EditorServersPane,Gtk.Entry>, ValidatingRow<EditorServersPane> {
-     public Components.Validator validator {
--- 
-GitLab
-
index 3af66dae2eb9a298221c846e9fac7815026cbb81..d869fcded515dbbb6979754bb37cd60da2d9afd1 100644 (file)
@@ -5,15 +5,13 @@
 Summary:       Geary - mail client for GNOME 3
 Summary(pl.UTF-8):     Geary - klient pocztowy dla GNOME 3
 Name:          geary
-Version:       43.0
-Release:       2
+Version:       44.0
+Release:       1
 License:       LGPL v2.1+
 Group:         X11/Applications/Mail
-Source0:       https://download.gnome.org/sources/geary/43/%{name}-%{version}.tar.xz
-# Source0-md5: 7630b0ec6cda7991407422853ed0fb75
+Source0:       https://download.gnome.org/sources/geary/44/%{name}-%{version}.tar.xz
+# Source0-md5: f6285b9aa38933908c270e038ec3ee4c
 Patch0:                %{name}-meson.patch
-Patch1:                %{name}-type-arguments.patch
-Patch2:                %{name}-non-null.patch
 URL:           https://wiki.gnome.org/Apps/Geary
 BuildRequires: appstream-glib-devel >= 0.7.10
 BuildRequires: cairo-devel
@@ -108,8 +106,6 @@ interfejsem.
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
-%patch2 -p1
 
 %if %{without unity}
 %{__sed} -i -e '/^subdir.*messaging-menu/ d' src/client/plugin/meson.build
@@ -129,6 +125,9 @@ rm -rf $RPM_BUILD_ROOT
 
 %ninja_install -C build
 
+# not supported by glibc (as of 2.37)
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ie
+
 %find_lang %{name} --with-gnome
 
 %clean
@@ -149,7 +148,7 @@ rm -rf $RPM_BUILD_ROOT
 %doc AUTHORS COPYING.icons NEWS README.md THANKS
 %attr(755,root,root) %{_bindir}/geary
 %dir %{_libdir}/geary
-%attr(755,root,root) %{_libdir}/geary/libgeary-client-43.0.so
+%attr(755,root,root) %{_libdir}/geary/libgeary-client-44.0.so
 %dir %{_libdir}/geary/web-extensions
 %attr(755,root,root) %{_libdir}/geary/web-extensions/libgeary-web-process.so
 %dir %{_libdir}/geary/plugins
This page took 0.210029 seconds and 4 git commands to generate.