]> git.pld-linux.org Git - packages/gdsl.git/blob - gdsl.spec
- updated to 1.3 (from pld-devel-pl Mateusz Murawski)
[packages/gdsl.git] / gdsl.spec
1 Summary:        Generic Data Structures Library
2 Summary(pl):    Biblioteka podstawowych struktur danych
3 Name:           gdsl
4 Version:        1.3
5 Release:        1
6 License:        GPL v2
7 Group:          Libraries
8 Source0:        http://freesoftware.fsf.org/download/gdsl/%{name}-%{version}.tar.gz
9 # Source0-md5:  9981f1ced783e30f50247e39179706bc
10 URL:            http://www.freesoftware.fsf.org/gdsl/
11 BuildRequires:  autoconf
12 BuildRequires:  automake
13 BuildRequires:  libtool
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 GDSL (Generic Data Structures Library) is a portable and
18 OS-independant generic data structures manipulation library fully
19 written in pure ANSI C from scratch, for C programmers. Most common
20 data structures are available with powerful algorithms and hidden
21 implementation. Available structures are lists, queues, stacks, hash
22 tables, binary trees, search binary trees, red-black trees, 2D arrays,
23 and permutations.
24
25 %description -l pl
26 GDSL (Generic Data Structues Library) to przeno¶na i niezale¿na od
27 systemu operacyjnego biblioteka operacji na podstawowych strukturach
28 danych, napisana od zera w czystym ANSI C, dla programistów C.
29 Wiêkszo¶æ ogólnych struktur danych jest dostêpna wraz z potê¿nymi
30 algorytmami i ukryt± implementacj±. Dostêpne struktury to listy,
31 kolejki, stosy, tablice haszuj±ce, drzewa binarne, drzewa wyszukiwañ
32 binarnych, drzewa czerwono-czarne, tablice dwuwymiarowe i permutacje.
33
34 %package devel
35 Summary:        Header files and development documentation for Generic Data Structures Library
36 Summary(pl):    Pliki nag³ówkowe i dokumentacja do biblioteki podstawowych struktur danych
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}
39
40 %description devel
41 Header files and development documentation for Generic Data Structures
42 Library.
43
44 %description devel -l pl
45 Pliki nag³ówkowe i dokumentacja do biblioteki podstawowych struktur
46 danych.
47
48 %package static
49 Summary:        Static Generic Data Structures Library
50 Summary(pl):    Statyczna biblioteka podstawowych struktur danych
51 Group:          Development/Libraries
52 Requires:       %{name}-devel = %{version}
53
54 %description static
55 Static Generic Data Structures Library.
56
57 %description static -l pl
58 Statyczna biblioteka podstawowych struktur danych.
59
60 %prep
61 %setup -q
62
63 %build
64 rm -f missing
65 %{__libtoolize}
66 %{__aclocal}
67 %{__autoconf}
68 %{__automake}
69 %configure
70
71 %{__make}
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75
76 %{__make} install DESTDIR=$RPM_BUILD_ROOT
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %post   -p /sbin/ldconfig
82 %postun -p /sbin/ldconfig
83
84 %files
85 %defattr(644,root,root,755)
86 %doc AUTHORS
87 %attr(755,root,root) %{_libdir}/*.so.*.*
88 %{_bindir}/%{name}-config
89
90 %files devel
91 %defattr(644,root,root,755)
92 %doc src/examples/* README TODO doc/html/*.html doc/html/*.css doc/html/*.png
93 %attr(755,root,root) %{_libdir}/*.so
94 %{_libdir}/*.la
95 %dir %{_includedir}/gdsl
96 %{_includedir}/gdsl/*.h
97 %{_includedir}/*.h
98
99 %{_mandir}/man3/*
100
101 %files static
102 %defattr(644,root,root,755)
103 %attr(644,root,root) %{_libdir}/*.a
This page took 0.07688 seconds and 3 git commands to generate.