]> git.pld-linux.org Git - packages/gdome2.git/blob - gdome2.spec
- compilation fix
[packages/gdome2.git] / gdome2.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        DOM level2 library for accessing XML files
6 Summary(pl.UTF-8):      Biblioteka dostępu do plików XML, DOM poziom 2
7 Name:           gdome2
8 Version:        0.8.1
9 Release:        10
10 License:        LGPL
11 Group:          Libraries
12 Source0:        http://gdome2.cs.unibo.it/tarball/%{name}-%{version}.tar.gz
13 # Source0-md5:  bfc114e59eec50cbda8e4ece751ff022
14 Patch0:         %{name}-glib2.patch
15 Patch1:         %{name}-build_fix.patch
16 URL:            http://gdome2.cs.unibo.it/
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  glib2-devel >= 2.2.0
20 BuildRequires:  libtool
21 BuildRequires:  libxml2-devel >= 2.4.26
22 BuildRequires:  pkgconfig
23 Requires:       libxml2 >= 2.4.26
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 gdome2 is a fast, light and complete DOM level2 implementation based
28 on libxml2. Although it has been written for the GNOME project, it can
29 be used stand-alone.
30
31 A DOM implementation (also called a host implementation) is what makes
32 a parsed XML or HTML document available for processing via the DOM
33 interface.
34
35 gdome2 currently supports the "Core", "XML", "Events" and
36 "MutationEvents" modules from the DOM2 Recommendation (see
37 http://www.w3.org/TR/DOM-Level-2-Core/ and
38 http://www.w3.org/TR/DOM-Level-2-Events/), and is supposed to become a
39 full implementation of all the DOM Level2 standard.
40
41 Now gdome2 also partially supports the XPath module from the DOM level
42 3 drafts.
43
44 %description -l pl.UTF-8
45 gdome2 jest szybką, lekką i kompletną implementacją poziomu 2 DOM
46 opartą o libxml2. Pomimo, że gdome2 zostało napisane z myślą o
47 projekcie GNOME, może być używane samodzielnie.
48
49 Implementacja DOM (zwana również implementacją hosta) udostępnia
50 przeanalizowany składniowo dokument XML lub HTML w celu dalszego
51 jego przetwarzania poprzez interfejs DOM.
52
53 gdome2 w chwili obecnej wspiera następujące moduły rekomendacji DOM2:
54 "Core", "XML", "Events" oraz "MutationEvents" (więcej informacji można
55 uzyskać pod adresem http://www.w3.org/TR/DOM-Level-2-Core/ oraz
56 http://www.w3.org/TR/DOM-Level-2-Events/), a w przyszłości ma zostać
57 pełną implementacją standardu poziomu 2 DOM.
58
59 gdome2 wspiera również częściowo poziom 3 DOM, konkretnie XPath.
60
61 %package devel
62 Summary:        Development files for gdome2
63 Summary(pl.UTF-8):      Pliki nagłówkowe gdome2
64 Group:          Development/Libraries
65 Requires:       %{name} = %{version}-%{release}
66 Requires:       glib2-devel >= 2.2.0
67 Requires:       libxml2-devel >= 2.4.26
68
69 %description devel
70 This package contains the header files and configuration scripts for
71 developing with gdome2.
72
73 gdome2 is a fast, light and complete DOM level2 implementation based
74 on libxml2. Although it has been written for the GNOME project, it can
75 be used stand-alone.
76
77 A DOM implementation (also called a host implementation) is what makes
78 a parsed XML or HTML document available for processing via the DOM
79 interface.
80
81 gdome2 currently supports the "Core", "XML", "Events" and
82 "MutationEvents" modules from the DOM2 Recommendation (see
83 http://www.w3.org/TR/DOM-Level-2-Core/ and
84 http://www.w3.org/TR/DOM-Level-2-Events/), and is supposed to become a
85 full implementation of all the DOM Level2 standard.
86
87 Now gdome2 also partially supports the XPath module from the DOM level
88 3 drafts.
89
90 %description devel -l pl.UTF-8
91 Pakiet ten zawiera pliki nagłówkowe oraz skrypty konfiguracyjne
92 potrzebne do rozwijania oprogramowania opartego o gdome2.
93
94 gdome2 jest szybką, lekką i kompletną implementacją poziomu 2 DOM
95 opartą o libxml2. Pomimo, że gdome2 zostało napisane z myślą o
96 projekcie GNOME, może być używane samodzielnie.
97
98 Implementacja DOM (zwana również implementacją hosta) udostępnia
99 przeanalizowany składniowo dokument XML lub HTML w celu dalszego
100 jego przetwarzania poprzez interfejs DOM.
101
102 gdome2 w chwili obecnej wspiera następujące moduły rekomendacji DOM2:
103 "Core", "XML", "Events" oraz "MutationEvents" (więcej informacji można
104 uzyskać pod adresem http://www.w3.org/TR/DOM-Level-2-Core/ oraz
105 http://www.w3.org/TR/DOM-Level-2-Events/), a w przyszłości ma zostać
106 pełną implementacją standardu poziomu 2 DOM.
107
108 gdome2 wspiera również częściowo poziom 3 DOM, konkretnie XPath.
109
110 %package static
111 Summary:        Static libraries for gdome2
112 Summary(pl.UTF-8):      Biblioteki statyczne dla gdome2
113 Group:          Development/Libraries
114 Requires:       %{name}-devel = %{version}-%{release}
115
116 %description static
117 This package contains static libraries for developing with gdome2.
118
119 %description static -l pl.UTF-8
120 Pakiet ten zawiera statyczne biblioteki potrzebne do rozwijania
121 oprogramowania opartego o gdome2.
122
123 %prep
124 %setup -q
125 %patch0 -p1
126 %patch1 -p1
127
128 echo 'AM_DEFUN([AM_PATH_GLIB], [$3])' >> acinclude.m4
129
130 %build
131 %{__libtoolize}
132 %{__aclocal}
133 %{__autoconf}
134 %{__automake}
135 %configure \
136         %{!?with_static_libs:--disable-static}
137
138 %{__make}
139
140 %install
141 rm -rf $RPM_BUILD_ROOT
142
143 %{__make} install \
144         DESTDIR=$RPM_BUILD_ROOT
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post   -p /sbin/ldconfig
150 %postun -p /sbin/ldconfig
151
152 %files
153 %defattr(644,root,root,755)
154 %doc AUTHORS MAINTAINERS ChangeLog README
155 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
156
157 %files devel
158 %defattr(644,root,root,755)
159 %doc gtk-doc/html/*.html
160 %attr(755,root,root) %{_bindir}/gdome-config
161 %attr(755,root,root) %{_libdir}/lib*.so
162 %{_libdir}/lib*.la
163 %attr(755,root,root) %{_libdir}/*.sh
164 %{_includedir}/libgdome
165 %{_mandir}/man1/gdome-config.1*
166 %{_aclocaldir}/%{name}.m4
167 %{_pkgconfigdir}/%{name}.pc
168
169 %if %{with static_libs}
170 %files static
171 %defattr(644,root,root,755)
172 %{_libdir}/*.a
173 %endif
This page took 0.916985 seconds and 3 git commands to generate.