]> git.pld-linux.org Git - packages/gdm2.20.git/blob - gdm.spec
- removed all Group fields translations (oure rpm now can handle translating
[packages/gdm2.20.git] / gdm.spec
1 Summary:        GNOME Display Manager
2 Summary(es):    Administrador de Entrada del GNOME
3 Summary(pl):    gdm
4 Summary(pt_BR): Gerenciador de Entrada do GNOME
5 Name:           gdm
6 Version:        2.2.5.4
7 Release:        3
8 Epoch:          1
9 License:        LGPL/GPL
10 Group:          X11/Applications
11 Source0:        ftp://ftp.gnome.org/pub/GNOME/stable/sources/%{name}/%{name}-%{version}.tar.bz2
12 Source1:        %{name}.pamd
13 Source2:        %{name}.init
14 Source3:        %{name}.conf
15 Patch0:         %{name}-xdmcp.patch
16 Patch1:         %{name}-am_fixes.patch
17 Patch2:         %{name}-permissions.patch
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  esound-devel
21 BuildRequires:  gdk-pixbuf-devel
22 BuildRequires:  gettext-devel
23 BuildRequires:  gnome-libs-devel
24 BuildRequires:  gtk+-devel
25 BuildRequires:  libglade-devel
26 BuildRequires:  libtool
27 BuildRequires:  libxml-devel
28 BuildRequires:  perl-modules
29 BuildRequires:  scrollkeeper
30 BuildRequires:  intltool >= 0.14
31 Requires:       gnome-libs >= 1.0.0
32 Requires:       which
33 Requires:       /usr/X11R6/bin/sessreg
34 PreReq:         scrollkeeper
35 PreReq:         shadow
36 PreReq:         /sbin/chkconfig
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38 Obsoletes:      xdm kdm wdm
39
40 %define         _prefix         /usr/X11R6
41 %define         _bindir         %{_prefix}/bin
42 %define         _datadir        %{_prefix}/share
43 %define         _sbindir        %{_prefix}/sbin
44 %define         _mandir         %{_prefix}/man
45 %define         _localstatedir  /var/lib
46 %define         _sysconfdir     /etc/X11
47 %define         _omf_dest_dir   %(scrollkeeper-config --omfdir)
48
49 %description
50 Gdm (the GNOME Display Manager) is a highly configurable
51 reimplementation of xdm, the X Display Manager. Gdm allows you to log
52 into your system with the X Window System running and supports running
53 several different X sessions on your local machine at the same time.
54
55 %description -l es
56 Administrador de Entrada del GNOME.
57
58 %description -l pl
59 Gdm jest wysokokonfigurowaln± reimplementacj± xdma. Gdm pozwala
60 logowaæ siê do systemu z poziomu X11 i wspiera jednoczesn± pracê kilku
61 ró¿nych Xsesji na lokalnej maszynie.
62
63 %description -l pt_BR
64 Gerenciador de Entrada do GNOME.
65
66 %package Xnest
67 Summary:        Xnest (ie embedded X) server for GDM
68 Summary(pl):    Serwer Xnest dla GDM
69 Group:          X11/Applications
70 Requires:       %{name} = %{version}
71 Requires:       XFree86-Xnest
72
73 %description Xnest
74 This package add support for Xnest server in gdm.
75
76 %description Xnest -l pl
77 Ten pakiet dodaje do gdm wsparcie dla Xnest.
78
79 %prep
80 %setup -q
81 %patch0 -p1
82 %patch1 -p1
83 %patch2 -p1
84
85 %build
86 rm -f missing
87 libtoolize --copy --force
88 gettextize --copy --force
89 aclocal -I %{_aclocaldir}/gnome
90 autoconf
91 automake -a -c
92 %configure \
93         --with-xinerama=yes \
94         --with-xdmcp=yes \
95         --with-tcp-wrappers=yes \
96         --disable-console-helper
97
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,pam.d,security}
103
104 %{__make} install \
105         DESTDIR=$RPM_BUILD_ROOT \
106         Settingsdir=%{_applnkdir}/Settings/GNOME \
107         Systemdir=%{_applnkdir}/System \
108         omf_dest_dir=%{_omf_dest_dir}/omf/%{name}
109
110 install %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/gdm
111 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/gdm
112 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/gdm.conf
113 touch $RPM_BUILD_ROOT/etc/security/blacklist.gdm
114
115 mv $RPM_BUILD_ROOT%{_applnkdir}/System/gdmconfig.desktop \
116         $RPM_BUILD_ROOT%{_applnkdir}/Settings/GNOME/
117
118 gzip -9nf AUTHORS ChangeLog NEWS README TODO
119
120 %find_lang %{name} --all-name --with-gnome
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %pre
126 /usr/sbin/groupadd -g 55 -r -f xdm
127
128 if [ -z "`id -u xdm 2>/dev/null`" ]; then
129         /usr/sbin/useradd -u 55 -r -d /dev/null -s /bin/false -c 'X Display Manager' -g xdm xdm 1>&2
130 fi
131
132 %post
133 /sbin/chkconfig --add gdm
134 if [ -f /var/lock/subsys/gdm ]; then
135         echo "Run \"/etc/rc.d/init.d/gdm restart\" to restart gdm." >&2
136 else
137         echo "Run \"/etc/rc.d/init.d/gdm start\" to start gdm." >&2
138 fi
139 /usr/bin/scrollkeeper-update
140
141 %preun
142 if [ "$1" = "0" ]; then
143         if [ -f /var/lock/subsys/gdm ]; then
144                 /etc/rc.d/init.d/gdm stop >&2
145         fi
146         /sbin/chkconfig --del gdm
147 fi
148
149 %postun
150 if [ "$1" = "0" ]; then
151         if [ -n "`id -u xdm 2>/dev/null`" ]; then
152                 /usr/sbin/userdel xdm
153         fi
154         /usr/sbin/groupdel xdm
155 fi
156 /usr/bin/scrollkeeper-update
157
158 %files -f %{name}.lang
159 %defattr(644,root,root,755)
160 %doc *.gz
161 %attr(755,root,root) %{_bindir}/gdm
162 %attr(755,root,root) %{_bindir}/gdmchooser
163 %attr(755,root,root) %{_bindir}/gdmconfig
164 %attr(755,root,root) %{_bindir}/gdmflexiserver
165 %attr(755,root,root) %{_bindir}/gdmlogin
166 %attr(755,root,root) %{_bindir}/gdmmktemp
167 %attr(755,root,root) %{_bindir}/gdmphotosetup
168 %attr(755,root,root) %{_sbindir}/*
169 %attr(755,root,root) %config %{_sysconfdir}/gdm/Init
170 %attr(755,root,root) %config %{_sysconfdir}/gdm/PreSession
171 %attr(755,root,root) %config %{_sysconfdir}/gdm/Sessions
172 %attr(755,root,root) %config %{_sysconfdir}/gdm/PostSession
173 %attr(755,root,root) %config %{_sysconfdir}/gdm/gnomerc
174 %attr(755,root,root) %config %{_sysconfdir}/gdm/XKeepsCrashing
175 %config %{_sysconfdir}/gdm/factory-gdm.conf
176 %config %{_sysconfdir}/gdm/gdm.conf
177 %config %{_sysconfdir}/gdm/locale.alias
178 %attr(755,root,root) %dir %{_sysconfdir}/gdm
179 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/pam.d/gdm
180 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/security/blacklist.gdm
181 %attr(770,root,xdm) /var/lib/gdm
182 %attr(754,root,root) /etc/rc.d/init.d/gdm
183 %{_pixmapsdir}/*
184 # these lines to devel subpackage?
185 %{_applnkdir}/Settings/GNOME/*
186 %{_applnkdir}/System/gdmflexiserver.desktop
187 %{_datadir}/gdm
188 %{_omf_dest_dir}/omf/%{name}
189
190 %files Xnest
191 %defattr(644,root,root,755)
192 %attr(755,root,root) %{_bindir}/gdmXnestchooser
193 %{_applnkdir}/System/gdmflexiserver-xnest.desktop
This page took 0.042047 seconds and 3 git commands to generate.