]> git.pld-linux.org Git - packages/gdm2.20.git/blob - gdm.spec
- adapterized and made spec %%debug ready or added using %%rpm*flags macros
[packages/gdm2.20.git] / gdm.spec
1 Summary:        GNOME Display Manager
2 Summary(pl):    gdm
3 Name:           gdm
4 Version:        2.0beta4
5 Release:        6
6 Source0:        ftp://socsci.auc.dk/~mkp/gdm/%{name}-%{version}.tar.gz
7 Source1:        %{name}.pamd
8 Source2:        %{name}.init
9 Patch0:         %{name}-config.patch
10 Patch1:         %{name}-gnomerc.patch
11 Patch2:         %{name}-chpass.patch
12 Patch3:         %{name}-daemonfixes.patch
13 Patch4:         %{name}-dumberrmsg.patch
14 Patch5:         %{name}-fdleak.patch
15 Patch6:         %{name}-fixmessages.patch
16 Patch7:         %{name}-i18n.patch
17 Patch8:         %{name}-loopofdeath.patch
18 Patch9:         %{name}-no_questions_asked.patch
19 Patch10:        %{name}-pipewrite.patch
20 Patch11:        %{name}-rhlang.patch
21 Patch12:        %{name}-system-auth.patch
22 Patch13:        %{name}-tolower.patch
23 Patch14:        %{name}-usershell.patch
24 Patch15:        %{name}-nonbash-shell.patch
25 Patch16:        %{name}-xdmcp.patch
26 Patch17:        %{name}-ypconfigure.patch
27 Group:          X11/Applications
28 Group(de):      X11/Applikationen
29 Group(pl):      X11/Aplikacje
30 License:        LGPL/GPL
31 Prereq:         /usr/sbin/groupadd
32 Prereq:         /usr/sbin/groupdel
33 Prereq:         /usr/sbin/useradd
34 Prereq:         /usr/sbin/userdel
35 Prereq:         /sbin/chkconfig
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37 BuildRequires:  gnome-libs-devel
38 BuildRequires:  gtk+-devel
39 BuildRequires:  esound-devel
40 Requires:       gnome-libs >= 1.0.0
41 Requires:       which
42 Requires:       /usr/X11R6/bin/sessreg
43 Obsoletes:      xdm kdm wdm
44
45 %define         _prefix         /usr/X11R6
46 %define         _mandir         %{_prefix}/man
47 %define         _sysconfdir     /etc/X11
48
49 %description 
50 gdm manages local and remote displays and provides the user with a
51 graphical login window.
52
53 %description -l pl
54 gdm zarz±dza lokalnymi i zdalnymi X serwerami i udostêpnia
55 u¿ytkownikowi graficzne okienko logowania.
56
57 %prep
58 %setup -q
59 %patch0 -p1     
60 %patch1 -p1     
61 %patch2 -p1     
62 %patch3 -p1     
63 %patch4 -p1     
64 %patch5 -p1     
65 %patch6 -p1     
66 %patch7 -p1     
67 %patch8 -p1     
68 %patch9 -p1     
69 %patch10 -p1
70 %patch11 -p1
71 %patch12 -p1
72 %patch13 -p1
73 %patch14 -p1
74 %patch15 -p1
75 %patch16 -p1
76 %patch17 -p1
77
78 %build
79 CFLAGS="%{rpmcflags}" \
80 ./configure %{_target_platform} \
81         --prefix=%{_prefix} \
82         --sysconfdir=%{_sysconfdir} \
83         --localstatedir=/var/lib
84 %{__make}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88
89 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d/
90
91 install -d $RPM_BUILD_ROOT{%{_prefix},/etc/{pam.d,security}}
92 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/gdm
93
94 %{__make} install prefix=$RPM_BUILD_ROOT%{_prefix} \
95         sysconfdir=$RPM_BUILD_ROOT%{_sysconfdir} \
96         localstatedir=$RPM_BUILD_ROOT/var/lib
97
98 sed -e "s#$RPM_BUILD_ROOT##g" config/gnomerc >config/gnomerc.X
99 install config/gnomerc.X $RPM_BUILD_ROOT%{_sysconfdir}/gdm/gnomerc
100
101 sed -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_sysconfdir}/gdm/Sessions/Gnome \
102         > $RPM_BUILD_ROOT%{_sysconfdir}/gdm/Sessions/Gnome.X
103
104 mv -f $RPM_BUILD_ROOT%{_sysconfdir}/gdm/Sessions/Gnome.X \
105         $RPM_BUILD_ROOT%{_sysconfdir}/gdm/Sessions/Gnome
106
107 install %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/gdm
108 touch $RPM_BUILD_ROOT/etc/security/blacklist.gdm
109
110 gzip -9nf AUTHORS ChangeLog NEWS README TODO RELEASENOTES
111
112 %find_lang gdm
113
114 %pre
115 /usr/sbin/groupadd -g 55 -r -f xdm
116
117 if [ -z "`id -u xdm 2>/dev/null`" ]; then
118         /usr/sbin/useradd -u 55 -r -d /dev/null -s /bin/false -c 'X Display Manager' -g xdm xdm 1>&2
119 fi
120
121 %post
122 /sbin/chkconfig --add gdm
123 if [ -f /var/lock/subsys/gdm ]; then
124         /etc/rc.d/init.d/gdm restart >&2
125 else
126         echo "Run \"/etc/rc.d/init.d/gdm start\" to start gdm." >&2
127 fi
128
129 %preun
130 if [ -f /var/lock/subsys/gdm ]; then
131                  /etc/rc.d/init.d/gdm stop >&2
132 fi
133 /sbin/chkconfig --del gdm
134
135 %postun
136 if [ "$1" = "0" ]; then
137
138         if [ -n "`id -u xdm 2>/dev/null`" ]; then
139                 /usr/sbin/userdel xdm
140         fi
141         
142         /usr/sbin/groupdel xdm
143
144 fi
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %files -f gdm.lang
150 %defattr(644,root,root,755)
151 %doc {AUTHORS,ChangeLog,NEWS,README,TODO}.gz
152 %attr(775,root,xdm) %{_bindir}/gdm
153 %attr(775,root,xdm) %{_bindir}/gdmlogin
154 %attr(775,root,xdm) %{_bindir}/gdmchooser
155 %attr(775,root,xdm) %config %{_sysconfdir}/gdm/Init
156 %attr(775,root,xdm) %config %{_sysconfdir}/gdm/PreSession
157 %attr(775,root,xdm) %config %{_sysconfdir}/gdm/Sessions
158 %attr(775,root,xdm) %config %{_sysconfdir}/gdm/PostSession
159 %attr(775,root,xdm) %config %{_sysconfdir}/gdm/gnomerc
160 %attr(664,root,xdm) %config %{_sysconfdir}/gdm/gdm.conf
161 %attr(664,root,xdm) %config %{_sysconfdir}/gdm/locale.alias
162 %attr(775,root,xdm) %dir %{_sysconfdir}/gdm
163 %attr(640,root,root) %config %verify(not size mtime md5) /etc/pam.d/gdm
164 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/security/blacklist.gdm
165 %attr(750,xdm,xdm) /var/lib/gdm
166 %attr(754,root,root) /etc/rc.d/init.d/gdm
167 %{_pixmapsdir}/*
This page took 0.04762 seconds and 3 git commands to generate.