]> git.pld-linux.org Git - packages/gdm2.20.git/blob - gdm.spec
26487b29ded65187b48b3bd73263cb1487348a0a
[packages/gdm2.20.git] / gdm.spec
1 Summary:        GNOME Display Manager
2 Summary(es):    Administrador de Entrada del GNOME
3 Summary(pl):    gdm
4 Summary(pt_BR): Gerenciador de Entrada do GNOME
5 Name:           gdm
6 Version:        2.2.5.4
7 Release:        2
8 Epoch:          1
9 License:        LGPL/GPL
10 Group:          X11/Applications
11 Group(de):      X11/Applikationen
12 Group(es):      X11/Aplicaciones
13 Group(pl):      X11/Aplikacje
14 Group(pt_BR):   X11/Aplicações
15 Group(pt):      X11/Aplicações
16 Source0:        ftp://ftp.gnome.org/pub/GNOME/stable/sources/%{name}/%{name}-%{version}.tar.bz2
17 Source1:        %{name}.pamd
18 Source2:        %{name}.init
19 Source3:        %{name}.conf
20 Patch0:         %{name}-xdmcp.patch
21 Patch1:         %{name}-am_fixes.patch
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 BuildRequires:  esound-devel
25 BuildRequires:  gdk-pixbuf-devel
26 BuildRequires:  gettext-devel
27 BuildRequires:  gnome-libs-devel
28 BuildRequires:  gtk+-devel
29 BuildRequires:  libglade-devel
30 BuildRequires:  libtool
31 BuildRequires:  libxml-devel
32 BuildRequires:  perl-modules
33 BuildRequires:  scrollkeeper
34 Requires:       gnome-libs >= 1.0.0
35 Requires:       which
36 Requires:       /usr/X11R6/bin/sessreg
37 Prereq:         scrollkeeper
38 Prereq:         shadow
39 Prereq:         /sbin/chkconfig
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41 Obsoletes:      xdm kdm wdm
42
43 %define         _prefix         /usr/X11R6
44 %define         _bindir         %{_prefix}/bin
45 %define         _datadir        %{_prefix}/share
46 %define         _sbindir        %{_prefix}/sbin
47 %define         _mandir         %{_prefix}/man
48 %define         _localstatedir  /var/lib
49 %define         _sysconfdir     /etc/X11
50 %define         _omf_dest_dir   %(scrollkeeper-config --omfdir)
51
52 %description 
53 gdm manages local and remote displays and provides the user with a
54 graphical login window.
55
56 %description -l es
57 Administrador de Entrada del GNOME.
58
59 %description -l pl
60 gdm zarz±dza lokalnymi i zdalnymi X serwerami i udostêpnia
61 u¿ytkownikowi graficzne okienko logowania.
62
63 %description -l pt_BR
64 Gerenciador de Entrada do GNOME.
65
66 %package Xnest
67 Summary:        Xnest (ie embedded X) server for GDM
68 Group:          X11/Applications
69 Group(de):      X11/Applikationen
70 Group(es):      X11/Aplicaciones
71 Group(pl):      X11/Aplikacje
72 Group(pt_BR):   X11/Aplicações
73 Group(pt):      X11/Aplicações
74 Requires:       %{name} = %{version}
75 Requires:       XFree86-Xnest
76
77 %description Xnest
78 Gdm (the GNOME Display Manager) is a highly configurable
79 reimplementation of xdm, the X Display Manager. Gdm allows you to log
80 into your system with the X Window System running and supports running
81 several different X sessions on your local machine at the same time.
82
83 This package add support for Xnest server in gdm.
84
85 %prep
86 %setup -q
87 %patch0 -p1
88 %patch1 -p1
89
90 %build
91 rm -f missing
92 libtoolize --copy --force
93 gettextize --copy --force
94 aclocal -I %{_aclocaldir}/gnome
95 autoconf
96 automake -a -c
97 %configure \
98         --with-xinerama=yes \
99         --with-xdmcp=yes \
100         --with-tcp-wrappers=yes \
101         --disable-console-helper
102
103 %{__make}
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,pam.d,security}
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT \
111         Settingsdir=%{_applnkdir}/Settings/GNOME \
112         Systemdir=%{_applnkdir}/System \
113         omf_dest_dir=%{_omf_dest_dir}/omf/%{name}
114
115 install %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/gdm
116 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/gdm
117 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/gdm.conf
118 touch $RPM_BUILD_ROOT/etc/security/blacklist.gdm
119
120 mv $RPM_BUILD_ROOT%{_applnkdir}/System/gdmconfig.desktop \
121         $RPM_BUILD_ROOT%{_applnkdir}/Settings/GNOME/
122
123 gzip -9nf AUTHORS ChangeLog NEWS README TODO
124
125 %find_lang %{name} --all-name --with-gnome
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %pre
131 /usr/sbin/groupadd -g 55 -r -f xdm
132
133 if [ -z "`id -u xdm 2>/dev/null`" ]; then
134         /usr/sbin/useradd -u 55 -r -d /dev/null -s /bin/false -c 'X Display Manager' -g xdm xdm 1>&2
135 fi
136
137 %post
138 /sbin/chkconfig --add gdm
139 if [ -f /var/lock/subsys/gdm ]; then
140         /etc/rc.d/init.d/gdm restart >&2
141 else
142         echo "Run \"/etc/rc.d/init.d/gdm start\" to start gdm." >&2
143 fi
144 /usr/bin/scrollkeeper-update
145
146 %preun
147 if [ "$1" = "0" ]; then
148         if [ -f /var/lock/subsys/gdm ]; then
149                  /etc/rc.d/init.d/gdm stop >&2
150         fi
151         /sbin/chkconfig --del gdm
152 fi
153
154 %postun
155 if [ "$1" = "0" ]; then
156         if [ -n "`id -u xdm 2>/dev/null`" ]; then
157                 /usr/sbin/userdel xdm
158         fi
159         /usr/sbin/groupdel xdm
160 fi
161 /usr/bin/scrollkeeper-update
162
163 %files -f %{name}.lang
164 %defattr(644,root,root,755)
165 %doc *.gz
166 %attr(755,root,root) %{_bindir}/gdm
167 %attr(755,root,root) %{_bindir}/gdmchooser
168 %attr(755,root,root) %{_bindir}/gdmconfig
169 %attr(755,root,root) %{_bindir}/gdmflexiserver
170 %attr(755,root,root) %{_bindir}/gdmlogin
171 %attr(755,root,root) %{_bindir}/gdmmktemp
172 %attr(755,root,root) %{_bindir}/gdmphotosetup
173 %attr(755,root,root) %{_sbindir}/*
174 %attr(755,root,root) %config %{_sysconfdir}/gdm/Init
175 %attr(755,root,root) %config %{_sysconfdir}/gdm/PreSession
176 %attr(755,root,root) %config %{_sysconfdir}/gdm/Sessions
177 %attr(755,root,root) %config %{_sysconfdir}/gdm/PostSession
178 %attr(755,root,root) %config %{_sysconfdir}/gdm/gnomerc
179 %attr(755,root,root) %config %{_sysconfdir}/gdm/XKeepsCrashing
180 %config %{_sysconfdir}/gdm/factory-gdm.conf
181 %config %{_sysconfdir}/gdm/gdm.conf
182 %config %{_sysconfdir}/gdm/locale.alias
183 %attr(755,root,root) %dir %{_sysconfdir}/gdm
184 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/pam.d/gdm
185 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/security/blacklist.gdm
186 %attr(750,xdm,xdm)  /var/lib/gdm
187 %attr(754,root,root) /etc/rc.d/init.d/gdm
188 %{_pixmapsdir}/*
189 # these lines to devel subpackage?
190 %{_applnkdir}/Settings/GNOME/*
191 %{_applnkdir}/System/gdmflexiserver.desktop
192 %{_datadir}/gdm
193 %{_omf_dest_dir}/omf/%{name}
194
195 %files Xnest
196 %defattr(644,root,root,755)
197 %attr(755,root,root) %{_bindir}/gdmXnestchooser
198 %{_applnkdir}/System/gdmflexiserver-xnest.desktop
This page took 0.028478 seconds and 2 git commands to generate.