]> git.pld-linux.org Git - packages/gdl.git/blobdiff - gdl.spec
- updated to 3.40.0
[packages/gdl.git] / gdl.spec
index 7d4406c5d5b060e0bc3b152172c1bdc2031a8152..8f91b77641c18dcac5e89363c7fd4279953f7991 100644 (file)
--- a/gdl.spec
+++ b/gdl.spec
@@ -1,47 +1,46 @@
-Summary:       GNOME Devtool Libraries
-Summary(pl.UTF-8):     Biblioteki GNOME Devtool
+#
+# Conditional build:
+%bcond_without static_libs     # static library
+
+Summary:       GNOME Devtools Library
+Summary(pl.UTF-8):     Biblioteka GNOME Devtools Library
 Name:          gdl
-Version:       3.2.0
+Version:       3.40.0
 Release:       1
-License:       GPL v2+
+License:       LGPL v2.1+
 Group:         Libraries
-Source0:       http://ftp.gnome.org/pub/GNOME/sources/gdl/3.2/%{name}-%{version}.tar.xz
-# Source0-md5: 7301c3409e392f013eabd7b6478ec149
+Source0:       https://download.gnome.org/sources/gdl/3.40/%{name}-%{version}.tar.xz
+# Source0-md5: 21df1254b49b74a498feb99be57364d0
+URL:           https://gitlab.gnome.org/GNOME/gdl
 BuildRequires: autoconf >= 2.65
-BuildRequires: automake
-BuildRequires: docbook-dtd412-xml
-BuildRequires: gettext-devel
+BuildRequires: automake >= 1:1.10
+BuildRequires: docbook-dtd43-xml
+BuildRequires: gettext-tools
 BuildRequires: gobject-introspection-devel >= 0.10.0
 BuildRequires: gtk+3-devel >= 3.0.0
 BuildRequires: gtk-doc >= 1.4
-BuildRequires: intltool >= 0.40.0
+BuildRequires: intltool >= 0.40.4
 BuildRequires: libtool
 BuildRequires: libxml2-devel >= 1:2.6.26
 BuildRequires: pkgconfig
-# sr@Latn vs. sr@latin
-Conflicts:     glibc-misc < 6:2.7
+BuildRequires: rpm-build >= 4.6
+BuildRequires: tar >= 1:1.22
+BuildRequires: xz
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-This package contains components and libraries that are intended to be
-shared between GNOME development tools, including gnome-debug,
-gnome-build, and anjuta2. The current pieces of GDL include: a symbol
-browser bonobo component (symbol-browser-control), a docking widget
-(gdl), a utility library that also contains the stubs and skels for
-the symbol browser and text editor components (gdl, idl).
+The GNOME Devtools Library package provides a docking system and
+several utilities useful to GNOME development tools and GNOME
+applications in general.
 
 %description -l pl.UTF-8
-Ten pakiet zawiera komponenty i biblioteki zaprojektowane jako wspólne
-dla różnych narzędzi programistycznych GNOME, takich jak: gnome-debug,
-gnome-build i anjuta2. Aktualnie GDL zawiera: przeglądarkę symboli
-jako komponent bonobo (symbol-browser-control), dokowany element
-interfejsu graficznego (gdl), bibliotekę narzędzi zawierającą także
-szkielety dla przeglądarki symboli i komponentów edytora tekstu (gdl,
-idl).
+Pakiet GNOME Devtools Library zapewnia system dokujący oraz kilka
+narzędzi przydatnych w narzędziach programistycznych GNOME oraz
+ogólnie aplikacjach GNOME.
 
 %package devel
 Summary:       Header files for gdl development
-Summary(pl.UTF-8):     Pliki nagłówkowe do biblioteki gdl
+Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki gdl
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 Requires:      gtk+3-devel >= 3.0.0
@@ -56,22 +55,23 @@ Pakiet zawiera pliki nagłówkowe niezbędne do kompilowania programów
 używających bibliotek gdl.
 
 %package static
-Summary:       Static libraries for gdl development
-Summary(pl.UTF-8):     Statyczne biblioteki gdl
+Summary:       Static gdl library
+Summary(pl.UTF-8):     Statyczna biblioteka gdl
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
-This package contains the static gdl libraries.
+This package contains the static gdl library.
 
 %description static -l pl.UTF-8
-Pakiet zawiera statyczne biblioteki gdl.
+Pakiet zawiera statyczną bibliotekę gdl.
 
 %package apidocs
 Summary:       gdl library API documentation
 Summary(pl.UTF-8):     Dokumentacja API biblioteki gdl
 Group:         Documentation
 Requires:      gtk-doc-common
+BuildArch:     noarch
 
 %description apidocs
 gdl library API documentation.
@@ -83,7 +83,7 @@ Dokumentacja API biblioteki gdl.
 %setup -q
 
 %build
-%{__glib_gettextize}
+#{__glib_gettextize}
 %{__gtkdocize}
 %{__intltoolize}
 %{__libtoolize}
@@ -92,10 +92,10 @@ Dokumentacja API biblioteki gdl.
 %{__autoheader}
 %{__automake}
 %configure \
-       --disable-silent-rules \
-       --with-html-dir=%{_gtkdocdir} \
        --enable-gtk-doc \
-       --enable-static
+       --disable-silent-rules \
+       %{?with_static_libs:--enable-static} \
+       --with-html-dir=%{_gtkdocdir}
 
 %{__make}
 
@@ -117,11 +117,10 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -f %{name}-3.lang
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog NEWS README
+%doc AUTHORS ChangeLog MAINTAINERS NEWS README
 %attr(755,root,root) %{_libdir}/libgdl-3.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libgdl-3.so.1
+%attr(755,root,root) %ghost %{_libdir}/libgdl-3.so.5
 %{_libdir}/girepository-1.0/Gdl-3.typelib
-%{_datadir}/gdl-3
 
 %files devel
 %defattr(644,root,root,755)
@@ -130,9 +129,11 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/libgdl-3.0
 %{_pkgconfigdir}/gdl-3.0.pc
 
+%if %{with static_libs}
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/libgdl-3.a
+%endif
 
 %files apidocs
 %defattr(644,root,root,755)
This page took 0.057265 seconds and 4 git commands to generate.