]> git.pld-linux.org Git - packages/gdl.git/blobdiff - gdl.spec
noarch apidoc
[packages/gdl.git] / gdl.spec
index 08c56e0ede525bf78552a080840267e64716b75f..424e84b7987ad306a12dfddb43bd4fc2e4497385 100644 (file)
--- a/gdl.spec
+++ b/gdl.spec
@@ -1,18 +1,24 @@
-Summary:       GNOME Devtool Libraries
-Summary(pl.UTF-8):     Biblioteki GNOME Devtool
+#
+# Conditional build:
+%bcond_without static_libs     # static library
+
+Summary:       GNOME Devtools Library
+Summary(pl.UTF-8):     Biblioteka GNOME Devtools Library
 Name:          gdl
-Version:       2.28.0
+Version:       3.18.0
 Release:       2
-License:       GPL v2+
+License:       LGPL v2.1+
 Group:         Libraries
-Source0:       http://ftp.gnome.org/pub/GNOME/sources/gdl/2.28/%{name}-%{version}.tar.bz2
-# Source0-md5: fb0030d3a81fd52932f9cba09e4ce1e0
-BuildRequires: autoconf >= 2.53
-BuildRequires: automake
-BuildRequires: gettext-devel
-BuildRequires: gtk+2-devel >= 2:2.16.0
+Source0:       http://ftp.gnome.org/pub/GNOME/sources/gdl/3.18/%{name}-%{version}.tar.xz
+# Source0-md5: 25f2e50969406563b78c8ad4571ef826
+BuildRequires: autoconf >= 2.65
+BuildRequires: automake >= 1:1.10
+BuildRequires: docbook-dtd43-xml
+BuildRequires: gettext-tools
+BuildRequires: gobject-introspection-devel >= 0.10.0
+BuildRequires: gtk+3-devel >= 3.0.0
 BuildRequires: gtk-doc >= 1.4
-BuildRequires: intltool >= 0.40.0
+BuildRequires: intltool >= 0.40.4
 BuildRequires: libtool
 BuildRequires: libxml2-devel >= 1:2.6.26
 BuildRequires: pkgconfig
@@ -21,28 +27,21 @@ Conflicts:  glibc-misc < 6:2.7
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-This package contains components and libraries that are intended to be
-shared between GNOME development tools, including gnome-debug,
-gnome-build, and anjuta2. The current pieces of GDL include: a symbol
-browser bonobo component (symbol-browser-control), a docking widget
-(gdl), a utility library that also contains the stubs and skels for
-the symbol browser and text editor components (gdl, idl).
+The GNOME Devtools Library package provides a docking system and
+several utilities useful to GNOME development tools and GNOME
+applications in general.
 
 %description -l pl.UTF-8
-Ten pakiet zawiera komponenty i biblioteki zaprojektowane jako wspólne
-dla różnych narzędzi programistycznych GNOME, takich jak: gnome-debug,
-gnome-build i anjuta2. Aktualnie GDL zawiera: przeglądarkę symboli
-jako komponent bonobo (symbol-browser-control), dokowany element
-interfejsu graficznego (gdl), bibliotekę narzędzi zawierającą także
-szkielety dla przeglądarki symboli i komponentów edytora tekstu (gdl,
-idl).
+Pakiet GNOME Devtools Library zapewnia system dokujący oraz kilka
+narzędzi przydatnych w narzędziach programistycznych GNOME oraz
+ogólnie aplikacjach GNOME.
 
 %package devel
 Summary:       Header files for gdl development
-Summary(pl.UTF-8):     Pliki nagłówkowe do biblioteki gdl
+Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki gdl
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
-Requires:      gtk+2-devel >= 2:2.16.0
+Requires:      gtk+3-devel >= 3.0.0
 Requires:      libxml2-devel >= 1:2.6.26
 
 %description devel
@@ -54,22 +53,25 @@ Pakiet zawiera pliki nagłówkowe niezbędne do kompilowania programów
 używających bibliotek gdl.
 
 %package static
-Summary:       Static libraries for gdl development
-Summary(pl.UTF-8):     Statyczne biblioteki gdl
+Summary:       Static gdl library
+Summary(pl.UTF-8):     Statyczna biblioteka gdl
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
-This package contains the static gdl libraries.
+This package contains the static gdl library.
 
 %description static -l pl.UTF-8
-Pakiet zawiera statyczne biblioteki gdl.
+Pakiet zawiera statyczną bibliotekę gdl.
 
 %package apidocs
 Summary:       gdl library API documentation
 Summary(pl.UTF-8):     Dokumentacja API biblioteki gdl
 Group:         Documentation
 Requires:      gtk-doc-common
+%if "%{_rpmversion}" >= "5"
+BuildArch:     noarch
+%endif
 
 %description apidocs
 gdl library API documentation.
@@ -81,17 +83,19 @@ Dokumentacja API biblioteki gdl.
 %setup -q
 
 %build
-%{__glib_gettextize}
+#{__glib_gettextize}
+%{__gtkdocize}
 %{__intltoolize}
 %{__libtoolize}
-%{__aclocal}
+%{__aclocal} -I m4
 %{__autoconf}
 %{__autoheader}
 %{__automake}
 %configure \
-       --with-html-dir=%{_gtkdocdir} \
        --enable-gtk-doc \
-       --enable-static
+       --disable-silent-rules \
+       %{?with_static_libs:--enable-static} \
+       --with-html-dir=%{_gtkdocdir}
 
 %{__make}
 
@@ -101,7 +105,9 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-%find_lang %{name}-1
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
+
+%find_lang %{name}-3
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -109,24 +115,26 @@ rm -rf $RPM_BUILD_ROOT
 %post  -p /sbin/ldconfig
 %postun        -p /sbin/ldconfig
 
-%files -f %{name}-1.lang
+%files -f %{name}-3.lang
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog NEWS README
-%attr(755,root,root) %{_libdir}/libgdl-1.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libgdl-1.so.3
-%{_datadir}/gdl
+%doc AUTHORS ChangeLog MAINTAINERS NEWS README
+%attr(755,root,root) %{_libdir}/libgdl-3.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libgdl-3.so.5
+%{_libdir}/girepository-1.0/Gdl-3.typelib
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libgdl-1.so
-%{_includedir}/libgdl-1.0
-%{_libdir}/libgdl-1.la
-%{_pkgconfigdir}/gdl-1.0.pc
+%attr(755,root,root) %{_libdir}/libgdl-3.so
+%{_datadir}/gir-1.0/Gdl-3.gir
+%{_includedir}/libgdl-3.0
+%{_pkgconfigdir}/gdl-3.0.pc
 
+%if %{with static_libs}
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/libgdl-1.a
+%{_libdir}/libgdl-3.a
+%endif
 
 %files apidocs
 %defattr(644,root,root,755)
-%{_gtkdocdir}/gdl
+%{_gtkdocdir}/gdl-3.0
This page took 0.179266 seconds and 4 git commands to generate.