]> git.pld-linux.org Git - packages/gdkxft.git/blob - gdkxft.spec
- removed all Group fields translations (oure rpm now can handle translating
[packages/gdkxft.git] / gdkxft.spec
1 #
2 # Conditional build:
3 # _without_gnome        - without capplet subpackage (which require GNOME libs to build)
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        Adapt GTK-1.2 to support xft fonts
7 Summary(pl):    Wsparcie dla fontów xft dla GTK-1.2
8 Summary(pt_BR): Adapta o GTK-1.2 para suportar fontes xft
9 Name:           gdkxft
10 Version:        1.5
11 Release:        5
12 License:        LGPL
13 Group:          X11/Libraries
14 Source0:        http://prdownloads.sourceforge.net/gdkxft/%{name}-%{version}.tar.gz
15 %{!?_without_gnome:BuildRequires:       control-center-devel}
16 %{!?_without_gnome:BuildRequires:       libglade-devel}
17 BuildRequires:  gtk+-devel >= 1.2.0
18 BuildRequires:  perl-devel
19 Prereq:         /sbin/ldconfig
20 URL:            http://gdkxft.sourceforge.net/
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _prefix         /usr/X11R6
24 %define         _mandir         %{_prefix}/man
25
26 %description 
27 A library that adds transparent support for anti-aliased fonts to the
28 libgdk component of gtk+-1.2.x. Gtk+ widgets will automagically use
29 the fonts.
30
31 %description -l pl
32 Biblioteka dodaj±ca prze¼roczyst± obs³ugê dla wyg³adzanych fontów w
33 komponencie libgdk biblioteki gtk+-1.2.x. Widgety gtk+ automatycznie
34 bêd± u¿ywa³y tych fontów.
35
36 %description -l pt_BR
37 Este pacote contém bibliotecas para adicionar suporte transparente a
38 fontes anti-aliased para o componente libgdk do gtk+-1.2. Os widgets
39 Gtk+ vão automaticamente usar essas fontes.
40
41 %package devel
42 Summary:        Header files for developing apps
43 Summary(es):    Bibliotecas y archivos de inclusión para desarrollo
44 Summary(pl):    Pliki nag³owkowe gdkxft
45 Summary(pt_BR): Bibliotecas e arquivos de inclusão para desenvolvimento
46 Group:          Development/Libraries
47 PreReq:         %{name} = %{version}-%{release}
48
49 %description devel
50 Header files for developing apps with will use libgdkxft.
51
52 %description devel -l pl
53 Pliki nag³ówkowe do tworzenia aplikacji u¿ywaj±cych libgdkxft.
54
55 %description devel -l pt_BR
56 Bibliotecas e arquivos de inclusão necessários para desenvolvimento
57 baseado na libgdkxft.
58
59 %package static
60 Summary:        Static libraries for libgdkxft development
61 Summary(pl):    Statyczna biblioteka libgdkxft
62 Summary(pt_BR): Bibliotecas estáticas para desenvolvimento com a libgdkxft
63 Group:          Development/Libraries
64 Requires:       %{name}-devel = %{version}-%{release}
65
66 %description static
67 Static libraries for libgdkxft development.
68
69 %description static -l pl
70 Statyczna biblioteka libgdkxft.
71
72 %description static -l pt_BR
73 Bibliotecas estáticas para desenvolvimento com a libgdkxft.
74
75 %package capplet
76 Summary:        Capplet to configure gdkxft in GNOME
77 Summary(pl):    Narzêdzie do konfiguracji gdkxft w GNOME
78 Group:          X11/Applications
79 Requires:       %{name} = %{version}
80
81 %description capplet
82 Capplet to configure gdkxft in GNOME.
83
84 %description capplet -l pl
85 Narzêdzie do konfiguracji gdkxft w GNOME.
86
87 %prep
88 %setup -q
89
90 %build
91 %configure \
92         --enable-static \
93         --enable-shared
94
95 %{__make}
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99 install -d $RPM_BUILD_ROOT{/etc/X11/xinit/xinitrc.d,%{_datadir}/themes/Gdkxft/gtk}
100
101 %{__make} install \
102         DESTDIR=$RPM_BUILD_ROOT
103
104 > $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/gdkxft
105 > $RPM_BUILD_ROOT%{_datadir}/themes/Gdkxft/gtk/gtkrc
106
107 gzip -9nf AUTHORS ChangeLog NEWS README
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post
113 %{_sbindir}/gdkxft_sysinstall
114 /sbin/ldconfig
115
116 %preun
117 if [ "$1" = "0" ]; then
118         %{_sbindir}/gdkxft_sysinstall -u
119 fi
120
121 %postun -p /sbin/ldconfig
122
123 %files
124 %defattr(644,root,root,755)
125 %doc *.gz
126 %dir %{_datadir}/themes/Gdkxft
127 %dir %{_datadir}/themes/Gdkxft/gtk
128 %ghost %{_datadir}/themes/Gdkxft/gtk/gtkrc
129 %attr(755,root,root) %ghost /etc/X11/xinit/xinitrc.d/gdkxft
130 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/gdkxft.conf
131 %attr(755,root,root) %{_sbindir}/gdkxft_sysinstall
132 %attr(755,root,root) %{_libdir}/libgdkxft.so.*.*
133
134 %files devel
135 %defattr(644,root,root,755)
136 %attr(755,root,root) %{_libdir}/libgdkxft.la
137 %attr(755,root,root) %{_libdir}/libgdkxft.so
138
139 %files static
140 %defattr(644,root,root,755)
141 %{_libdir}/libgdkxft.a
142
143 %if %{?_without_gnome:0}%{!?_without_gnome:1}
144 %files capplet
145 %defattr(644,root,root,755)
146 %attr(755,root,root) %{_bindir}/*-capplet
147 %endif
This page took 0.045992 seconds and 3 git commands to generate.