]> git.pld-linux.org Git - packages/gdbm18.git/blob - gdbm18.spec
- removed Prereq: /usr/sbin/fix-info-dir
[packages/gdbm18.git] / gdbm18.spec
1 Summary:        GNU database library for C
2 Summary(de):    GNU-Datenbank-Library für C
3 Summary(fr):    La librairie GNU de bases de données pout le langage C.
4 Summary(pl):    GNU biblioteka bazy danych la jêzyka C
5 Name:           gdbm
6 Version:        1.8.0
7 Release:        3
8 Copyright:      GPL
9 Group:          Libraries
10 Group(pl):      Biblioteki
11 Source:         ftp://prep.ai.mit.edu/pub/gnu/%{name}-%{version}.tar.gz
12 Patch0:         gdbm-info.patch
13 Patch1:         gdbm-DESTDIR.patch
14 Patch2:         gdbm-jbj.patch
15 BuildRequires:  libtool
16 BuildRequires:  autoconf
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Gdbm is a GNU database indexing library, including routines which use
21 extensible hashing. Gdbm works in a similar way to standard UNIX dbm
22 routines. Gdbm is useful for developers who write C applications and need
23 access to a simple and efficient database or who are building C applications
24 which will use such a database.
25
26 %description -l de
27 Dies ist eine Datenbank-Index-Library für Programmierer, die 
28 C-Anwendungen schreiben und eine einfache und leistungsfähige
29 Datenbank benötigen oder diese in C-Anwendungen einsetzen möchten.
30
31 %description -l fr
32 Une librairie d'indexation de bases de données. Elle est utile pour ceux
33 qui désirent écrivent des applications en C et ont besion d'accéder à
34 une base de données simple et efficace ou de construire une application
35 en C qui l'utilise.
36
37 %description -l pl
38 W pakiecie znajduje siê biblioteka indeksowania bazy danych. Biblioteka
39 ta jest szczególnie uzyteczna dla ludzi, którzy pisz± oprogramowanie w C
40 i potrzebuj± prostej i szybkiej bazy danych, lub dla tych którzy pisz±
41 programy w C z wykorzystaniem tej biblioteki. 
42
43 %description -l tr
44 gdbm bir veri tabaný dizinleme kitaplýðýdýr. C uygulamalarý yazýp basit ve
45 etkin bir þekilde veri tabanýna ulaþmak isteyenler için yararlý olacaktýr.
46
47 %package devel
48 Summary:        development libraries and header files for gdbm
49 Summary(de):    Entwicklungs-Libraries und Header-Dateien für gdbm 
50 Summary(fr):    Bibliothèques de développement et en-têtes pour gdbm
51 Summary(pl):    Biblioteki i pliki nag³ówkowe dla gdbm
52 Summary(tr):    gdbm için baþlýk dosyalarý ve geliþtirme kitaplýklarý
53 Group:          Development/Libraries
54 Group(pl):      Programowanie/Biblioteki
55 Requires:       %{name} = %{version}
56
57 %description devel
58 These are the development libraries and header files for gdbm, the
59 GNU database system.  These are required if you plan to do 
60 development using the gdbm database.
61
62 %description -l de devel
63 Dies sind die Entwicklungs-Libraries und Header-Dateien für gdbm, das
64 GNU-Datenbanksystem. Sie sind darauf angewiesen, wenn Sie vorhaben,
65 die gdbm-Datenbank für Entwicklungsarbeiten zu benutzen.
66
67 %description -l fr devel
68 Ce sont les librairies de développement et les fichiers d'en-tête pour gdbm,
69 le système de base de données GNU. Ceci est nécessaire si vous désirez 
70 développer en utilisant la base de données gdbm.
71
72 %description -l pl devel
73 W pakiecie tym znajduj± siê pliki nag³ówkowe i biblioteki dla GNU
74 systemu bazy danych.
75
76 %description -l tr devel
77 GNU veri tabaný sistemi gdbm ile program geliþtirmek için gereken baþlýk
78 dosyalarý ve kitaplýklar.
79
80 %package static
81 Summary:        Static gdbm library
82 Summary(pl):    Biblioteki statyczne gdbm
83 Group:          Development/Libraries
84 Group(pl):      Programowanie/Biblioteki
85 Requires:       %{name}-devel = %{version}
86
87 %description static
88 Static gdbm library.
89
90 %prep
91 %setup  -q
92 %patch0 -p1
93 %patch1 -p1
94 %patch2 -p1
95
96 %build
97 libtoolize --copy --force
98 aclocal
99 autoheader
100 autoconf
101 %configure
102
103 make CFLAGS="$RPM_OPT_FLAGS"
104
105 makeinfo gdbm.texinfo
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}} \
110            $RPM_BUILD_ROOT{%{_mandir}/man3,%{_infodir}}
111
112 make install \
113         prefix=%{_prefix} \
114         exec_prefix=%{_exec_prefix} \
115         binprefix=%{_exec_prefix} \
116         manprefix=%{_prefix} \
117         libdir=%{_libdir} \
118         includedir=%{_includedir} \
119         infodir=%{_infodir} \
120         man3dir=%{_mandir}/man3 \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
124
125 gzip -fn9 $RPM_BUILD_ROOT{%{_infodir}/gdbm*info*,%{_mandir}/man3/*}
126
127 %post -p /sbin/ldconfig
128
129 %post devel
130 [ -x /usr/sbin/fix-info-dir ] && /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
131
132 %postun -p /sbin/ldconfig
133
134 %postun devel
135 [ -x /usr/sbin/fix-info-dir ] && /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %files
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_libdir}/lib*.so.*.*
143
144 %files devel
145 %defattr(644,root,root,755)
146 %attr(755,root,root) %{_libdir}/lib*.so
147 %attr(755,root,root) %{_libdir}/lib*.la
148 %{_mandir}/man3/*
149 %{_includedir}/*
150 %{_infodir}/gdbm*
151
152 %files static
153 %defattr(644,root,root,755)
154 %{_libdir}/lib*.a
This page took 0.057145 seconds and 3 git commands to generate.