]> git.pld-linux.org Git - packages/gdbm18.git/blob - gdbm18.spec
- fixed using macros
[packages/gdbm18.git] / gdbm18.spec
1 Summary:        GNU database library for C
2 Summary(de):    GNU-Datenbank-Library für C
3 Summary(fr):    La librairie GNU de bases de données pout le langage C.
4 Summary(pl):    GNU biblioteka bazy danych la jêzyka C
5 Name:           gdbm
6 Version:        1.7.3
7 Release:        22
8 Copyright:      GPL
9 Group:          Libraries
10 Group(pl):      Biblioteki
11 Source:         ftp://prep.ai.mit.edu/pub/gnu/%{name}-%{version}.tar.gz
12 Patch0:         gdbm-shlib.patch
13 Patch1:         gdbm-info.patch
14 Patch2:         gdbm-configure.patch
15 Patch3:         gdbm-DESTDIR.patch
16 Buildroot:      /tmp/%{name}-%{version}-root
17
18 %description
19 This is a database indexing library. It is useful for those who need 
20 to write C applications and need access to a simple and efficient
21 database or build C applications which use it.
22
23 %description -l de
24 Dies ist eine Datenbank-Index-Library für Programmierer, die 
25 C-Anwendungen schreiben und eine einfache und leistungsfähige
26 Datenbank benötigen oder diese in C-Anwendungen einsetzen möchten.
27
28 %description -l fr
29 Une librairie d'indexation de bases de données. Elle est utile pour ceux
30 qui désirent écrivent des applications en C et ont besion d'accéder à
31 une base de données simple et efficace ou de construire une application
32 en C qui l'utilise.
33
34 %description -l pl
35 W pakiecie znajduje siê biblioteka indeksowania bazy danych. Biblioteka
36 ta jest szczególnie uzyteczna dla ludzi, którzy pisz± oprogramowanie w C
37 i potrzebuj± prostej i szybkiej bazy danych, lub dla tych którzy pisz±
38 programy w C z wykorzystaniem tej biblioteki. 
39
40 %description -l tr
41 gdbm bir veri tabaný dizinleme kitaplýðýdýr. C uygulamalarý yazýp basit ve
42 etkin bir þekilde veri tabanýna ulaþmak isteyenler için yararlý olacaktýr.
43
44 %package devel
45 Summary:        development libraries and header files for gdbm
46 Summary(de):    Entwicklungs-Libraries und Header-Dateien für gdbm 
47 Summary(fr):    Bibliothèques de développement et en-têtes pour gdbm
48 Summary(pl):    Biblioteki i pliki nag³ówkowe dla gdbm
49 Summary(tr):    gdbm için baþlýk dosyalarý ve geliþtirme kitaplýklarý
50 Group:          Development/Libraries
51 Group(pl):      Programowanie/Biblioteki
52 Requires:       %{name} = %{version}
53 Prereq:         /sbin/install-info
54
55 %description devel
56 These are the development libraries and header files for gdbm, the
57 GNU database system.  These are required if you plan to do 
58 development using the gdbm database.
59
60 %description -l de devel
61 Dies sind die Entwicklungs-Libraries und Header-Dateien für gdbm, das
62 GNU-Datenbanksystem. Sie sind darauf angewiesen, wenn Sie vorhaben,
63 die gdbm-Datenbank für Entwicklungsarbeiten zu benutzen.
64
65 %description -l fr devel
66 Ce sont les librairies de développement et les fichiers d'en-tête pour gdbm,
67 le système de base de données GNU. Ceci est nécessaire si vous désirez 
68 développer en utilisant la base de données gdbm.
69
70 %description -l pl devel
71 W pakiecie tym znajduj± siê pliki nag³ówkowe i biblioteki dla GNU
72 systemu bazy danych.
73
74 %description -l tr devel
75 GNU veri tabaný sistemi gdbm ile program geliþtirmek için gereken baþlýk
76 dosyalarý ve kitaplýklar.
77
78 %package static
79 Summary:        Static gdbm library
80 Summary(pl):    Biblioteki statyczne gdbm
81 Group:          Development/Libraries
82 Group(pl):      Programowanie/Biblioteki
83 Requires:       %{name}-devel = %{version}
84
85 %description static
86 Static gdbm library.
87
88 %prep
89 %setup  -q
90 %patch0 -p1
91 %patch1 -p1
92 %patch2 -p1
93 %patch3 -p1
94
95 %build
96 mkdir shared
97 aclocal
98 autoheader
99 automake --add-missing || :
100 autoconf
101 %configure
102
103 make CFLAGS="$RPM_OPT_FLAGS"
104 make CFLAGS="$RPM_OPT_FLAGS" shared
105
106 makeinfo gdbm.texinfo
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}} \
111            $RPM_BUILD_ROOT{%{_mandir}/man3,%{_infodir}}
112
113 make install \
114         prefix=%{_prefix} \
115         exec_prefix=%{_exec_prefix} \
116         binprefix=%{_exec_prefix} \
117         manprefix=%{_prefix} \
118         libdir=%{_libdir} \
119         includedir=%{_includedir} \
120         infodir=%{_infodir} \
121         man3dir=%{_mandir}/man3 \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 ln -sf libgdbm.so.2.0.0 $RPM_BUILD_ROOT%{_libdir}/libgdbm.so
125
126 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
127
128 gzip -fn9 $RPM_BUILD_ROOT{%{_infodir}/gdbm*info*,%{_mandir}/man3/*}
129
130 %post -p /sbin/ldconfig
131
132 %post devel
133 /sbin/install-info %{_infodir}/gdbm.info.gz /etc/info-dir
134
135 %postun -p /sbin/ldconfig
136
137 %preun devel
138 if [ "$1" = "0" ]; then
139         /sbin/install-info --delete %{_infodir}/gdbm.info.gz /etc/info-dir
140 fi
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %files
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_libdir}/lib*.so.*.*
148
149 %files devel
150 %defattr(644,root,root,755)
151 %attr(755,root,root) %{_libdir}/lib*.so
152 %{_mandir}/man3/*
153 %{_includedir}/*
154 %{_infodir}/gdbm*
155
156 %files static
157 %defattr(644,root,root,755)
158 %{_libdir}/lib*.a
159
160 %changelog
161 * Thu Apr 29 1999 Artur Frysiak <wiget@pld.org.pl>
162   [1.7.3-22]
163 - used %%configure macro
164 - added gdbm-configure.patch
165
166 * Sun Mar 14 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
167   [1.7.3-21]
168 - added --strip-unneeded parameter on striping shared libraries,
169 - removed man group from man pages.
170
171 * Mon Jan 04 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
172   [1.7.3-20]
173 - standarized {un}registering info pages (added gdbm-info.patch),
174 - added gzipping man pages.
175
176 * Sun Nov 22 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
177   [1.7.3-19]
178 - removed "Prereq: /sbin/install-info" from static,
179 - fixed --entry text on {un}registering info page for ed in %post
180   %preun in devel.
181
182 * Wed Sep 30 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
183 - build against glibc-2.1,
184 - translation modified for pl.
185
186 * Sun Aug 30 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
187   [1.7.3-18]
188 - added -q %setup parameter,
189 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
190 - added using %%{name} and %%{version} in Source,
191 - added static subpackage,
192 - changed dependencies to "Requires: %%{name} = %%{version}" in devel
193   subpackage,
194 - added stripping shared libraries,
195 - added %attr and %defattr macros in %files (allows build package from
196   non-root account).
197
198 * Thu May 07 1998 Prospector System <bugs@redhat.com>
199 - translations modified for de, fr, tr
200
201 * Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
202 - gdbm-devel moved to Development/Libraries
203
204 * Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
205 - buildroot and built for Manhattan
206
207 * Tue Oct 14 1997 Donnie Barnes <djb@redhat.com>
208 - spec file cleanups
209
210 * Thu Jun 12 1997 Erik Troan <ewt@redhat.com>
211 - built against glibc
This page took 0.081368 seconds and 3 git commands to generate.