]> git.pld-linux.org Git - packages/gdbm18.git/blob - gdbm18.spec
- release 10: added texinfo to BuildRequires.
[packages/gdbm18.git] / gdbm18.spec
1 Summary:        GNU database library for C
2 Summary(de):    GNU-Datenbank-Library für C
3 Summary(fr):    La librairie GNU de bases de données pout le langage C
4 Summary(pl):    GNU biblioteka bazy danych la jêzyka C
5 Name:           gdbm
6 Version:        1.8.0
7 Release:        10
8 License:        GPL
9 Group:          Libraries
10 Group(de):      Libraries
11 Group(fr):      Librairies
12 Group(pl):      Biblioteki
13 Source0:        ftp://prep.ai.mit.edu/pub/gnu/%{name}-%{version}.tar.gz
14 Patch0:         %{name}-info.patch
15 Patch1:         %{name}-DESTDIR.patch
16 Patch2:         %{name}-jbj.patch
17 BuildRequires:  autoconf
18 BuildRequires:  libtool
19 BuildRequires:  texinfo
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Gdbm is a GNU database indexing library, including routines which use
24 extensible hashing. Gdbm works in a similar way to standard UNIX dbm
25 routines. Gdbm is useful for developers who write C applications and
26 need access to a simple and efficient database or who are building C
27 applications which will use such a database.
28
29 %description -l de
30 Dies ist eine Datenbank-Index-Library für Programmierer, die
31 C-Anwendungen schreiben und eine einfache und leistungsfähige
32 Datenbank benötigen oder diese in C-Anwendungen einsetzen möchten.
33
34 %description -l fr
35 Une librairie d'indexation de bases de données. Elle est utile pour
36 ceux qui désirent écrivent des applications en C et ont besion
37 d'accéder à une base de données simple et efficace ou de construire
38 une application en C qui l'utilise.
39
40 %description -l pl
41 W pakiecie znajduje siê biblioteka indeksowania bazy danych.
42 Biblioteka ta jest szczególnie uzyteczna dla ludzi, którzy pisz±
43 oprogramowanie w C i potrzebuj± prostej i szybkiej bazy danych, lub
44 dla tych którzy pisz± programy w C z wykorzystaniem tej biblioteki.
45
46 %description -l tr
47 gdbm bir veri tabaný dizinleme kitaplýðýdýr. C uygulamalarý yazýp
48 basit ve etkin bir þekilde veri tabanýna ulaþmak isteyenler için
49 yararlý olacaktýr.
50
51 %package devel
52 Summary:        development libraries and header files for gdbm
53 Summary(de):    Entwicklungs-Libraries und Header-Dateien für gdbm 
54 Summary(fr):    Bibliothèques de développement et en-têtes pour gdbm
55 Summary(pl):    Biblioteki i pliki nag³ówkowe dla gdbm
56 Summary(tr):    gdbm için baþlýk dosyalarý ve geliþtirme kitaplýklarý
57 Group:          Development/Libraries
58 Group(de):      Entwicklung/Libraries
59 Group(fr):      Development/Librairies
60 Group(pl):      Programowanie/Biblioteki
61 Requires:       %{name} = %{version}
62
63 %description devel
64 These are the development libraries and header files for gdbm, the GNU
65 database system. These are required if you plan to do development
66 using the gdbm database.
67
68 %description -l de devel
69 Dies sind die Entwicklungs-Libraries und Header-Dateien für gdbm, das
70 GNU-Datenbanksystem. Sie sind darauf angewiesen, wenn Sie vorhaben,
71 die gdbm-Datenbank für Entwicklungsarbeiten zu benutzen.
72
73 %description -l fr devel
74 Ce sont les librairies de développement et les fichiers d'en-tête pour
75 gdbm, le système de base de données GNU. Ceci est nécessaire si vous
76 désirez développer en utilisant la base de données gdbm.
77
78 %description -l pl devel
79 W pakiecie tym znajduj± siê pliki nag³ówkowe i biblioteki dla GNU
80 systemu bazy danych.
81
82 %description -l tr devel
83 GNU veri tabaný sistemi gdbm ile program geliþtirmek için gereken
84 baþlýk dosyalarý ve kitaplýklar.
85
86 %package static
87 Summary:        Static gdbm library
88 Summary(pl):    Biblioteki statyczne gdbm
89 Group:          Development/Libraries
90 Group(de):      Entwicklung/Libraries
91 Group(fr):      Development/Librairies
92 Group(pl):      Programowanie/Biblioteki
93 Requires:       %{name}-devel = %{version}
94
95 %description static
96 Static gdbm library.
97
98 %prep
99 %setup  -q
100 %patch0 -p1
101 %patch1 -p1
102 %patch2 -p1
103
104 %build
105 libtoolize --copy --force
106 aclocal
107 autoheader
108 autoconf
109 %configure
110
111 %{__make} CFLAGS="%{rpmcflags}"
112
113 makeinfo gdbm.texinfo
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}} \
118            $RPM_BUILD_ROOT{%{_mandir}/man3,%{_infodir}}
119
120 %{__make} install install-compat \
121         prefix=%{_prefix} \
122         exec_prefix=%{_exec_prefix} \
123         binprefix=%{_exec_prefix} \
124         manprefix=%{_prefix} \
125         libdir=%{_libdir} \
126         includedir=%{_includedir} \
127         infodir=%{_infodir} \
128         man3dir=%{_mandir}/man3 \
129         DESTDIR=$RPM_BUILD_ROOT
130
131 %post   -p /sbin/ldconfig
132 %postun -p /sbin/ldconfig
133
134 %post devel
135 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
136
137 %postun devel
138 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %files
144 %defattr(644,root,root,755)
145 %attr(755,root,root) %{_libdir}/lib*.so.*.*
146
147 %files devel
148 %defattr(644,root,root,755)
149 %attr(755,root,root) %{_libdir}/lib*.so
150 %attr(755,root,root) %{_libdir}/lib*.la
151 %{_mandir}/man3/*
152 %{_includedir}/*
153 %{_infodir}/gdbm*
154
155 %files static
156 %defattr(644,root,root,755)
157 %{_libdir}/lib*.a
This page took 0.031986 seconds and 3 git commands to generate.