]> git.pld-linux.org Git - packages/gdbm.git/blob - gdbm.spec
- bump to release 4 (to allow upgrade from RH 6.2),
[packages/gdbm.git] / gdbm.spec
1 Summary:        GNU database library for C
2 Summary(de):    GNU-Datenbank-Library für C
3 Summary(fr):    La librairie GNU de bases de données pout le langage C.
4 Summary(pl):    GNU biblioteka bazy danych la jêzyka C
5 Name:           gdbm
6 Version:        1.8.0
7 Release:        4
8 License:        GPL
9 Group:          Libraries
10 Group(fr):      Librairies
11 Group(pl):      Biblioteki
12 Source0:        ftp://prep.ai.mit.edu/pub/gnu/%{name}-%{version}.tar.gz
13 Patch0:         gdbm-info.patch
14 Patch1:         gdbm-DESTDIR.patch
15 Patch2:         gdbm-jbj.patch
16 BuildRequires:  libtool
17 BuildRequires:  autoconf
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Gdbm is a GNU database indexing library, including routines which use
22 extensible hashing. Gdbm works in a similar way to standard UNIX dbm
23 routines. Gdbm is useful for developers who write C applications and need
24 access to a simple and efficient database or who are building C
25 applications which will use such a database.
26
27 %description -l de
28 Dies ist eine Datenbank-Index-Library für Programmierer, die C-Anwendungen
29 schreiben und eine einfache und leistungsfähige Datenbank benötigen oder
30 diese in C-Anwendungen einsetzen möchten.
31
32 %description -l fr
33 Une librairie d'indexation de bases de données. Elle est utile pour ceux
34 qui désirent écrivent des applications en C et ont besion d'accéder à une
35 base de données simple et efficace ou de construire une application en C
36 qui l'utilise.
37
38 %description -l pl
39 W pakiecie znajduje siê biblioteka indeksowania bazy danych. Biblioteka ta
40 jest szczególnie uzyteczna dla ludzi, którzy pisz± oprogramowanie w C i
41 potrzebuj± prostej i szybkiej bazy danych, lub dla tych którzy pisz±
42 programy w C z wykorzystaniem tej biblioteki.
43
44 %description -l tr
45 gdbm bir veri tabaný dizinleme kitaplýðýdýr. C uygulamalarý yazýp basit ve
46 etkin bir þekilde veri tabanýna ulaþmak isteyenler için yararlý olacaktýr.
47
48 %package devel
49 Summary:        development libraries and header files for gdbm
50 Summary(de):    Entwicklungs-Libraries und Header-Dateien für gdbm 
51 Summary(fr):    Bibliothèques de développement et en-têtes pour gdbm
52 Summary(pl):    Biblioteki i pliki nag³ówkowe dla gdbm
53 Summary(tr):    gdbm için baþlýk dosyalarý ve geliþtirme kitaplýklarý
54 Group:          Development/Libraries
55 Group(fr):      Development/Librairies
56 Group(pl):      Programowanie/Biblioteki
57 Requires:       %{name} = %{version}
58
59 %description devel
60 These are the development libraries and header files for gdbm, the GNU
61 database system. These are required if you plan to do development using the
62 gdbm database.
63
64 %description -l de devel
65 Dies sind die Entwicklungs-Libraries und Header-Dateien für gdbm, das
66 GNU-Datenbanksystem. Sie sind darauf angewiesen, wenn Sie vorhaben, die
67 gdbm-Datenbank für Entwicklungsarbeiten zu benutzen.
68
69 %description -l fr devel
70 Ce sont les librairies de développement et les fichiers d'en-tête pour
71 gdbm, le système de base de données GNU. Ceci est nécessaire si vous
72 désirez développer en utilisant la base de données gdbm.
73
74 %description -l pl devel
75 W pakiecie tym znajduj± siê pliki nag³ówkowe i biblioteki dla GNU systemu
76 bazy danych.
77
78 %description -l tr devel
79 GNU veri tabaný sistemi gdbm ile program geliþtirmek için gereken baþlýk
80 dosyalarý ve kitaplýklar.
81
82 %package static
83 Summary:        Static gdbm library
84 Summary(pl):    Biblioteki statyczne gdbm
85 Group:          Development/Libraries
86 Group(fr):      Development/Librairies
87 Group(pl):      Programowanie/Biblioteki
88 Requires:       %{name}-devel = %{version}
89
90 %description static
91 Static gdbm library.
92
93 %prep
94 %setup  -q
95 %patch0 -p1
96 %patch1 -p1
97 %patch2 -p1
98
99 %build
100 libtoolize --copy --force
101 aclocal
102 autoheader
103 autoconf
104 %configure
105
106 make CFLAGS="$RPM_OPT_FLAGS"
107
108 makeinfo gdbm.texinfo
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}} \
113            $RPM_BUILD_ROOT{%{_mandir}/man3,%{_infodir}}
114
115 make install \
116         prefix=%{_prefix} \
117         exec_prefix=%{_exec_prefix} \
118         binprefix=%{_exec_prefix} \
119         manprefix=%{_prefix} \
120         libdir=%{_libdir} \
121         includedir=%{_includedir} \
122         infodir=%{_infodir} \
123         man3dir=%{_mandir}/man3 \
124         DESTDIR=$RPM_BUILD_ROOT
125
126 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
127
128 gzip -9nf $RPM_BUILD_ROOT{%{_infodir}/gdbm*info*,%{_mandir}/man3/*}
129
130 %post -p /sbin/ldconfig
131
132 %post devel
133 [ -x /usr/sbin/fix-info-dir ] && /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
134
135 %postun -p /sbin/ldconfig
136
137 %postun devel
138 [ -x /usr/sbin/fix-info-dir ] && /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %files
144 %defattr(644,root,root,755)
145 %attr(755,root,root) %{_libdir}/lib*.so.*.*
146
147 %files devel
148 %defattr(644,root,root,755)
149 %attr(755,root,root) %{_libdir}/lib*.so
150 %attr(755,root,root) %{_libdir}/lib*.la
151 %{_mandir}/man3/*
152 %{_includedir}/*
153 %{_infodir}/gdbm*
154
155 %files static
156 %defattr(644,root,root,755)
157 %{_libdir}/lib*.a
This page took 0.087275 seconds and 4 git commands to generate.