]> git.pld-linux.org Git - packages/gdb.git/commitdiff
- rel 6; python 2.7 fixes; rebuild configure.ac, too auto/th/gdb-7_0-6
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 8 Jul 2010 18:41:36 +0000 (18:41 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    gdb-python.patch -> 1.1
    gdb.spec -> 1.128

gdb-python.patch [new file with mode: 0644]
gdb.spec

diff --git a/gdb-python.patch b/gdb-python.patch
new file mode 100644 (file)
index 0000000..dbb8082
--- /dev/null
@@ -0,0 +1,27 @@
+--- gdb-7.0/gdb/configure.ac~  2010-07-08 14:54:43.770583270 +0200
++++ gdb-7.0/gdb/configure.ac   2010-07-08 14:56:17.539947910 +0200
+@@ -881,6 +881,12 @@
+   LIBS="$LIBS ${python_libs}"
+   have_libpython=no
+   if test "${have_libpython}" = no; then
++    AC_TRY_LIBPYTHON(python2.7, have_libpython)
++    if test "${HAVE_LIBPYTHON2_7}" = yes; then
++      AC_DEFINE(HAVE_LIBPYTHON2_7, 1, [Define if Python 2.7 is being used.])
++    fi
++  fi
++  if test "${have_libpython}" = no; then
+     AC_TRY_LIBPYTHON(python2.6, have_libpython)
+     if test "${HAVE_LIBPYTHON2_6}" = yes; then
+       AC_DEFINE(HAVE_LIBPYTHON2_6, 1, [Define if Python 2.6 is being used.])
+--- gdb-7.0/gdb/python/python-internal.h~      2010-07-08 14:54:43.136858331 +0200
++++ gdb-7.0/gdb/python/python-internal.h       2010-07-08 14:56:56.739736159 +0200
+@@ -45,6 +45,9 @@
+ #elif HAVE_LIBPYTHON2_6
+ #include "python2.6/Python.h"
+ #include "python2.6/frameobject.h"
++#elif HAVE_LIBPYTHON2_7
++#include "python2.7/Python.h"
++#include "python2.7/frameobject.h"
+ #else
+ #error "Unable to find usable Python.h"
+ #endif
index 3d22c3314df4d748c97f669742b11864832d7225..e17b2c1a27dff7d2d5046831dc06355729f88bd1 100644 (file)
--- a/gdb.spec
+++ b/gdb.spec
@@ -20,7 +20,7 @@ Summary(zh_CN.UTF-8): [开发]C和其他语言的调试器
 Summary(zh_TW.UTF-8):  [.-A開發]C和.$)B其.-A他語.$)B言的調試器
 Name:          gdb
 Version:       7.0
-Release:       5
+Release:       6
 License:       GPL v3+
 Group:         Development/Debuggers
 Source0:       http://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.bz2
@@ -154,6 +154,7 @@ Patch1001:  %{name}-info.patch
 Patch1002:     %{name}-passflags.patch
 Patch1005:     %{name}-pretty-print-by-default.patch
 Patch1006:     buildid-locate-rpm-pld.patch
+Patch1007:     %{name}-python.patch
 URL:           http://www.gnu.org/software/gdb/
 BuildRequires: autoconf >= 2.53
 BuildRequires: automake
@@ -389,6 +390,7 @@ rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
 %patch1002 -p1
 %patch1005 -p1
 %patch1006 -p1
+%patch1007 -p1
 
 mv $(basename %{SOURCE4} .tar.bz2) libstdcxxpython
 
@@ -397,15 +399,17 @@ cat > gdb/version.in << EOF
 PLD Linux (%{version}-%{release})
 EOF
 
+sed -i -e 's#_GCC_AUTOCONF_VERSION\], \[2\.64\]#_GCC_AUTOCONF_VERSION], [2.65]#g' config/override.m4
+
 %build
-for dir in $(find gdb -name 'configure.in'); do
+for dir in $(find gdb -name 'configure.in' -o -name 'configure.ac'); do
        dir=$(dirname "$dir")
        olddir=$(pwd)
        cd $dir
        rm -f aclocal.m4
        %{__aclocal}
        %{__autoconf}
-       %{__autoheader}
+       grep -q AC_CONFIG_HEADER configure.* && %{__autoheader}
        cd $olddir
 done
 cp -f /usr/share/automake/config.* .
This page took 0.103699 seconds and 4 git commands to generate.