]> git.pld-linux.org Git - packages/gdb.git/commitdiff
- relase 7 (in RH is 6), gdb-4_18-7
authorkloczek <kloczek@pld-linux.org>
Mon, 22 Nov 1999 13:48:33 +0000 (13:48 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- added BuildRequires rules,
- build agains ncurses 5.0,
- added patches set from Mandrake.

Changed files:
    gdb.spec -> 1.16

gdb.spec

index e5c22564a9394a8a8d46f77eb0ac067fe8e6cbdd..fd8a9df8b4426c28bf3095e8dbddeb3aeb99c9c9 100644 (file)
--- a/gdb.spec
+++ b/gdb.spec
@@ -1,24 +1,31 @@
-Summary:       Symbolic debugger for C and other languages
+Summary:       A GNU source-level debugger for C, C++ and Fortran
 Summary(de):   Symbolischer Debugger für C und andere Sprachen 
 Summary(fr):   Débugger symbolique pour C et d'autres langages
 Summary(pl):   Symboliczny odpluskwiacz dla C i innych jêzyków
 Summary(tr):   C ve diðer diller için sembolik hata ayýklayýcý
 Name:          gdb
 Version:       4.18
-Release:       5
+Release:       7
 Copyright:     GPL
 Group:         Development/Debuggers
 Group(pl):     Programowanie/Odpluskwiacze
 Source:                ftp://sourceware.cygnus.com/pub/gdb/%{name}-%{version}.tar.bz2
 Patch0:                gdb-info.patch
+Patch1:                gdb-sigtramp.patch
+Patch2:                gdb-sparc.patch
+Patch3:                gdb-xref.patch
+Patch4:                gdb-sparcmin.patch
+Patch5:                gdb-threads.patch
+Patch6:                gdb-shared-readline.patch
 Prereq:                /usr/sbin/fix-info-dir
+BuildRequires: ncurses-devel >= 5.0
+BuildRequires: readline-devel
 Buildroot:     /tmp/%{name}-%{version}-root
 
 %description
-This is a full featured, command driven debugger. It allows you to
-trace the exectuion of programs and examine their internal state
-at any time. It works for C and C++ compiled with the GNU C compiler
-gcc.
+Gdb is a full featured, command driven debugger. Gdb allows you to trace the
+execution of programs and examine their internal state at any time. Gdb
+works for C and C++ compiled with the GNU C compiler gcc.
 
 %description -l de
 dem Sie die Ausführung von Programmen verfolgen und jederzeit den 
@@ -42,36 +49,39 @@ ve herhangi bir anda program
 
 %prep
 %setup -q
-%patch -p1
+%patch0 -p1
+%patch1 -p1
+%patch2 -p1
+%patch3 -p1
+%patch4 -p1
+%patch5 -p1
+%patch6 -p1
 
 %build
 CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
-./configure \
+./configure %{_target_platform} \
        --prefix=%{_prefix} \
        --infodir=%{_infodir} \
        --mandir=%{_mandir} \
-       %{_target_platform} 
+       --enable-shared
 
 make
 make info
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_prefix}
+install -d $RPM_BUILD_ROOT%{_infodir}
 
-make \
+make install \
        prefix=$RPM_BUILD_ROOT%{_prefix} \
        infodir=$RPM_BUILD_ROOT%{_infodir} \
-       mandir=$RPM_BUILD_ROOT%{_mandir} \
-       install
+       mandir=$RPM_BUILD_ROOT%{_mandir}
 
 # install by hand
 install gdb/doc/*.info* $RPM_BUILD_ROOT%{_infodir}
 
 strip $RPM_BUILD_ROOT%{_bindir}/*
 
-rm -f $RPM_BUILD_ROOT%{_infodir}{bfd*,history*,readline*,standard*,texinfo*}
-
 gzip -fn9 $RPM_BUILD_ROOT{%{_infodir}/*info*,%{_mandir}/man?/*}
 
 %post
@@ -88,5 +98,5 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/*
 
 %{_mandir}/man1/*
-%{_infodir}/gd*.info*
+%{_infodir}/gdb*.info*
 %{_infodir}/stabs*.info*
This page took 0.036698 seconds and 4 git commands to generate.