]> git.pld-linux.org Git - packages/gdb.git/commitdiff
- updated to 11.2 auto/th/gdb-11.2-1
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 19 Jan 2022 19:42:46 +0000 (20:42 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Wed, 19 Jan 2022 19:42:46 +0000 (20:42 +0100)
- removed obsolete glibc2.34 patch

gdb.spec
glibc2.34.patch [deleted file]

index b0531fe1cbd8d5e6552124d854a6bcc9c771d81f..9a76f00ad516dfacae7d4fa03670dd609c778fdd 100644 (file)
--- a/gdb.spec
+++ b/gdb.spec
@@ -21,16 +21,15 @@ Summary(uk.UTF-8):  Символьний відладчик для С та інш
 Summary(zh_CN.UTF-8):  [开发]C和其他语言的调试器
 Summary(zh_TW.UTF-8):  [.-A開發]C和.$)B其.-A他語.$)B言的調試器
 Name:          gdb
-Version:       11.1
+Version:       11.2
 Release:       1
 License:       GPL v3+
 Group:         Development/Debuggers
 Source0:       https://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.xz
-# Source0-md5: 257cb0f67927f79acf636d8c01e19990
+# Source0-md5: 433bd0904caa31c247b1b1867f2f911d
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: 2e8a48939ae282c12bbacdd54e398247
 Source3:       %{name}-gstack.man
-Patch0:                glibc2.34.patch
 Patch1:                x32.patch
 Patch100:      gdb-6.6-buildid-locate.patch
 Patch101:      gdb-6.6-buildid-locate-solib-missing-ids.patch
@@ -55,6 +54,7 @@ BuildRequires:        babeltrace-devel >= 1.1.0
 BuildRequires: expat-devel
 BuildRequires: flex >= 2.6.4
 BuildRequires: gettext-tools >= 0.12.1
+BuildRequires: gmp-devel
 %if %{with guile}
 BuildRequires: guile-devel >= 2.0
 BuildRequires: guile-devel < 3.2
@@ -62,6 +62,7 @@ BuildRequires:        guile-devel < 3.2
 %ifarch %{ix86} %{x8664}
 BuildRequires: libipt-devel
 %endif
+BuildRequires: libmpc-devel
 BuildRequires: libselinux-devel
 BuildRequires: libstdc++-devel >= 6:4.8
 BuildRequires: libtool
@@ -81,7 +82,7 @@ BuildRequires:        zlib-devel
 %if %{with python}
 BuildRequires: python3-devel
 BuildRequires: rpm-pythonprov
-Obsoletes:     python-gdb
+Obsoletes:     python-gdb < 7.3
 # for traceback module
 Requires:      python3-modules
 %endif
@@ -192,7 +193,6 @@ GDB w postaci biblioteki statycznej.
 %{__rm} gdb/ada-exp.c gdb/ada-lex.c gdb/c-exp.c gdb/cp-name-parser.c gdb/f-exp.c
 %{__rm} gdb/m2-exp.c gdb/p-exp.c
 
-%patch0 -p1
 %patch1 -p1
 %patch100 -p1
 %patch101 -p1
diff --git a/glibc2.34.patch b/glibc2.34.patch
deleted file mode 100644 (file)
index a6fc61b..0000000
+++ /dev/null
@@ -1,107 +0,0 @@
-From 39d53d04357606a15efd400147fa7369d71baf2c Mon Sep 17 00:00:00 2001
-From: Mike Frysinger <vapier@gentoo.org>
-Date: Sun, 3 Oct 2021 12:02:53 -0400
-Subject: [PATCH] sim: filter out SIGSTKSZ [PR sim/28302]
-
-We map target signals to host signals so we can propagate signals
-between the host & simulated worlds.  That means we need to know
-the symbolic names & values of all signals that might be sent.
-
-The tools that generate that list use signal.h and include all
-symbols that start with "SIG" so as to automatically include any
-new symbols that the C library might add.  Unfortunately, this
-also picks up "SIGSTKSZ" which is not actually a signal itself,
-but a signal related setting -- it's the size of the stack when
-a signal is handled.
-
-By itself this doesn't super matter as we will never see a signal
-with that same value (since the range of valid signals tend to be
-way less than 1024, and the size of the default signal stack will
-never be that small).  But with recent glibc changes that make this
-into a dynamic value instead of a compile-time constant, some users
-see build failures when building the sim.
-
-As suggested by Adam Sampson, update our scripts to ignore this
-symbol to simplify everything and avoid the build failure.
-
-Bug: https://sourceware.org/PR28302
----
- sim/bfin/linux-targ-map.h | 5 +----
- sim/common/gennltvals.py  | 6 ++++--
- sim/common/nltvals.def    | 1 -
- 3 files changed, 5 insertions(+), 7 deletions(-)
-
-diff --git a/sim/bfin/linux-targ-map.h b/sim/bfin/linux-targ-map.h
-index e9c8c8f273b..0340ed54764 100644
---- a/sim/bfin/linux-targ-map.h
-+++ b/sim/bfin/linux-targ-map.h
-@@ -30,6 +30,7 @@ echo
- # XXX: nothing uses this ?
- echo '#include <signal.h>' | \
- bfin-uclinux-gcc -E -dD -P - | \
-+grep -v SIGSTKSZ | \
- sed -r -n \
-     -e '1istatic CB_TARGET_DEFS_MAP cb_linux_signal_map[] = {' \
-     -e '$i\ \ { 0, -1, -1 }\n};' \
-@@ -1987,10 +1988,6 @@ static CB_TARGET_DEFS_MAP cb_linux_signal_map[] =
- #ifdef SIG_SETMASK
- # define TARGET_LINUX_SIG_SETMASK 2
-   { "SIG_SETMASK", SIG_SETMASK, TARGET_LINUX_SIG_SETMASK },
--#endif
--#ifdef SIGSTKSZ
--# define TARGET_LINUX_SIGSTKSZ 8192
--  { "SIGSTKSZ", SIGSTKSZ, TARGET_LINUX_SIGSTKSZ },
- #endif
-   { 0, -1, -1 }
- };
-diff --git a/sim/common/gennltvals.py b/sim/common/gennltvals.py
-index db3ff641d40..955ace34311 100755
---- a/sim/common/gennltvals.py
-+++ b/sim/common/gennltvals.py
-@@ -67,6 +67,7 @@ FILE_HEADER = f"""\
- def gentvals(output: TextIO, cpp: str, srctype: str, srcdir: Path,
-              headers: Iterable[str],
-              pattern: str,
-+             filter: str = r'^$',
-              target: str = None):
-     """Extract constants from the specified files using a regular expression.
-@@ -94,12 +95,13 @@ def gentvals(output: TextIO, cpp: str, srctype: str, srcdir: Path,
-     srcfile = ''.join(f'#include <{x}>\n' for x in headers)
-     syms = set()
-     define_pattern = re.compile(r'^#\s*define\s+(' + pattern + ')')
-+    filter_pattern = re.compile(filter)
-     for header in headers:
-         with open(srcdir / header, 'r', encoding='utf-8') as fp:
-             data = fp.read()
-         for line in data.splitlines():
-             m = define_pattern.match(line)
--            if m:
-+            if m and not filter_pattern.search(line):
-                 syms.add(m.group(1))
-     for sym in sorted(syms):
-         srcfile += f'#ifdef {sym}\nDEFVAL {{ "{sym}", {sym} }},\n#endif\n'
-@@ -129,7 +131,7 @@ def gen_common(output: TextIO, newlib: Path, cpp: str):
-              ('errno.h', 'sys/errno.h'), 'E[A-Z0-9]*')
-     gentvals(output, cpp, 'signal', newlib / 'newlib/libc/include',
--             ('signal.h', 'sys/signal.h'), r'SIG[A-Z0-9]*')
-+             ('signal.h', 'sys/signal.h'), r'SIG[A-Z0-9]*', filter=r'SIGSTKSZ')
-     gentvals(output, cpp, 'open', newlib / 'newlib/libc/include',
-              ('fcntl.h', 'sys/fcntl.h', 'sys/_default_fcntl.h'), r'O_[A-Z0-9]*')
-diff --git a/sim/common/nltvals.def b/sim/common/nltvals.def
-index 8ae88397249..8bc6ae59026 100644
---- a/sim/common/nltvals.def
-+++ b/sim/common/nltvals.def
-@@ -116,7 +116,6 @@
-  { "SIGPROF", 27 },
-  { "SIGQUIT", 3 },
-  { "SIGSEGV", 11 },
-- { "SIGSTKSZ", 8192 },
-  { "SIGSTOP", 17 },
-  { "SIGSYS", 12 },
-  { "SIGTERM", 15 },
--- 
-2.27.0
-
This page took 0.056899 seconds and 4 git commands to generate.