]> git.pld-linux.org Git - packages/gdb.git/commitdiff
- no subshells gdb-5_2-1
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 23 May 2002 18:10:58 +0000 (18:10 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- added second section to passflags patch, now gdb builds

Changed files:
    gdb-passflags.patch -> 1.2
    gdb.spec -> 1.58

gdb-passflags.patch
gdb.spec

index 56d630befb6e4461f2f46b0d5a8f3f4824e63961..71fe27b5f3b87d671102bda578fb50f06cd990e6 100644 (file)
@@ -22,3 +22,14 @@ diff -ur gdb-5.1.1/sim/Makefile.in gdb-5.1.1-/sim/Makefile.in
        "against=$(against)" \
        "AR=$(AR)" \
        "AR_FLAGS=$(AR_FLAGS)" \
+--- gdb-5.2/gdb/Makefile.in.orig       Thu May 23 19:37:49 2002
++++ gdb-5.2/gdb/Makefile.in    Thu May 23 20:00:03 2002
+@@ -410,6 +410,8 @@
+ FLAGS_TO_PASS = \
+       "prefix=$(prefix)" \
++      "bindir=$(bindir)" \
++      "mandir=$(mandir)" \
+       "infodir=$(infodir)" \
+       "exec_prefix=$(exec_prefix)" \
+       "infodir=$(infodir)" \
index 473ea90b00666e275e40dbb266d88d23c725090f..f1cb1d0e811968dc010787bd8c9ded29b8395a79 100644 (file)
--- a/gdb.spec
+++ b/gdb.spec
@@ -20,11 +20,11 @@ Patch2:             %{name}-readline.patch
 Patch3:                %{name}-info.patch
 Patch4:                %{name}-procfs.patch
 Patch5:                %{name}-passflags.patch
-BuildRequires: ncurses-devel >= 5.2
-BuildRequires: readline-devel >= 4.2
 BuildRequires: XFree86-devel
 BuildRequires: autoconf >= 2.53
 BuildRequires: libtool
+BuildRequires: ncurses-devel >= 5.2
+BuildRequires: readline-devel >= 4.2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -89,21 +89,37 @@ verir.
 %patch5 -p1
 
 %build
-(cd gdb; autoconf)
-(cd gdb/doc; autoconf)
-(cd gdb/testsuite; autoconf)
-(cd gdb/testsuite/gdb.asm; autoconf)
-(cd gdb/testsuite/gdb.base; autoconf)
-(cd gdb/testsuite/gdb.c++; autoconf)
-(cd gdb/testsuite/gdb.chill; autoconf)
-(cd gdb/testsuite/gdb.disasm; autoconf)
-(cd gdb/testsuite/gdb.fortran; autoconf)
-(cd gdb/testsuite/gdb.java; autoconf)
-(cd gdb/testsuite/gdb.mi; autoconf)
-(cd gdb/testsuite/gdb.stabs; autoconf)
-(cd gdb/testsuite/gdb.threads; autoconf)
-(cd gdb/testsuite/gdb.trace; autoconf)
-(cd gdb/gdbserver; autoconf)
+cd gdb
+%{__autoconf}
+cd doc
+%{__autoconf}
+cd ../testsuite
+%{__autoconf}
+cd gdb.asm
+%{__autoconf}
+cd ../gdb.base
+%{__autoconf}
+cd ../gdb.c++
+%{__autoconf}
+cd ../gdb.chill
+%{__autoconf}
+cd ../gdb.disasm
+%{__autoconf}
+#cd ../gdb.fortran
+#%{__autoconf}
+cd ../gdb.java
+%{__autoconf}
+cd ../gdb.mi
+%{__autoconf}
+cd ../gdb.stabs
+%{__autoconf}
+cd ../gdb.threads
+%{__autoconf}
+cd ../gdb.trace
+%{__autoconf}
+cd ../../gdbserver
+%{__autoconf}
+cd ../..
 # !! Don't enable shared here !!
 # This will cause serious problems --misiek
 %configure2_13 \
@@ -118,13 +134,13 @@ verir.
        --with-cpu=%{_target_cpu} \
        --enable-tui \
 %ifnarch alpha
-       --with-mmalloc \
+       --with-mmalloc
 %endif
 
 # something is wrong after above - e.g. $exeext=="no" - fix it:
-(cd gdb
+cd gdb
 %configure
-)
+cd ..
 
 %{__make}
 %{__make} info
This page took 0.041087 seconds and 4 git commands to generate.