]> git.pld-linux.org Git - packages/gdb.git/commitdiff
- added info directory fixes to info patch gdb-5_0-7
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 4 Aug 2001 17:39:54 +0000 (17:39 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- rebuild each configure in gdb tree
- libtoolize in gdb (to remove 'no' extension from filenames :/)
- ...but %%configure2_13 must be used, main configure is not autoconf-generated
- release 7

Changed files:
    gdb-info.patch -> 1.6
    gdb.spec -> 1.39

gdb-info.patch
gdb.spec

index e0ccce8c3f97172c1e3d5a7b7b00de95326ed8f6..efae2739f8b17d6e07d01b62b9f48fc4d94e7d1f 100644 (file)
@@ -9,3 +9,69 @@ diff -urN gdb-5.0.org/gdb/Makefile.in gdb-5.0/gdb/Makefile.in
        "exec_prefix=$(exec_prefix)" \
        "against=$(against)" \
        "AR=$(AR)" \
+diff -Nur gdb-5.0.orig/gdb/doc/gdb.texinfo gdb-5.0/gdb/doc/gdb.texinfo
+--- gdb-5.0.orig/gdb/doc/gdb.texinfo   Fri May 12 12:30:39 2000
++++ gdb-5.0/gdb/doc/gdb.texinfo        Sat Aug  4 16:37:53 2001
+@@ -39,9 +39,9 @@
+ @c This is a dir.info fragment to support semi-automated addition of
+ @c manuals to an info tree.
+-@dircategory Programming & development tools.
++@dircategory Programming tools:
+ @direntry
+-* Gdb: (gdb).                     The @sc{gnu} debugger.
++* Gdb: (gdb).                         The @sc{gnu} debugger.
+ @end direntry
+ @ifinfo
+diff -Nur gdb-5.0.orig/gdb/doc/gdbgui.texinfo gdb-5.0/gdb/doc/gdbgui.texinfo
+--- gdb-5.0.orig/gdb/doc/gdbgui.texinfo        Mon Feb  7 01:19:39 2000
++++ gdb-5.0/gdb/doc/gdbgui.texinfo     Sat Aug  4 16:38:31 2001
+@@ -43,9 +43,10 @@
+ @c This is a dir.info fragment to support semi-automated addition of
+ @c manuals to an info tree.  zoo@cygnus.com is developing this facility.
+ @format
+-START-INFO-DIR-ENTRY
+-* Gdb: (gdb).                     The GNU debugger.
+-END-INFO-DIR-ENTRY
++@dircategory Programming tools:
++@direntry
++* Gdb: (gdb).                         The GNU debugger.
++@end direntry
+ @end format
+ @end ifinfo
+ @c
+diff -Nur gdb-5.0.orig/gdb/doc/gdbint.texinfo gdb-5.0/gdb/doc/gdbint.texinfo
+--- gdb-5.0.orig/gdb/doc/gdbint.texinfo        Wed Apr 12 07:16:56 2000
++++ gdb-5.0/gdb/doc/gdbint.texinfo     Sat Aug  4 16:39:49 2001
+@@ -3,9 +3,10 @@
+ @ifinfo
+ @format
+-START-INFO-DIR-ENTRY
+-* Gdb-Internals: (gdbint).    The GNU debugger's internals.
+-END-INFO-DIR-ENTRY
++@dircategory Programming tools:
++@direntry
++* Gdb-Internals: (gdbint).            The GNU debugger's internals.
++@end direntry
+ @end format
+ @end ifinfo
+diff -Nur gdb-5.0.orig/gdb/doc/stabs.texinfo gdb-5.0/gdb/doc/stabs.texinfo
+--- gdb-5.0.orig/gdb/doc/stabs.texinfo Mon Jun 28 18:02:18 1999
++++ gdb-5.0/gdb/doc/stabs.texinfo      Sat Aug  4 16:40:42 2001
+@@ -5,9 +5,10 @@
+ @ifinfo
+ @format
+-START-INFO-DIR-ENTRY
+-* Stabs: (stabs).                 The "stabs" debugging information format.
+-END-INFO-DIR-ENTRY
++@dircategory Programming tools:
++@direntry
++* Stabs: (stabs).                     The "stabs" debugging information format.
++@end direntry
+ @end format
+ @end ifinfo
index d521e8254d412a92c827603a0e8a63ade0130e94..247f4517b0ec2a319a9e90a5067d748d07fd8433 100644 (file)
--- a/gdb.spec
+++ b/gdb.spec
@@ -5,7 +5,7 @@ Summary(pl):    Symboliczny odpluskwiacz dla C i innych j
 Summary(tr):   C ve diðer diller için sembolik hata ayýklayýcý
 Name:          gdb
 Version:       5.0
-Release:       6
+Release:       7
 License:       GPL
 Group:         Development/Debuggers
 Group(pl):     Programowanie/Odpluskwiacze
@@ -19,6 +19,8 @@ Patch4:               %{name}-procfs.patch
 BuildRequires: ncurses-devel >= 5.2
 BuildRequires: readline-devel >= 4.2
 BuildRequires: XFree86-devel
+BuildRequires: autoconf
+BuildRequires: automake
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -58,10 +60,22 @@ verir.
 %patch4 -p1
 
 %build
-(cd gdb; aclocal; autoconf; cd ..)
+(cd gdb; libtoolize --copy --force; aclocal; autoconf)
+(cd gdb/doc; autoconf)
+(cd gdb/testsuite; autoconf)
+(cd gdb/testsuite/gdb.asm; autoconf)
+(cd gdb/testsuite/gdb.base; autoconf)
+(cd gdb/testsuite/gdb.c++; autoconf)
+(cd gdb/testsuite/gdb.disasm; autoconf)
+(cd gdb/testsuite/gdb.chill; autoconf)
+(cd gdb/testsuite/gdb.mi; autoconf)
+(cd gdb/testsuite/gdb.threads; autoconf)
+(cd gdb/testsuite/gdb.trace; autoconf)
+(cd gdb/testsuite/gdb.stabs; autoconf)
+(cd gdb/gdbserver; autoconf)
 # !! Don't enable shared here !! 
 # This will cause serious problems --misiek
-%configure \
+%configure2_13 \
        --disable-shared \
        --enable-nls \
        --without-included-gettext \
@@ -77,7 +91,7 @@ verir.
 #      --enable-tui
 
 # rebuild main Makefile again (due to some bug, Makefile is deleted)
-%configure \
+%configure2_13 \
        --norecursion
                        
 %{__make}
This page took 0.043554 seconds and 4 git commands to generate.