]> git.pld-linux.org Git - packages/gdb.git/commitdiff
- update bfd/section for latest binutils
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 30 Jul 2013 20:15:24 +0000 (22:15 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Tue, 30 Jul 2013 20:15:24 +0000 (22:15 +0200)
- fix info build with texinfo 5.1
- rel 3

gdb.spec
std_section.patch [new file with mode: 0644]
texinfo.patch [new file with mode: 0644]

index f35a027b9b25ce434a0be4710184c50ceff415a8..b3a3b50a54f8f6515dff1f4a578d84895ca4fb3a 100644 (file)
--- a/gdb.spec
+++ b/gdb.spec
@@ -21,7 +21,7 @@ Summary(zh_TW.UTF-8): [.-A開發]C和.$)B其.-A他語.$)B言的調試器
 %define                snap    20120926
 Name:          gdb
 Version:       7.5.0
-Release:       0.%{snap}.2
+Release:       0.%{snap}.3
 License:       GPL v3+
 Group:         Development/Debuggers
 #Source0:      http://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.bz2
@@ -161,6 +161,8 @@ Patch1001:  %{name}-info.patch
 Patch1002:     %{name}-passflags.patch
 Patch1005:     %{name}-pretty-print-by-default.patch
 Patch1006:     buildid-locate-rpm-pld.patch
+Patch1007:     std_section.patch
+Patch1008:     stexinfo.patch
 
 URL:           http://www.gnu.org/software/gdb/
 BuildRequires: autoconf >= 2.69
@@ -420,6 +422,8 @@ rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
 %patch1002 -p1
 %patch1005 -p1
 %patch1006 -p1
+%patch1007 -p1
+%patch1008 -p1
 
 # Change the version that gets printed at GDB startup, so it is PLD Linux specific.
 cat > gdb/version.in << EOF
diff --git a/std_section.patch b/std_section.patch
new file mode 100644 (file)
index 0000000..a0eddfb
--- /dev/null
@@ -0,0 +1,70 @@
+--- gdb-7.5/bfd/section.c      2012-06-29 16:46:03.000000000 +0200
++++ gdb-7.6/bfd/section.c      2013-01-26 03:08:01.000000000 +0100
+@@ -545,7 +545,7 @@
+ .{* These sections are global, and are managed by BFD.  The application
+ .   and target back end are not permitted to change the values in
+ .   these sections.  *}
+-.extern asection std_section[4];
++.extern asection _bfd_std_section[4];
+ .
+ .#define BFD_ABS_SECTION_NAME "*ABS*"
+ .#define BFD_UND_SECTION_NAME "*UND*"
+@@ -553,13 +553,13 @@
+ .#define BFD_IND_SECTION_NAME "*IND*"
+ .
+ .{* Pointer to the common section.  *}
+-.#define bfd_com_section_ptr (&std_section[0])
++.#define bfd_com_section_ptr (&_bfd_std_section[0])
+ .{* Pointer to the undefined section.  *}
+-.#define bfd_und_section_ptr (&std_section[1])
++.#define bfd_und_section_ptr (&_bfd_std_section[1])
+ .{* Pointer to the absolute section.  *}
+-.#define bfd_abs_section_ptr (&std_section[2])
++.#define bfd_abs_section_ptr (&_bfd_std_section[2])
+ .{* Pointer to the indirect section.  *}
+-.#define bfd_ind_section_ptr (&std_section[3])
++.#define bfd_ind_section_ptr (&_bfd_std_section[3])
+ .
+ .#define bfd_is_und_section(sec) ((sec) == bfd_und_section_ptr)
+ .#define bfd_is_abs_section(sec) ((sec) == bfd_abs_section_ptr)
+@@ -725,9 +725,9 @@
+ };
+ #define STD_SECTION(NAME, IDX, FLAGS) \
+-  BFD_FAKE_SECTION(std_section[IDX], FLAGS, &global_syms[IDX], NAME, IDX)
++  BFD_FAKE_SECTION(_bfd_std_section[IDX], FLAGS, &global_syms[IDX], NAME, IDX)
+-asection std_section[] = {
++asection _bfd_std_section[] = {
+   STD_SECTION (BFD_COM_SECTION_NAME, 0, SEC_IS_COMMON),
+   STD_SECTION (BFD_UND_SECTION_NAME, 1, 0),
+   STD_SECTION (BFD_ABS_SECTION_NAME, 2, 0),
+--- gdb-7.5.0.20120926/bfd/bfd-in2.h   2012-07-13 17:47:23.000000000 +0200
++++ gdb-7.6/bfd/bfd-in2.h      2013-02-27 22:39:18.000000000 +0100
+@@ -1547,7 +1575,7 @@
+ /* These sections are global, and are managed by BFD.  The application
+    and target back end are not permitted to change the values in
+    these sections.  */
+-extern asection std_section[4];
++extern asection _bfd_std_section[4];
+ #define BFD_ABS_SECTION_NAME "*ABS*"
+ #define BFD_UND_SECTION_NAME "*UND*"
+@@ -1555,13 +1583,13 @@
+ #define BFD_IND_SECTION_NAME "*IND*"
+ /* Pointer to the common section.  */
+-#define bfd_com_section_ptr (&std_section[0])
++#define bfd_com_section_ptr (&_bfd_std_section[0])
+ /* Pointer to the undefined section.  */
+-#define bfd_und_section_ptr (&std_section[1])
++#define bfd_und_section_ptr (&_bfd_std_section[1])
+ /* Pointer to the absolute section.  */
+-#define bfd_abs_section_ptr (&std_section[2])
++#define bfd_abs_section_ptr (&_bfd_std_section[2])
+ /* Pointer to the indirect section.  */
+-#define bfd_ind_section_ptr (&std_section[3])
++#define bfd_ind_section_ptr (&_bfd_std_section[3])
+ #define bfd_is_und_section(sec) ((sec) == bfd_und_section_ptr)
+ #define bfd_is_abs_section(sec) ((sec) == bfd_abs_section_ptr)
diff --git a/texinfo.patch b/texinfo.patch
new file mode 100644 (file)
index 0000000..0a63831
--- /dev/null
@@ -0,0 +1,20 @@
+--- gdb-7.5.0.20120926/bfd/doc/bfd.texinfo~    2010-10-28 13:40:25.000000000 +0200
++++ gdb-7.5.0.20120926/bfd/doc/bfd.texinfo     2013-07-30 22:12:05.761876536 +0200
+@@ -322,7 +322,7 @@
+ @printindex cp
+ @tex
+-% I think something like @colophon should be in texinfo.  In the
++% I think something like @@colophon should be in texinfo.  In the
+ % meantime:
+ \long\def\colophon{\hbox to0pt{}\vfill
+ \centerline{The body of this manual is set in}
+@@ -333,7 +333,7 @@
+ \centerline{{\sl\fontname\tensl\/}}
+ \centerline{are used for emphasis.}\vfill}
+ \page\colophon
+-% Blame: doc@cygnus.com, 28mar91.
++% Blame: doc@@cygnus.com, 28mar91.
+ @end tex
+ @bye
This page took 0.282413 seconds and 4 git commands to generate.