]> git.pld-linux.org Git - packages/gdb.git/commitdiff
387714d487d849596d468d691b2337a5 vcd-1.5.tar.gz
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 6 Sep 2000 13:14:45 +0000 (13:14 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
6b1c9c98225757c26f91083b233da0ff  liveice.tar.gz
21ebeb1c2fb04ca9ef6dbae842cc1687  beav140s.zip

Changed files:
    gdb-gettext.patch -> 1.1
    gdb-info.patch -> 1.4
    gdb-ncurses.patch -> 1.1
    gdb-readline.patch -> 1.1

gdb-gettext.patch [new file with mode: 0644]
gdb-info.patch [deleted file]
gdb-ncurses.patch [new file with mode: 0644]
gdb-readline.patch [new file with mode: 0644]

diff --git a/gdb-gettext.patch b/gdb-gettext.patch
new file mode 100644 (file)
index 0000000..4c79413
--- /dev/null
@@ -0,0 +1,270 @@
+diff -urN gdb-5.0.org/gdb/acinclude.m4 gdb-5.0/gdb/acinclude.m4
+--- gdb-5.0.org/gdb/acinclude.m4       Tue Sep  5 16:45:26 2000
++++ gdb-5.0/gdb/acinclude.m4   Tue Sep  5 17:32:45 2000
+@@ -859,3 +859,266 @@
+     AC_SUBST(TIX_BUILD_LIB_SPEC)
+ dnl    AC_SUBST(TIX_LIB_SPEC)
+ ])
++
++AC_DEFUN(CY_WITH_NLS,
++  [AC_MSG_CHECKING([whether NLS is requested])
++    dnl Default is enabled NLS
++    AC_ARG_ENABLE(nls,
++      [  --disable-nls           do not use Native Language Support],
++      USE_NLS=$enableval, USE_NLS=yes)
++    AC_MSG_RESULT($USE_NLS)
++    AC_SUBST(USE_NLS)
++
++    USE_INCLUDED_LIBINTL=no
++
++    dnl If we use NLS figure out what method
++    if test "$USE_NLS" = "yes"; then
++      AC_DEFINE(ENABLE_NLS)
++      AC_MSG_CHECKING([whether included gettext is requested])
++      AC_ARG_WITH(included-gettext,
++        [  --with-included-gettext use the GNU gettext library included here],
++        nls_cv_force_use_gnu_gettext=$withval,
++        nls_cv_force_use_gnu_gettext=no)
++      AC_MSG_RESULT($nls_cv_force_use_gnu_gettext)
++
++      nls_cv_use_gnu_gettext="$nls_cv_force_use_gnu_gettext"
++      if test "$nls_cv_force_use_gnu_gettext" != "yes"; then
++        dnl User does not insist on using GNU NLS library.  Figure out what
++        dnl to use.  If gettext or catgets are available (in this order) we
++        dnl use this.  Else we have to fall back to GNU NLS library.
++      dnl catgets is only used if permitted by option --with-catgets.
++      nls_cv_header_intl=
++      nls_cv_header_libgt=
++      CATOBJEXT=NONE
++
++      AC_CHECK_HEADER(libintl.h,
++        [AC_CACHE_CHECK([for gettext in libc], gt_cv_func_gettext_libc,
++          [AC_TRY_LINK([#include <libintl.h>], [return (int) gettext ("")],
++             gt_cv_func_gettext_libc=yes, gt_cv_func_gettext_libc=no)])
++
++         if test "$gt_cv_func_gettext_libc" != "yes"; then
++           AC_CHECK_LIB(intl, bindtextdomain,
++             [AC_CACHE_CHECK([for gettext in libintl],
++               gt_cv_func_gettext_libintl,
++               [AC_TRY_LINK([], [return (int) gettext ("")],
++               gt_cv_func_gettext_libintl=yes,
++               gt_cv_func_gettext_libintl=no)])])
++         fi
++
++         if test "$gt_cv_func_gettext_libc" = "yes" \
++            || test "$gt_cv_func_gettext_libintl" = "yes"; then
++            AC_DEFINE(HAVE_GETTEXT)
++            AM_PATH_PROG_WITH_TEST(MSGFMT, msgfmt,
++              [test -z "`$ac_dir/$ac_word -h 2>&1 | grep 'dv '`"], no)dnl
++            if test "$MSGFMT" != "no"; then
++              AC_CHECK_FUNCS(dcgettext)
++              AC_PATH_PROG(GMSGFMT, gmsgfmt, $MSGFMT)
++              AM_PATH_PROG_WITH_TEST(XGETTEXT, xgettext,
++                [test -z "`$ac_dir/$ac_word -h 2>&1 | grep '(HELP)'`"], :)
++              AC_TRY_LINK(, [extern int _nl_msg_cat_cntr;
++                             return _nl_msg_cat_cntr],
++                [CATOBJEXT=.gmo
++                 DATADIRNAME=share],
++                [CATOBJEXT=.mo
++                 DATADIRNAME=lib])
++              INSTOBJEXT=.mo
++            fi
++          fi
++      ])
++
++      dnl In the standard gettext, we would now check for catgets.
++        dnl However, we never want to use catgets for our releases.
++
++        if test "$CATOBJEXT" = "NONE"; then
++        dnl Neither gettext nor catgets in included in the C library.
++        dnl Fall back on GNU gettext library.
++        nls_cv_use_gnu_gettext=yes
++        fi
++      fi
++
++      if test "$nls_cv_use_gnu_gettext" = "yes"; then
++        dnl Mark actions used to generate GNU NLS library.
++        INTLOBJS="\$(GETTOBJS)"
++        AM_PATH_PROG_WITH_TEST(MSGFMT, msgfmt,
++        [test -z "`$ac_dir/$ac_word -h 2>&1 | grep 'dv '`"], msgfmt)
++        AC_PATH_PROG(GMSGFMT, gmsgfmt, $MSGFMT)
++        AM_PATH_PROG_WITH_TEST(XGETTEXT, xgettext,
++        [test -z "`$ac_dir/$ac_word -h 2>&1 | grep '(HELP)'`"], :)
++        AC_SUBST(MSGFMT)
++      USE_INCLUDED_LIBINTL=yes
++        CATOBJEXT=.gmo
++        INSTOBJEXT=.mo
++        DATADIRNAME=share
++      INTLDEPS='$(top_builddir)/../intl/libintl.a'
++      INTLLIBS=$INTLDEPS
++      LIBS=`echo $LIBS | sed -e 's/-lintl//'`
++        nls_cv_header_intl=libintl.h
++        nls_cv_header_libgt=libgettext.h
++      fi
++
++      dnl Test whether we really found GNU xgettext.
++      if test "$XGETTEXT" != ":"; then
++      dnl If it is no GNU xgettext we define it as : so that the
++      dnl Makefiles still can work.
++      if $XGETTEXT --omit-header /dev/null 2> /dev/null; then
++        : ;
++      else
++        AC_MSG_RESULT(
++          [found xgettext programs is not GNU xgettext; ignore it])
++        XGETTEXT=":"
++      fi
++      fi
++
++      # We need to process the po/ directory.
++      POSUB=po
++    else
++      DATADIRNAME=share
++      nls_cv_header_intl=libintl.h
++      nls_cv_header_libgt=libgettext.h
++    fi
++
++    # If this is used in GNU gettext we have to set USE_NLS to `yes'
++    # because some of the sources are only built for this goal.
++    if test "$PACKAGE" = gettext; then
++      USE_NLS=yes
++      USE_INCLUDED_LIBINTL=yes
++    fi
++
++    dnl These rules are solely for the distribution goal.  While doing this
++    dnl we only have to keep exactly one list of the available catalogs
++    dnl in configure.in.
++    for lang in $ALL_LINGUAS; do
++      GMOFILES="$GMOFILES $lang.gmo"
++      POFILES="$POFILES $lang.po"
++    done
++
++    dnl Make all variables we use known to autoconf.
++    AC_SUBST(USE_INCLUDED_LIBINTL)
++    AC_SUBST(CATALOGS)
++    AC_SUBST(CATOBJEXT)
++    AC_SUBST(DATADIRNAME)
++    AC_SUBST(GMOFILES)
++    AC_SUBST(INSTOBJEXT)
++    AC_SUBST(INTLDEPS)
++    AC_SUBST(INTLLIBS)
++    AC_SUBST(INTLOBJS)
++    AC_SUBST(POFILES)
++    AC_SUBST(POSUB)
++  ])
++
++AC_DEFUN(CY_GNU_GETTEXT,
++  [AC_REQUIRE([AC_PROG_MAKE_SET])dnl
++   AC_REQUIRE([AC_PROG_CC])dnl
++   AC_REQUIRE([AC_PROG_RANLIB])dnl
++   AC_REQUIRE([AC_ISC_POSIX])dnl
++   AC_REQUIRE([AC_HEADER_STDC])dnl
++   AC_REQUIRE([AC_C_CONST])dnl
++   AC_REQUIRE([AC_C_INLINE])dnl
++   AC_REQUIRE([AC_TYPE_OFF_T])dnl
++   AC_REQUIRE([AC_TYPE_SIZE_T])dnl
++   AC_REQUIRE([AC_FUNC_ALLOCA])dnl
++   AC_REQUIRE([AC_FUNC_MMAP])dnl
++
++   AC_CHECK_HEADERS([argz.h limits.h locale.h nl_types.h malloc.h string.h \
++unistd.h values.h sys/param.h])
++   AC_CHECK_FUNCS([getcwd munmap putenv setenv setlocale strchr strcasecmp \
++__argz_count __argz_stringify __argz_next])
++
++   if test "${ac_cv_func_stpcpy+set}" != "set"; then
++     AC_CHECK_FUNCS(stpcpy)
++   fi
++   if test "${ac_cv_func_stpcpy}" = "yes"; then
++     AC_DEFINE(HAVE_STPCPY, 1, [Define if you have the stpcpy function])
++   fi
++
++   AM_LC_MESSAGES
++   CY_WITH_NLS
++
++   if test "x$CATOBJEXT" != "x"; then
++     if test "x$ALL_LINGUAS" = "x"; then
++       LINGUAS=
++     else
++       AC_MSG_CHECKING(for catalogs to be installed)
++       NEW_LINGUAS=
++       for lang in ${LINGUAS=$ALL_LINGUAS}; do
++         case "$ALL_LINGUAS" in
++          *$lang*) NEW_LINGUAS="$NEW_LINGUAS $lang" ;;
++         esac
++       done
++       LINGUAS=$NEW_LINGUAS
++       AC_MSG_RESULT($LINGUAS)
++     fi
++
++     dnl Construct list of names of catalog files to be constructed.
++     if test -n "$LINGUAS"; then
++       for lang in $LINGUAS; do CATALOGS="$CATALOGS $lang$CATOBJEXT"; done
++     fi
++   fi
++
++   dnl The reference to <locale.h> in the installed <libintl.h> file
++   dnl must be resolved because we cannot expect the users of this
++   dnl to define HAVE_LOCALE_H.
++   if test $ac_cv_header_locale_h = yes; then
++     INCLUDE_LOCALE_H="#include <locale.h>"
++   else
++     INCLUDE_LOCALE_H="\
++/* The system does not provide the header <locale.h>.  Take care yourself.  */"
++   fi
++   AC_SUBST(INCLUDE_LOCALE_H)
++
++   dnl Determine which catalog format we have (if any is needed)
++   dnl For now we know about two different formats:
++   dnl   Linux libc-5 and the normal X/Open format
++   if test -f $srcdir/po2tbl.sed.in; then
++      if test "$CATOBJEXT" = ".cat"; then
++       AC_CHECK_HEADER(linux/version.h, msgformat=linux, msgformat=xopen)
++
++       dnl Transform the SED scripts while copying because some dumb SEDs
++         dnl cannot handle comments.
++       sed -e '/^#/d' $srcdir/$msgformat-msg.sed > po2msg.sed
++      fi
++      dnl po2tbl.sed is always needed.
++      sed -e '/^#.*[^\\]$/d' -e '/^#$/d' \
++       $srcdir/po2tbl.sed.in > po2tbl.sed
++   fi
++
++   dnl In the intl/Makefile.in we have a special dependency which makes
++   dnl only sense for gettext.  We comment this out for non-gettext
++   dnl packages.
++   if test "$PACKAGE" = "gettext"; then
++     GT_NO="#NO#"
++     GT_YES=
++   else
++     GT_NO=
++     GT_YES="#YES#"
++   fi
++   AC_SUBST(GT_NO)
++   AC_SUBST(GT_YES)
++
++   MKINSTALLDIRS="\$(srcdir)/../../mkinstalldirs"
++   AC_SUBST(MKINSTALLDIRS)
++
++   dnl *** For now the libtool support in intl/Makefile is not for real.
++   l=
++   AC_SUBST(l)
++
++   dnl Generate list of files to be processed by xgettext which will
++   dnl be included in po/Makefile.  But only do this if the po directory
++   dnl exists in srcdir.
++   if test -d $srcdir/po; then
++      test -d po || mkdir po
++      if test "x$srcdir" != "x."; then
++       if test "x`echo $srcdir | sed 's@/.*@@'`" = "x"; then
++          posrcprefix="$srcdir/"
++       else
++          posrcprefix="../$srcdir/"
++       fi
++      else
++       posrcprefix="../"
++      fi
++      rm -f po/POTFILES
++      sed -e "/^#/d" -e "/^\$/d" -e "s,.*,    $posrcprefix& \\\\," -e "\$s/\(.*\) \\\\/\1/" \
++       < $srcdir/po/POTFILES.in > po/POTFILES
++   fi
++  ])
++
diff --git a/gdb-info.patch b/gdb-info.patch
deleted file mode 100644 (file)
index 0c880c0..0000000
+++ /dev/null
@@ -1,145 +0,0 @@
-diff -Nru gdb-4.18/gdb/doc/gdb.texinfo gdb-4.18.new/gdb/doc/gdb.texinfo
---- gdb-4.18/gdb/doc/gdb.texinfo       Mon Nov 22 15:04:50 1999
-+++ gdb-4.18.new/gdb/doc/gdb.texinfo   Mon Nov 22 15:05:13 1999
-@@ -41,9 +41,10 @@
- @c This is a dir.info fragment to support semi-automated addition of
- @c manuals to an info tree.  zoo@cygnus.com is developing this facility.
- @format
--START-INFO-DIR-ENTRY
--* Gdb: (gdb).                     The @sc{gnu} debugger.
--END-INFO-DIR-ENTRY
-+@dircategory Programming tools:
-+@direntry
-+* Gdb: (gdb).                         The @sc{gnu} debugger
-+@end direntry
- @end format
- @end ifinfo
- @c
-@@ -189,8 +190,10 @@
- @end ifclear
--* Command Line Editing::        Command Line Editing
--* Using History Interactively:: Using History Interactively
-+* Command Line Editing: (readline)Command Line Editing.
-+                              Command Line Editing
-+* Using History Interactively: (readline)Readline Movement Commands.
-+                              Using History Interactively
- * Installing GDB::              Installing GDB
- * Index::                       Index
-@@ -4644,7 +4647,7 @@
- by preprocessor @code{#define} commands.
- @value{GDBN} now supports array constants in expressions input by
--the user.  The syntax is @var{@{element, element@dots{}@}}.  For example,
-+the user.  The syntax is @var{@{element element@dots{}@}}.  For example,
- you can now use the command @code{print @{1, 2, 3@}} to build up an array in 
- memory that is malloc'd in the target program.
-@@ -5281,7 +5284,7 @@
- @kindex set print null-stop
- @item set print null-stop
- Cause @value{GDBN} to stop printing the characters of an array when the first
--@sc{NULL} is encountered.  This is useful when large arrays actually
-+@sc{null} is encountered.  This is useful when large arrays actually
- contain only short strings.
- @kindex set print pretty
-@@ -6528,7 +6531,7 @@
- @item
- Character constants are a single character surrounded by single quotes
- (@code{'}), or a number---the ordinal value of the corresponding character
--(usually its @sc{ASCII} value).  Within quotes, the single character may
-+(usually its @sc{ascii} value).  Within quotes, the single character may
- be represented by a letter or by @dfn{escape sequences}, which are of
- the form @samp{\@var{nnn}}, where @var{nnn} is the octal representation
- of the character's ordinal value; or of the form @samp{\@var{x}}, where
-@@ -9872,8 +9875,6 @@
- @c     inc-hist.texi
- @c Use -I with makeinfo to point to the appropriate directory,
- @c environment var TEXINPUTS with TeX.
--@include rluser.texinfo
--@include inc-hist.texi
- @ifclear PRECONFIGURED
-@@ -9967,7 +9968,7 @@
- Then give @file{gdb.dvi} to your @sc{dvi} printing program.
- @end ifclear
--@node Installing GDB, Index, Using History Interactively, Top
-+@node Installing GDB, Index, (readline)Using History Interactively, Top
- @appendix Installing @value{GDBN}
- @cindex configuring @value{GDBN}
- @cindex installation
-diff -Nru gdb-4.18/gdb/doc/gdbint.texinfo gdb-4.18.new/gdb/doc/gdbint.texinfo
---- gdb-4.18/gdb/doc/gdbint.texinfo    Mon Nov 22 15:04:50 1999
-+++ gdb-4.18.new/gdb/doc/gdbint.texinfo        Mon Nov 22 11:40:12 1999
-@@ -3,9 +3,10 @@
- @ifinfo
- @format
--START-INFO-DIR-ENTRY
--* Gdb-Internals: (gdbint).    The GNU debugger's internals.
--END-INFO-DIR-ENTRY
-+@dircategory Programming tools:
-+@direntry
-+* Gdb-Internals: (gdbint)             The GNU debugger's internals
-+@end direntry
- @end format
- @end ifinfo
-diff -Nru gdb-4.18/gdb/doc/stabs.texinfo gdb-4.18.new/gdb/doc/stabs.texinfo
---- gdb-4.18/gdb/doc/stabs.texinfo     Mon Nov 22 15:04:50 1999
-+++ gdb-4.18.new/gdb/doc/stabs.texinfo Mon Nov 22 11:40:12 1999
-@@ -5,9 +5,11 @@
- @ifinfo
- @format
--START-INFO-DIR-ENTRY
--* Stabs: (stabs).                 The "stabs" debugging information format.
--END-INFO-DIR-ENTRY
-+@dircategory Programming tools:
-+@direntry
-+* Stabs: (stabs)                      The "stabs" debugging information
-+                                      format
-+@end direntry
- @end format
- @end ifinfo
-@@ -872,7 +874,7 @@
- .stabn 224,0,0,LBE2             # @r{224 is N_RBRAC}
- @end example
--@xref{Procedures} for more information on the @code{N_FUN} stab, and
-+@xref{Procedures}, for more information on the @code{N_FUN} stab, and
- @ref{Block Structure} for more information on the @code{N_LBRAC} and
- @code{N_RBRAC} stabs.
-@@ -3370,7 +3372,7 @@
- Variable on the stack; see @ref{Stack Variables}.
- @item :
--C++ nested symbol; see @xref{Nested Symbols}
-+C++ nested symbol; see @xref{Nested Symbols}.
- @item a
- Parameter passed by reference in register; see @ref{Reference Parameters}.
-diff -Nru gdb-4.18/mmalloc/mmalloc.texi gdb-4.18.new/mmalloc/mmalloc.texi
---- gdb-4.18/mmalloc/mmalloc.texi      Mon Nov 22 15:04:50 1999
-+++ gdb-4.18.new/mmalloc/mmalloc.texi  Mon Nov 22 11:40:12 1999
-@@ -3,9 +3,10 @@
- @ifinfo
- @format
--START-INFO-DIR-ENTRY
--* Mmalloc: (mmalloc).         The GNU mapped-malloc package.
--END-INFO-DIR-ENTRY
-+@dircategory Programming tools:
-+@direntry
-+* Mmalloc: (mmalloc)                  The GNU mapped-malloc package
-+@end direntry
- @end format
- This file documents the GNU mmalloc (mapped-malloc) package, written by
diff --git a/gdb-ncurses.patch b/gdb-ncurses.patch
new file mode 100644 (file)
index 0000000..b43b94e
--- /dev/null
@@ -0,0 +1,76 @@
+diff -urN gdb-5.0.org/gdb/config.in gdb-5.0/gdb/config.in
+--- gdb-5.0.org/gdb/config.in  Fri Apr 14 12:40:00 2000
++++ gdb-5.0/gdb/config.in      Tue Sep  5 18:21:12 2000
+@@ -207,8 +207,8 @@
+ /* Define if you have the <ctype.h> header file.  */
+ #undef HAVE_CTYPE_H
+-/* Define if you have the <curses.h> header file.  */
+-#undef HAVE_CURSES_H
++/* Define if you have the <ncurses/curses.h> header file.  */
++#undef HAVE_NCURSES_CURSES_H
+ /* Define if you have the <endian.h> header file.  */
+ #undef HAVE_ENDIAN_H
+diff -urN gdb-5.0.org/gdb/configure.in gdb-5.0/gdb/configure.in
+--- gdb-5.0.org/gdb/configure.in       Tue Sep  5 18:19:34 2000
++++ gdb-5.0/gdb/configure.in   Tue Sep  5 18:20:44 2000
+@@ -97,7 +97,7 @@
+     AC_DEFINE(_MSE_INT_H)
+ esac; esac
+-AC_CHECK_HEADERS(ctype.h curses.h endian.h link.h thread_db.h proc_service.h \
++AC_CHECK_HEADERS(ctype.h ncurses/curses.h endian.h link.h thread_db.h proc_service.h \
+       memory.h objlist.h ptrace.h sgtty.h stddef.h stdlib.h \
+       string.h sys/procfs.h sys/ptrace.h sys/reg.h stdint.h \
+       term.h termio.h termios.h unistd.h wait.h sys/wait.h \
+diff -urN gdb-5.0.org/gdb/tui/tui.h gdb-5.0/gdb/tui/tui.h
+--- gdb-5.0.org/gdb/tui/tui.h  Tue Sep  5 18:19:34 2000
++++ gdb-5.0/gdb/tui/tui.h      Tue Sep  5 18:20:16 2000
+@@ -2,7 +2,7 @@
+ #ifndef TUI_H
+ #define TUI_H
+-#include <curses.h>
++#include <ncurses/curses.h>
+ #ifdef ANSI_PROTOTYPES
+ #include <stdarg.h>
+diff -urN gdb-5.0.org/gdb/tui/tuiGeneralWin.c gdb-5.0/gdb/tui/tuiGeneralWin.c
+--- gdb-5.0.org/gdb/tui/tuiGeneralWin.c        Tue Sep  5 18:19:34 2000
++++ gdb-5.0/gdb/tui/tuiGeneralWin.c    Tue Sep  5 18:20:25 2000
+@@ -3,7 +3,7 @@
+    ** This module supports general window behavior
+  */
+-#include <curses.h>
++#include <ncurses/curses.h>
+ #include "defs.h"
+ #include "tui.h"
+ #include "tuiData.h"
+diff -urN gdb-5.0.org/gdb/utils.c gdb-5.0/gdb/utils.c
+--- gdb-5.0.org/gdb/utils.c    Tue Sep  5 18:19:34 2000
++++ gdb-5.0/gdb/utils.c        Tue Sep  5 18:21:55 2000
+@@ -24,8 +24,8 @@
+ #include "gdb_string.h"
+ #include "event-top.h"
+-#ifdef HAVE_CURSES_H
+-#include <curses.h>
++#ifdef HAVE_NCURSES_CURSES_H
++#include <ncurses/curses.h>
+ #endif
+ #ifdef HAVE_TERM_H
+ #include <term.h>
+diff -urN gdb-5.0.org/gdb/tui/tui.c gdb-5.0/gdb/tui/tui.c
+--- gdb-5.0.org/gdb/tui/tui.c  Tue Sep  5 19:51:50 2000
++++ gdb-5.0/gdb/tui/tui.c      Tue Sep  5 19:52:17 2000
+@@ -7,7 +7,7 @@
+ #include <stdlib.h>
+ #include <ctype.h>
+ #include <malloc.h>
+-#include <curses.h>
++#include <ncurses/curses.h>
+ #ifdef HAVE_TERM_H
+ #include <term.h>
+ #endif
diff --git a/gdb-readline.patch b/gdb-readline.patch
new file mode 100644 (file)
index 0000000..eaed0c0
--- /dev/null
@@ -0,0 +1,157 @@
+diff -urN gdb-5.0.org/Makefile.in gdb-5.0/Makefile.in
+--- gdb-5.0.org/Makefile.in    Thu May 18 07:00:23 2000
++++ gdb-5.0/Makefile.in        Tue Sep  5 18:32:37 2000
+@@ -558,7 +558,6 @@
+       all-perl \
+       all-prms \
+       all-rcs \
+-      all-readline \
+       all-release \
+       all-recode \
+       all-sed \
+@@ -631,7 +630,6 @@
+       check-perl \
+       check-prms \
+       check-rcs \
+-      check-readline \
+       check-recode \
+       check-sed \
+       check-send-pr \
+@@ -705,7 +703,6 @@
+       install-perl \
+       install-prms \
+       install-rcs \
+-      install-readline \
+       install-recode \
+       install-sed \
+       install-send-pr \
+@@ -869,7 +866,6 @@
+       clean-perl \
+       clean-prms \
+       clean-rcs \
+-      clean-readline \
+       clean-release \
+       clean-recode \
+       clean-sed \
+@@ -1561,7 +1557,7 @@
+ all-gcc: all-bison all-byacc all-binutils all-gas all-ld
+ all-bootstrap: all-libiberty all-bison all-byacc all-binutils all-gas all-ld
+ GDB_TK = all-tk all-tcl all-itcl all-tix all-libgui
+-all-gdb: all-libiberty all-opcodes all-bfd all-mmalloc all-readline all-bison all-byacc all-sim $(gdbnlmrequirements) $(GDB_TK)
++all-gdb: all-libiberty all-opcodes all-bfd all-mmalloc all-bison all-byacc all-sim $(gdbnlmrequirements) $(GDB_TK)
+ all-gettext:
+ all-gnuserv:
+ configure-target-gperf: $(ALL_GCC)
+@@ -1606,12 +1602,11 @@
+ all-perl:
+ all-prms: all-libiberty
+ all-rcs:
+-all-readline:
+ all-recode: all-libiberty
+ all-sed: all-libiberty
+ all-send-pr: all-prms
+ all-shellutils:
+-all-sim: all-libiberty all-bfd all-opcodes all-readline
++all-sim: all-libiberty all-bfd all-opcodes
+ all-tar: all-libiberty
+ all-tcl:
+ all-tcl8.1:
+@@ -1853,7 +1848,7 @@
+               SUPPORT_FILES="$(GNATS_SUPPORT_DIRS)"
+ .PHONY: gdb.tar.bz2
+-GDB_SUPPORT_DIRS= bfd include libiberty mmalloc opcodes readline sim utils intl
++GDB_SUPPORT_DIRS= bfd include libiberty mmalloc opcodes sim utils intl
+ gdb.tar.bz2: $(DIST_SUPPORT) $(GDB_SUPPORT_DIRS) gdb
+       $(MAKE) -f Makefile.in gdb-taz TOOL=gdb \
+               MD5PROG="$(MD5PROG)" \
+diff -urN gdb-5.0.org/gdb/Makefile.in gdb-5.0/gdb/Makefile.in
+--- gdb-5.0.org/gdb/Makefile.in        Tue Sep  5 18:30:00 2000
++++ gdb-5.0/gdb/Makefile.in    Tue Sep  5 19:15:00 2000
+@@ -126,10 +126,10 @@
+ BFD_CFLAGS = -I$(BFD_DIR) -I$(BFD_SRC)
+ # Where is the READLINE library?  Typically in ../readline.
+-READLINE_DIR = ../readline
+-READLINE = $(READLINE_DIR)/libreadline.a
+-READLINE_SRC = $(srcdir)/$(READLINE_DIR)
+-READLINE_CFLAGS = -I$(READLINE_SRC)/..
++READLINE_DIR = /usr/include/readline
++READLINE = -lreadline
++READLINE_SRC = /usr/include/readline
++READLINE_CFLAGS = -I/usr/include/readline
+ WARN_CFLAGS = @WARN_CFLAGS@
+ WERROR_CFLAGS = @WERROR_CFLAGS@
+diff -urN gdb-5.0.org/gdb/event-top.c gdb-5.0/gdb/event-top.c
+--- gdb-5.0.org/gdb/event-top.c        Tue Sep  5 19:34:20 2000
++++ gdb-5.0/gdb/event-top.c    Tue Sep  5 19:34:42 2000
+@@ -32,6 +32,7 @@
+ #include "gdbcmd.h"
+ /* readline include files */
++#define savestring
+ #include <readline/readline.h>
+ #include <readline/history.h>
+diff -urN gdb-5.0.org/gdb/gdbserver/Makefile.in gdb-5.0/gdb/gdbserver/Makefile.in
+--- gdb-5.0.org/gdb/gdbserver/Makefile.in      Tue Sep  5 18:30:00 2000
++++ gdb-5.0/gdb/gdbserver/Makefile.in  Tue Sep  5 18:30:35 2000
+@@ -87,7 +87,7 @@
+ # Where is the source dir for the READLINE library?  Traditionally in .. or .
+ # (For the binary library built from it, we use ${READLINE_DIR}${subdir}.)
+-READLINE_DIR = ${srcdir}/../readline
++READLINE_DIR = /usr/lib
+ READLINE_DEP = $$(READLINE_DIR)
+ # All the includes used for CFLAGS and for lint.
+diff -urN gdb-5.0.org/gdb/top.c gdb-5.0/gdb/top.c
+--- gdb-5.0.org/gdb/top.c      Wed Apr 12 18:46:03 2000
++++ gdb-5.0/gdb/top.c  Tue Sep  5 19:45:56 2000
+@@ -36,6 +36,7 @@
+ #include "version.h"
+ /* readline include files */
++#define savestring
+ #include <readline/readline.h>
+ #include <readline/history.h>
+diff -urN gdb-5.0.org/gdb/tracepoint.c gdb-5.0/gdb/tracepoint.c
+--- gdb-5.0.org/gdb/tracepoint.c       Tue Dec 14 02:05:38 1999
++++ gdb-5.0/gdb/tracepoint.c   Tue Sep  5 19:38:26 2000
+@@ -36,6 +36,7 @@
+ #include "ax-gdb.h"
+ /* readline include files */
++#define savestring
+ #include <readline/readline.h>
+ #include <readline/history.h>
+diff -urN gdb-5.0.org/gdb/tui/Makefile.in gdb-5.0/gdb/tui/Makefile.in
+--- gdb-5.0.org/gdb/tui/Makefile.in    Tue Sep  5 18:30:00 2000
++++ gdb-5.0/gdb/tui/Makefile.in        Tue Sep  5 18:28:16 2000
+@@ -49,9 +49,9 @@
+ BFD_CFLAGS = -I$(BFD_DIR) -I$(BFD_SRC)
+ # Where is the READLINE library?  Typically in ../readline.
+-READLINE_DIR = ../../readline
+-READLINE_SRC = $(srcdir)/$(READLINE_DIR)
+-READLINE_CFLAGS = -I$(READLINE_SRC)
++READLINE_DIR = /usr/lib
++READLINE_SRC = /usr/lib
++READLINE_CFLAGS = -I/usr/include/readline
+ # Where is the INTL library?  Typically in ../intl.
+ INTL_DIR = ../../intl
+diff -urN gdb-5.0.org/gdb/utils.c gdb-5.0/gdb/utils.c
+--- gdb-5.0.org/gdb/utils.c    Tue Sep  5 18:54:25 2000
++++ gdb-5.0/gdb/utils.c        Tue Sep  5 19:49:03 2000
+@@ -50,6 +50,7 @@
+ #include "language.h"
+ #include "annotate.h"
++#define savestring
+ #include <readline/readline.h>
+ #undef XMALLOC
This page took 0.121205 seconds and 4 git commands to generate.