]> git.pld-linux.org Git - packages/gdb.git/blob - gdb.spec
- added es,fr,hu,ja,pl man pages
[packages/gdb.git] / gdb.spec
1 Summary:        A GNU source-level debugger for C, C++ and Fortran
2 Summary(de):    Symbolischer Debugger für C und andere Sprachen 
3 Summary(fr):    Débugger symbolique pour C et d'autres langages
4 Summary(pl):    Symboliczny odpluskwiacz dla C i innych jêzyków
5 Summary(tr):    C ve diðer diller için sembolik hata ayýklayýcý
6 Name:           gdb
7 Version:        5.0
8 Release:        8
9 License:        GPL
10 Group:          Development/Debuggers
11 Group(pl):      Programowanie/Odpluskwiacze
12 Group(de):      Entwicklung/Debugger
13 Source0:        ftp://ftp.gnu.org/pub/gnu/gdb/%{name}-%{version}.tar.bz2
14 Source1:        %{name}-non-english-man-pages.tar.bz2
15 Patch0:         %{name}-gettext.patch
16 Patch1:         %{name}-ncurses.patch
17 Patch2:         %{name}-readline.patch
18 Patch3:         %{name}-info.patch
19 Patch4:         %{name}-procfs.patch
20 BuildRequires:  ncurses-devel >= 5.2
21 BuildRequires:  readline-devel >= 4.2
22 BuildRequires:  XFree86-devel
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  libtool
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Gdb is a full featured, command driven debugger. Gdb allows you to
30 trace the execution of programs and examine their internal state at
31 any time. Gdb works for C and C++ compiled with the GNU C compiler
32 gcc.
33
34 %description -l de
35 dem Sie die Ausführung von Programmen verfolgen und jederzeit den
36 inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
37 kompiliertes C++.
38
39 %description -l fr
40 Débugger complet, piloté par commandes. Permet de tracer l'exécution
41 des programmes et d'examiner à tout moment leur état interne.
42 Fonctionne avec les binaires C et C++ compilés avec le compilateur C
43 de GNU, gcc.
44
45 %description -l pl
46 Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalaj±cym
47 ¶ledziæ wykonywanie programu i badaæ jego stan wewnêtrzny. Gdb
48 umo¿liwia odpluskwianie programów napisanych w C/C++ i skompilowanych
49 przy pomocy kompilatora GNU (gcc).
50
51 %description -l tr
52 Bir komut arayüzü üzerinden programcýya programýný adým adým izleme
53 (trace) ve herhangi bir anda programýn durumunu inceleme olanaðý
54 verir.
55
56 %prep
57 %setup -q
58 %patch0 -p1
59 %patch1 -p1
60 %patch2 -p1
61 %patch3 -p1
62 %patch4 -p1
63
64 %build
65 (cd gdb; libtoolize --copy --force; aclocal; autoconf)
66 (cd gdb/doc; autoconf)
67 (cd gdb/testsuite; autoconf)
68 (cd gdb/testsuite/gdb.asm; autoconf)
69 (cd gdb/testsuite/gdb.base; autoconf)
70 (cd gdb/testsuite/gdb.c++; autoconf)
71 (cd gdb/testsuite/gdb.disasm; autoconf)
72 (cd gdb/testsuite/gdb.chill; autoconf)
73 (cd gdb/testsuite/gdb.mi; autoconf)
74 (cd gdb/testsuite/gdb.threads; autoconf)
75 (cd gdb/testsuite/gdb.trace; autoconf)
76 (cd gdb/testsuite/gdb.stabs; autoconf)
77 (cd gdb/gdbserver; autoconf)
78 # !! Don't enable shared here !! 
79 # This will cause serious problems --misiek
80 %configure2_13 \
81         --disable-shared \
82         --enable-nls \
83         --without-included-gettext \
84         --enable-multi-ice \
85         --enable-gdbmi \
86         --enable-netrom \
87         --with-cpu=%{_target_cpu} \
88         --with-x \
89 %ifnarch alpha
90         --with-mmalloc \
91 %endif
92         --with-mmap
93 #       --enable-tui
94
95 # rebuild main Makefile again (due to some bug, Makefile is deleted)
96 %configure2_13 \
97         --norecursion
98                         
99 %{__make}
100 %{__make} info
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104 install -d $RPM_BUILD_ROOT%{_infodir}
105
106 %{__make} install install-info \
107         prefix=$RPM_BUILD_ROOT%{_prefix} \
108         bindir=$RPM_BUILD_ROOT%{_bindir} \
109         sbindir=$RPM_BUILD_ROOT%{_sbindir} \
110         infodir=$RPM_BUILD_ROOT%{_infodir} \
111         includedir=$RPM_BUILD_ROOT%{_includedir} \
112         libdir=$RPM_BUILD_ROOT%{_libdir} \
113         mandir=$RPM_BUILD_ROOT%{_mandir}
114
115 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post
121 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
122
123 %postun
124 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
125
126 %files
127 %defattr(644,root,root,755)
128 %attr(755,root,root) %{_bindir}/*
129
130 %{_mandir}/man1/*
131 %lang(es) %{_mandir}/es/man1/*
132 %lang(fr) %{_mandir}/fr/man1/*
133 %lang(hu) %{_mandir}/hu/man1/*
134 %lang(ja) %{_mandir}/ja/man1/*
135 %lang(pl) %{_mandir}/pl/man1/*
136 %{_infodir}/gdb*.info*
137 %{_infodir}/stabs*.info*
This page took 0.046036 seconds and 4 git commands to generate.