]> git.pld-linux.org Git - packages/gdb.git/blob - gdb.spec
- updated
[packages/gdb.git] / gdb.spec
1 #
2 # NOTE: Do not remove -lib package, it is required by FPC
3 #
4 Summary:        A GNU source-level debugger for C, C++ and Fortran
5 Summary(de.UTF-8):      Symbolischer Debugger für C und andere Sprachen
6 Summary(es.UTF-8):      Depurador de programas C y otras lenguajes
7 Summary(fr.UTF-8):      Débugger symbolique pour C et d'autres langages
8 Summary(pl.UTF-8):      Symboliczny odpluskwiacz dla C i innych języków
9 Summary(pt_BR.UTF-8):   Depurador de programas C e outras linguagens
10 Summary(ru.UTF-8):      Символический отладчик для C и других языков
11 Summary(tr.UTF-8):      C ve diğer diller için sembolik hata ayıklayıcı
12 Summary(uk.UTF-8):      Символьний відладчик для С та інших мов
13 Summary(zh_CN.UTF-8):   [开发]C和其他语言的调试器
14 Summary(zh_TW.UTF-8):   [.-A開發]C和.$)B其.-A他語.$)B言的調試器
15 %define snap    20081014
16 Name:           gdb
17 Version:        6.8.50
18 Release:        0.%{snap}.1
19 License:        GPL v3+
20 Group:          Development/Debuggers
21 # Source0:      http://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.bz2
22 Source0:        ftp://sourceware.org/pub/gdb/snapshots/current/gdb-%{version}.%{snap}.tar.bz2
23 # Source0-md5:  7317a7da78f28058e45c1f0dec24cbdb
24 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
25 # Source1-md5:  2e8a48939ae282c12bbacdd54e398247
26 Patch0:         %{name}-readline.patch
27 Patch1:         %{name}-info.patch
28 Patch2:         %{name}-passflags.patch
29 Patch4:         %{name}-gdbinit-stat.patch
30 Patch5:         %{name}-pretty-print-by-default.patch
31 Patch6:         %{name}-absolute-gnu_debuglink-path.patch
32 URL:            http://www.gnu.org/software/gdb/
33 BuildRequires:  autoconf >= 2.53
34 BuildRequires:  automake
35 BuildRequires:  bison
36 BuildRequires:  flex
37 BuildRequires:  libtool
38 BuildRequires:  ncurses-devel >= 5.2
39 BuildRequires:  readline-devel >= 4.3
40 BuildRequires:  texinfo >= 4.4
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 Gdb is a full featured, command driven debugger. Gdb allows you to
45 trace the execution of programs and examine their internal state at
46 any time. Gdb works for C and C++ compiled with the GNU C compiler
47 gcc.
48
49 %description -l de.UTF-8
50 dem Sie die Ausführung von Programmen verfolgen und jederzeit den
51 inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
52 kompiliertes C++.
53
54 %description -l es.UTF-8
55 Este es un debugger orientado a comandos repleto de características.
56 Te permite rastrear la ejecución de programas y examinar su estado
57 interno a cualquier momento. Funciona para C y C++ compilado con el
58 compilador GNU C.
59
60 %description -l fr.UTF-8
61 Débugger complet, piloté par commandes. Permet de tracer l'exécution
62 des programmes et d'examiner à tout moment leur état interne.
63 Fonctionne avec les binaires C et C++ compilés avec le compilateur C
64 de GNU, gcc.
65
66 %description -l pl.UTF-8
67 Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalającym
68 śledzić wykonywanie programu i badać jego stan wewnętrzny. Gdb
69 umożliwia odpluskwianie programów napisanych w C/C++ i skompilowanych
70 przy pomocy kompilatora GNU (gcc).
71
72 %description -l pt_BR.UTF-8
73 Este é um debugger orientado a comandos repleto de características.
74 Ele permite à você rastrear a execução de programas e examinar o seu
75 estado interno a qualquer momento. Ele funciona para para C e C++
76 compilado com o compilador GNU C.
77
78 %description -l ru.UTF-8
79 Это полноценный отладчик, управляемый командами. Он позволяет
80 трассировать исполнение программ и изучать их внутреннее состояние в
81 любой момент времени. Работает с программами на C и C++,
82 скомпилированными GNU компилятором C (gcc, egcs, pgcc).
83
84 %description -l tr.UTF-8
85 Bir komut arayüzü üzerinden programcıya programını adım adım izleme
86 (trace) ve herhangi bir anda programın durumunu inceleme olanağı
87 verir.
88
89 %description -l uk.UTF-8
90 Це повноцінний відладчик, що керується командами. Він дозволяє
91 трасувати виконання програм та вивчати їх внутрішній стан в довільний
92 момент часу. Працює з програмами на C та C++, зкомпільованими
93 компіляторами GNU C (gcc, egcs, pgcc).
94
95 %package lib
96 Summary:        GDB in the form of a static library
97 Summary(pl.UTF-8):      GDB w postaci biblioteki statycznej
98 Group:          Development/Debuggers
99 #Requires:      binutils-devel >= 2.17.50
100
101 %description lib
102 GDB in the form of a static library.
103
104 %description lib -l pl.UTF-8
105 GDB w postaci biblioteki statycznej.
106
107 %prep
108 %setup -q -n %{name}-%{version}.%{snap}
109 %patch0 -p1
110 %patch1 -p1
111 %patch2 -p1
112 %patch4 -p0
113 %patch5 -p1
114 %patch6 -p1
115
116 %build
117 for dir in `find gdb/ -name 'configure.in'`; do
118         dir=$(dirname "$dir")
119         olddir=$(pwd)
120         cd $dir
121         rm -f aclocal.m4
122         %{__aclocal}
123         %{__autoconf}
124         cd $olddir
125 done
126 cp -f /usr/share/automake/config.* .
127 # don't --enable-shared here, there would be libs version mismatch with binutils
128 %configure \
129         --disable-gdbtk \
130         --disable-shared \
131         --enable-gdbcli \
132         --enable-gdbmi \
133         --enable-multi-ice \
134         --enable-netrom \
135         --enable-nls \
136         --enable-tui \
137         --with-cpu=%{_target_cpu} \
138 %ifnarch alpha
139         --with-mmalloc \
140 %endif
141         --without-included-gettext \
142         --without-included-regex \
143         --without-x
144
145 %{__make}
146 %{__make} info
147
148 %install
149 rm -rf $RPM_BUILD_ROOT
150 install -d $RPM_BUILD_ROOT%{_infodir}
151
152 %{__make} install install-info \
153         prefix=$RPM_BUILD_ROOT%{_prefix} \
154         bindir=$RPM_BUILD_ROOT%{_bindir} \
155         sbindir=$RPM_BUILD_ROOT%{_sbindir} \
156         infodir=$RPM_BUILD_ROOT%{_infodir} \
157         includedir=$RPM_BUILD_ROOT%{_includedir} \
158         libdir=$RPM_BUILD_ROOT%{_libdir} \
159         mandir=$RPM_BUILD_ROOT%{_mandir}
160
161 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
162
163 install gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
164
165 %clean
166 rm -rf $RPM_BUILD_ROOT
167
168 %post   -p      /sbin/postshell
169 -/usr/sbin/fix-info-dir -c %{_infodir}
170
171 %postun -p      /sbin/postshell
172 -/usr/sbin/fix-info-dir -c %{_infodir}
173
174 %files
175 %defattr(644,root,root,755)
176 %doc gdb/{ChangeLog,NEWS,PROBLEMS,README}
177 %attr(755,root,root) %{_bindir}/*
178 %{_mandir}/man1/*
179 %lang(es) %{_mandir}/es/man1/*
180 %lang(fr) %{_mandir}/fr/man1/*
181 %lang(hu) %{_mandir}/hu/man1/*
182 %lang(ja) %{_mandir}/ja/man1/*
183 %lang(pl) %{_mandir}/pl/man1/*
184 %{_infodir}/gdb*.info*
185 %{_infodir}/stabs*.info*
186
187 %files lib
188 %defattr(644,root,root,755)
189 %{_libdir}/libgdb.a
This page took 0.047938 seconds and 3 git commands to generate.