]> git.pld-linux.org Git - packages/gdb.git/blob - gdb.spec
- readed
[packages/gdb.git] / gdb.spec
1 Summary:        A GNU source-level debugger for C, C++ and Fortran
2 Summary(de):    Symbolischer Debugger für C und andere Sprachen 
3 Summary(fr):    Débugger symbolique pour C et d'autres langages
4 Summary(pl):    Symboliczny odpluskwiacz dla C i innych jêzyków
5 Summary(tr):    C ve diðer diller için sembolik hata ayýklayýcý
6 Name:           gdb
7 Version:        5.0
8 Release:        3
9 License:        GPL
10 Group:          Development/Debuggers
11 Group(pl):      Programowanie/Odpluskwiacze
12 Source0:        ftp://ftp.gnu.org/pub/gnu/gdb/%{name}-%{version}.tar.bz2
13 Patch0:         %{name}-gettext.patch
14 Patch1:         %{name}-ncurses.patch
15 Patch2:         %{name}-readline.patch
16 Patch3:         %{name}-info.patch
17 BuildRequires:  ncurses-devel >= 5.0
18 BuildRequires:  readline-devel >= 4.1
19 BuildRequires:  XFree86-devel
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Gdb is a full featured, command driven debugger. Gdb allows you to
24 trace the execution of programs and examine their internal state at
25 any time. Gdb works for C and C++ compiled with the GNU C compiler
26 gcc.
27
28 %description -l de
29 dem Sie die Ausführung von Programmen verfolgen und jederzeit den
30 inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
31 kompiliertes C++.
32
33 %description -l fr
34 Débugger complet, piloté par commandes. Permet de tracer l'exécution
35 des programmes et d'examiner à tout moment leur état interne.
36 Fonctionne avec les binaires C et C++ compilés avec le compilateur C
37 de GNU, gcc.
38
39 %description -l pl
40 Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalaj±cym
41 ¶ledziæ wykonywanie programu i badaæ jego stan wewnêtrzny. Gdb
42 umo¿liwia odpluskwianie programów napisanych w C/C++ i skompilowanych
43 przy pomocy kompilatora GNU (gcc).
44
45 %description -l tr
46 Bir komut arayüzü üzerinden programcýya programýný adým adým izleme
47 (trace) ve herhangi bir anda programýn durumunu inceleme olanaðý
48 verir.
49
50 %prep
51 %setup -q
52 %patch0 -p1
53 %patch1 -p1
54 %patch2 -p1
55 %patch3 -p1
56
57 %build
58 (cd gdb; aclocal; autoconf; cd ..)
59 # !! Don't enable shared here !! 
60 # This will cause serious problems --misiek
61 %configure \
62         --disable-shared \
63         --enable-nls \
64         --without-included-gettext \
65         --enable-multi-ice \
66         --enable-gdbmi \
67         --enable-netrom \
68         --with-cpu=%{__host_cpu} \
69         --with-x \
70         --with-mmap \
71         --with-mmalloc
72 #       --enable-tui
73
74 # rebuild main Makefile again (due to some bug, Makefile is deleted)
75 %configure \
76         --norecursion
77                         
78 %{__make}
79 %{__make} info
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83 install -d $RPM_BUILD_ROOT%{_infodir}
84
85 %{__make} install install-info \
86         prefix=$RPM_BUILD_ROOT%{_prefix} \
87         bindir=$RPM_BUILD_ROOT%{_bindir} \
88         sbindir=$RPM_BUILD_ROOT%{_sbindir} \
89         infodir=$RPM_BUILD_ROOT%{_infodir} \
90         includedir=$RPM_BUILD_ROOT%{_includedir} \
91         libdir=$RPM_BUILD_ROOT%{_libdir} \
92         mandir=$RPM_BUILD_ROOT%{_mandir}
93
94 gzip -9nf $RPM_BUILD_ROOT{%{_infodir}/*info*,%{_mandir}/man?/*}
95
96 %post
97 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
98
99 %postun
100 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %files
106 %defattr(644,root,root,755)
107 %attr(755,root,root) %{_bindir}/*
108
109 %{_mandir}/man1/*
110 %{_infodir}/gdb*.info*
111 %{_infodir}/stabs*.info*
This page took 0.035033 seconds and 3 git commands to generate.