]> git.pld-linux.org Git - packages/gdb.git/blob - gdb.spec
- added man-pages tar URL
[packages/gdb.git] / gdb.spec
1 Summary:        A GNU source-level debugger for C, C++ and Fortran
2 Summary(de):    Symbolischer Debugger für C und andere Sprachen 
3 Summary(es):    Depurador de programas C y otras lenguajes
4 Summary(fr):    Débugger symbolique pour C et d'autres langages
5 Summary(pl):    Symboliczny odpluskwiacz dla C i innych jêzyków
6 Summary(pt_BR): Depurador de programas C e outras linguagens
7 Summary(tr):    C ve diðer diller için sembolik hata ayýklayýcý
8 Name:           gdb
9 Version:        5.1
10 Release:        1
11 License:        GPL
12 Group:          Development/Debuggers
13 Group(de):      Entwicklung/Debugger
14 Group(pl):      Programowanie/Odpluskwiacze
15 Source0:        ftp://ftp.gnu.org/pub/gnu/gdb/%{name}-%{version}.tar.gz
16 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
17 Patch0:         %{name}-gettext.patch
18 Patch1:         %{name}-ncurses.patch
19 Patch2:         %{name}-readline.patch
20 Patch3:         %{name}-info.patch
21 Patch4:         %{name}-procfs.patch
22 BuildRequires:  ncurses-devel >= 5.2
23 BuildRequires:  readline-devel >= 4.2
24 BuildRequires:  XFree86-devel
25 BuildRequires:  autoconf
26 BuildRequires:  automake
27 BuildRequires:  libtool
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Gdb is a full featured, command driven debugger. Gdb allows you to
32 trace the execution of programs and examine their internal state at
33 any time. Gdb works for C and C++ compiled with the GNU C compiler
34 gcc.
35
36 %description -l de
37 dem Sie die Ausführung von Programmen verfolgen und jederzeit den
38 inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
39 kompiliertes C++.
40
41 %description -l es
42 Este es un debugger orientado a comandos repleto de características.
43 Te permite rastrear la ejecución de programas y examinar su estado
44 interno a cualquier momento. Funciona para C y C++ compilado con el
45 compilador GNU C.
46
47 %description -l fr
48 Débugger complet, piloté par commandes. Permet de tracer l'exécution
49 des programmes et d'examiner à tout moment leur état interne.
50 Fonctionne avec les binaires C et C++ compilés avec le compilateur C
51 de GNU, gcc.
52
53 %description -l pl
54 Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalaj±cym
55 ¶ledziæ wykonywanie programu i badaæ jego stan wewnêtrzny. Gdb
56 umo¿liwia odpluskwianie programów napisanych w C/C++ i skompilowanych
57 przy pomocy kompilatora GNU (gcc).
58
59 %description -l pt_BR
60 Este é um debugger orientado a comandos repleto de características.
61 Ele permite à você rastrear a execução de programas e examinar o seu
62 estado interno a qualquer momento. Ele funciona para para C e C++
63 compilado com o compilador GNU C.
64
65 %description -l tr
66 Bir komut arayüzü üzerinden programcýya programýný adým adým izleme
67 (trace) ve herhangi bir anda programýn durumunu inceleme olanaðý
68 verir.
69
70 %prep
71 %setup -q
72 %patch0 -p1
73 %patch1 -p1
74 %patch2 -p1
75 %patch3 -p1
76 %patch4 -p1
77
78 %build
79 (cd gdb; libtoolize --copy --force; aclocal; autoconf)
80 (cd gdb/doc; autoconf)
81 (cd gdb/testsuite; autoconf)
82 (cd gdb/testsuite/gdb.asm; autoconf)
83 (cd gdb/testsuite/gdb.base; autoconf)
84 (cd gdb/testsuite/gdb.c++; autoconf)
85 (cd gdb/testsuite/gdb.chill; autoconf)
86 (cd gdb/testsuite/gdb.disasm; autoconf)
87 (cd gdb/testsuite/gdb.fortran; autoconf)
88 (cd gdb/testsuite/gdb.java; autoconf)
89 (cd gdb/testsuite/gdb.mi; autoconf)
90 (cd gdb/testsuite/gdb.stabs; autoconf)
91 (cd gdb/testsuite/gdb.threads; autoconf)
92 (cd gdb/testsuite/gdb.trace; autoconf)
93 (cd gdb/gdbserver; autoconf)
94 # !! Don't enable shared here !! 
95 # This will cause serious problems --misiek
96 %configure2_13 \
97         --disable-shared \
98         --enable-nls \
99         --without-included-gettext \
100         --enable-multi-ice \
101         --enable-gdbmi \
102         --enable-gdcli \
103         --enable-netrom \
104         --with-cpu=%{_target_cpu} \
105         --with-x \
106         --enable-tui \
107 %ifnarch alpha
108         --with-mmalloc \
109 %endif
110         --with-mmap
111
112 %{__make}
113 %{__make} info
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 install -d $RPM_BUILD_ROOT%{_infodir}
118
119 %{__make} install install-info \
120         prefix=$RPM_BUILD_ROOT%{_prefix} \
121         bindir=$RPM_BUILD_ROOT%{_bindir} \
122         sbindir=$RPM_BUILD_ROOT%{_sbindir} \
123         infodir=$RPM_BUILD_ROOT%{_infodir} \
124         includedir=$RPM_BUILD_ROOT%{_includedir} \
125         libdir=$RPM_BUILD_ROOT%{_libdir} \
126         mandir=$RPM_BUILD_ROOT%{_mandir}
127
128 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post
134 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
135
136 %postun
137 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
138
139 %files
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_bindir}/*
142
143 %{_mandir}/man1/*
144 %lang(es) %{_mandir}/es/man1/*
145 %lang(fr) %{_mandir}/fr/man1/*
146 %lang(hu) %{_mandir}/hu/man1/*
147 %lang(ja) %{_mandir}/ja/man1/*
148 %lang(pl) %{_mandir}/pl/man1/*
149 %{_infodir}/gdb*.info*
150 %{_infodir}/stabs*.info*
This page took 0.123364 seconds and 3 git commands to generate.