]> git.pld-linux.org Git - packages/gdb.git/blob - gdb.spec
- outdated
[packages/gdb.git] / gdb.spec
1 #
2 # NOTE: Do not remove -lib package, it is required by FPC
3 #
4 Summary:        A GNU source-level debugger for C, C++ and Fortran
5 Summary(de.UTF-8):      Symbolischer Debugger für C und andere Sprachen
6 Summary(es.UTF-8):      Depurador de programas C y otras lenguajes
7 Summary(fr.UTF-8):      Débugger symbolique pour C et d'autres langages
8 Summary(pl.UTF-8):      Symboliczny odpluskwiacz dla C i innych języków
9 Summary(pt_BR.UTF-8):   Depurador de programas C e outras linguagens
10 Summary(ru.UTF-8):      Символический отладчик для C и других языков
11 Summary(tr.UTF-8):      C ve diğer diller için sembolik hata ayıklayıcı
12 Summary(uk.UTF-8):      Символьний відладчик для С та інших мов
13 Summary(zh_CN.UTF-8):   [开发]C和其他语言的调试器
14 Summary(zh_TW.UTF-8):   [.-A開發]C和.$)B其.-A他語.$)B言的調試器
15 %define snap    20090311
16 Name:           gdb
17 Version:        6.8.50
18 Release:        0.%{snap}.1
19 License:        GPL v3+
20 Group:          Development/Debuggers
21 # Source0:      http://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.bz2
22 Source0:        ftp://sourceware.org/pub/gdb/snapshots/current/gdb-%{version}.%{snap}.tar.bz2
23 # Source0-md5:  911b57b37260317251b55ab3393913a5
24 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
25 # Source1-md5:  2e8a48939ae282c12bbacdd54e398247
26 Patch0:         %{name}-readline.patch
27 Patch1:         %{name}-info.patch
28 Patch2:         %{name}-passflags.patch
29 Patch5:         %{name}-pretty-print-by-default.patch
30 Patch6:         %{name}-absolute-gnu_debuglink-path.patch
31 URL:            http://www.gnu.org/software/gdb/
32 BuildRequires:  autoconf >= 2.53
33 BuildRequires:  automake
34 BuildRequires:  bison
35 BuildRequires:  flex
36 BuildRequires:  libtool
37 BuildRequires:  ncurses-devel >= 5.2
38 BuildRequires:  readline-devel >= 6.0
39 BuildRequires:  texinfo >= 4.4
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 Gdb is a full featured, command driven debugger. Gdb allows you to
44 trace the execution of programs and examine their internal state at
45 any time. Gdb works for C and C++ compiled with the GNU C compiler
46 gcc.
47
48 %description -l de.UTF-8
49 dem Sie die Ausführung von Programmen verfolgen und jederzeit den
50 inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
51 kompiliertes C++.
52
53 %description -l es.UTF-8
54 Este es un debugger orientado a comandos repleto de características.
55 Te permite rastrear la ejecución de programas y examinar su estado
56 interno a cualquier momento. Funciona para C y C++ compilado con el
57 compilador GNU C.
58
59 %description -l fr.UTF-8
60 Débugger complet, piloté par commandes. Permet de tracer l'exécution
61 des programmes et d'examiner à tout moment leur état interne.
62 Fonctionne avec les binaires C et C++ compilés avec le compilateur C
63 de GNU, gcc.
64
65 %description -l pl.UTF-8
66 Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalającym
67 śledzić wykonywanie programu i badać jego stan wewnętrzny. Gdb
68 umożliwia odpluskwianie programów napisanych w C/C++ i skompilowanych
69 przy pomocy kompilatora GNU (gcc).
70
71 %description -l pt_BR.UTF-8
72 Este é um debugger orientado a comandos repleto de características.
73 Ele permite à você rastrear a execução de programas e examinar o seu
74 estado interno a qualquer momento. Ele funciona para para C e C++
75 compilado com o compilador GNU C.
76
77 %description -l ru.UTF-8
78 Это полноценный отладчик, управляемый командами. Он позволяет
79 трассировать исполнение программ и изучать их внутреннее состояние в
80 любой момент времени. Работает с программами на C и C++,
81 скомпилированными GNU компилятором C (gcc, egcs, pgcc).
82
83 %description -l tr.UTF-8
84 Bir komut arayüzü üzerinden programcıya programını adım adım izleme
85 (trace) ve herhangi bir anda programın durumunu inceleme olanağı
86 verir.
87
88 %description -l uk.UTF-8
89 Це повноцінний відладчик, що керується командами. Він дозволяє
90 трасувати виконання програм та вивчати їх внутрішній стан в довільний
91 момент часу. Працює з програмами на C та C++, зкомпільованими
92 компіляторами GNU C (gcc, egcs, pgcc).
93
94 %package lib
95 Summary:        GDB in the form of a static library
96 Summary(pl.UTF-8):      GDB w postaci biblioteki statycznej
97 Group:          Development/Debuggers
98 #Requires:      binutils-devel >= 2.17.50
99
100 %description lib
101 GDB in the form of a static library.
102
103 %description lib -l pl.UTF-8
104 GDB w postaci biblioteki statycznej.
105
106 %prep
107 %setup -q -n %{name}-%{version}.%{snap}
108 %patch0 -p1
109 %patch1 -p1
110 %patch2 -p1
111 %patch5 -p1
112 %patch6 -p1
113
114 %build
115 for dir in `find gdb/ -name 'configure.in'`; do
116         dir=$(dirname "$dir")
117         olddir=$(pwd)
118         cd $dir
119         rm -f aclocal.m4
120         %{__aclocal}
121         %{__autoconf}
122         cd $olddir
123 done
124 cp -f /usr/share/automake/config.* .
125 # don't --enable-shared here, there would be libs version mismatch with binutils
126 %configure \
127         --disable-gdbtk \
128         --disable-shared \
129         --enable-gdbcli \
130         --enable-gdbmi \
131         --enable-multi-ice \
132         --enable-netrom \
133         --enable-nls \
134         --enable-tui \
135         --with-cpu=%{_target_cpu} \
136 %ifnarch alpha
137         --with-mmalloc \
138 %endif
139         --without-included-gettext \
140         --without-included-regex \
141         --without-x
142
143 %{__make}
144 %{__make} info
145
146 %install
147 rm -rf $RPM_BUILD_ROOT
148 install -d $RPM_BUILD_ROOT%{_infodir}
149
150 %{__make} install install-info \
151         prefix=$RPM_BUILD_ROOT%{_prefix} \
152         bindir=$RPM_BUILD_ROOT%{_bindir} \
153         sbindir=$RPM_BUILD_ROOT%{_sbindir} \
154         infodir=$RPM_BUILD_ROOT%{_infodir} \
155         includedir=$RPM_BUILD_ROOT%{_includedir} \
156         libdir=$RPM_BUILD_ROOT%{_libdir} \
157         mandir=$RPM_BUILD_ROOT%{_mandir}
158
159 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
160
161 install gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
162
163 %clean
164 rm -rf $RPM_BUILD_ROOT
165
166 %post   -p      /sbin/postshell
167 -/usr/sbin/fix-info-dir -c %{_infodir}
168
169 %postun -p      /sbin/postshell
170 -/usr/sbin/fix-info-dir -c %{_infodir}
171
172 %files
173 %defattr(644,root,root,755)
174 %doc gdb/{ChangeLog,NEWS,PROBLEMS,README}
175 %attr(755,root,root) %{_bindir}/*
176 %{_mandir}/man1/*
177 %lang(es) %{_mandir}/es/man1/*
178 %lang(fr) %{_mandir}/fr/man1/*
179 %lang(hu) %{_mandir}/hu/man1/*
180 %lang(ja) %{_mandir}/ja/man1/*
181 %lang(pl) %{_mandir}/pl/man1/*
182 %{_infodir}/gdb*.info*
183 %{_infodir}/stabs*.info*
184
185 %files lib
186 %defattr(644,root,root,755)
187 %{_libdir}/libgdb.a
This page took 1.072094 seconds and 3 git commands to generate.