]> git.pld-linux.org Git - packages/gdb.git/blob - gdb.spec
- updated to 14.1 + rebased Fedora buildid patches set
[packages/gdb.git] / gdb.spec
1 # NOTE: -lib package is used by fpc.spec
2
3 # TODO
4 # - rpm5 librpm support (gdb/configure.ac checks for 4.x or so)
5 # - change install msg to poldek in buildid-locate-rpm-pld.patch when poldek allows it. LP#493922
6 #
7 # Conditional build:
8 %bcond_without  guile           # Guile embedded scripting
9 %bcond_without  python          # build without python support
10
11 Summary:        A GNU source-level debugger for C, C++ and Fortran
12 Summary(de.UTF-8):      Symbolischer Debugger für C und andere Sprachen
13 Summary(es.UTF-8):      Depurador de programas C y otras lenguajes
14 Summary(fr.UTF-8):      Débugger symbolique pour C et d'autres langages
15 Summary(pl.UTF-8):      Symboliczny odpluskwiacz dla C i innych języków
16 Summary(pt_BR.UTF-8):   Depurador de programas C e outras linguagens
17 Summary(ru.UTF-8):      Символический отладчик для C и других языков
18 Summary(tr.UTF-8):      C ve diğer diller için sembolik hata ayıklayıcı
19 Summary(uk.UTF-8):      Символьний відладчик для С та інших мов
20 Summary(zh_CN.UTF-8):   [开发]C和其他语言的调试器
21 Summary(zh_TW.UTF-8):   [.-A開發]C和.$)B其.-A他語.$)B言的調試器
22 Name:           gdb
23 Version:        8.1.1
24 Release:        1
25 License:        GPL v3+
26 Group:          Development/Debuggers
27 Source0:        http://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.xz
28 # Source0-md5:  372fa63a53adeee1bfbfd581d8da9e34
29 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
30 # Source1-md5:  2e8a48939ae282c12bbacdd54e398247
31 Source3:        %{name}-gstack.man
32 Patch100:       gdb-6.6-buildid-locate.patch
33 Patch101:       gdb-6.6-buildid-locate-solib-missing-ids.patch
34 Patch102:       gdb-6.6-buildid-locate-rpm.patch
35 Patch103:       gdb-6.6-buildid-locate-core-as-arg.patch
36 Patch104:       gdb-6.6-buildid-locate-rpm-librpm-workaround.patch
37 Patch105:       gdb-6.6-buildid-locate-misleading-warning-missing-debuginfo-rhbz981154.patch
38 Patch106:       gdb-6.6-buildid-locate-rpm-scl.patch
39 Patch110:       gdb-6.3-gstack-20050411.patch
40 Patch111:       gdb-gdb-add-index-script.patch
41 Patch112:       gdb-archer-vla-tests.patch
42 Patch113:       gdb-vla-intel-fortran-strides.patch
43 Patch114:       gdb-vla-intel-stringbt-fix.patch
44 Patch115:       gdb-vla-intel-fortran-vla-strings.patch
45 Patch116:       gdb-vla-intel-tests.patch
46 Patch1000:      %{name}-readline.patch
47 Patch1001:      %{name}-info.patch
48 Patch1002:      %{name}-passflags.patch
49 Patch1005:      %{name}-pretty-print-by-default.patch
50 Patch1006:      buildid-locate-rpm-pld.patch
51 URL:            http://www.gnu.org/software/gdb/
52 BuildRequires:  autoconf >= 2.69
53 BuildRequires:  automake
54 BuildRequires:  bison
55 BuildRequires:  babeltrace-devel >= 1.1.0
56 BuildRequires:  expat-devel
57 BuildRequires:  flex >= 2.6.4
58 BuildRequires:  gettext-tools >= 0.12.1
59 %{?with_guile:BuildRequires:    guile-devel >= 2.0}
60 BuildRequires:  libselinux-devel
61 BuildRequires:  libstdc++-devel >= 6:4.8
62 BuildRequires:  libtool
63 BuildRequires:  make >= 3.81
64 BuildRequires:  mpfr-devel
65 BuildRequires:  ncurses-devel >= 5.2
66 BuildRequires:  pkgconfig
67 BuildRequires:  readline-devel
68 BuildRequires:  rpmbuild(macros) >= 1.219
69 BuildRequires:  tar >= 1:1.22
70 BuildRequires:  texinfo >= 4.4
71 BuildRequires:  xz
72 BuildRequires:  xz-devel
73 BuildRequires:  zlib-devel
74 %if %{with python}
75 BuildRequires:  python-devel
76 BuildRequires:  rpm-pythonprov
77 Obsoletes:      python-gdb
78 # for traceback module
79 Requires:       python-modules
80 %endif
81 %{?with_guile:Requires: guile >= 2.0.12}
82 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
83
84 %description
85 Gdb is a full featured, command driven debugger. Gdb allows you to
86 trace the execution of programs and examine their internal state at
87 any time. Gdb works for C and C++ compiled with the GNU C compiler
88 gcc.
89
90 %description -l de.UTF-8
91 dem Sie die Ausführung von Programmen verfolgen und jederzeit den
92 inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
93 kompiliertes C++.
94
95 %description -l es.UTF-8
96 Este es un debugger orientado a comandos repleto de características.
97 Te permite rastrear la ejecución de programas y examinar su estado
98 interno a cualquier momento. Funciona para C y C++ compilado con el
99 compilador GNU C.
100
101 %description -l fr.UTF-8
102 Débugger complet, piloté par commandes. Permet de tracer l'exécution
103 des programmes et d'examiner à tout moment leur état interne.
104 Fonctionne avec les binaires C et C++ compilés avec le compilateur C
105 de GNU, gcc.
106
107 %description -l pl.UTF-8
108 Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalającym
109 śledzić wykonywanie programu i badać jego stan wewnętrzny. Gdb
110 umożliwia odpluskwianie programów napisanych w C/C++ i skompilowanych
111 przy pomocy kompilatora GNU (gcc).
112
113 %description -l pt_BR.UTF-8
114 Este é um debugger orientado a comandos repleto de características.
115 Ele permite à você rastrear a execução de programas e examinar o seu
116 estado interno a qualquer momento. Ele funciona para para C e C++
117 compilado com o compilador GNU C.
118
119 %description -l ru.UTF-8
120 Это полноценный отладчик, управляемый командами. Он позволяет
121 трассировать исполнение программ и изучать их внутреннее состояние в
122 любой момент времени. Работает с программами на C и C++,
123 скомпилированными GNU компилятором C (gcc, egcs, pgcc).
124
125 %description -l tr.UTF-8
126 Bir komut arayüzü üzerinden programcıya programını adım adım izleme
127 (trace) ve herhangi bir anda programın durumunu inceleme olanağı
128 verir.
129
130 %description -l uk.UTF-8
131 Це повноцінний відладчик, що керується командами. Він дозволяє
132 трасувати виконання програм та вивчати їх внутрішній стан в довільний
133 момент часу. Працює з програмами на C та C++, зкомпільованими
134 компіляторами GNU C (gcc, egcs, pgcc).
135
136 %package gdbserver
137 Summary:        A standalone server for GDB (the GNU source-level debugger)
138 Summary(pl.UTF-8):      Samodzielny serwer GDB (debuggera GNU)
139 Group:          Development/Debuggers
140
141 %description gdbserver
142 GDB, the GNU debugger, allows you to debug programs written in C, C++,
143 Java, and other languages, by executing them in a controlled fashion
144 and printing their data.
145
146 This package provides a program that allows you to run GDB on a
147 different machine than the one which is running the program being
148 debugged.
149
150 %description gdbserver -l pl.UTF-8
151 GDB (GNU debugger) pozwala śledzić programy napisane w C, C++, Javie i
152 innych językach programowania poprzez wykonywanie ich w sposób
153 kontrolowany oraz wypisywanie ich danych.
154
155 Ten pakiet zawiera program pozwalający uruchamiać GDB na innej
156 maszynie niż ta, na której działa śledzony program.
157
158 %package lib
159 Summary:        GDB in the form of a static library
160 Summary(pl.UTF-8):      GDB w postaci biblioteki statycznej
161 Group:          Development/Debuggers
162 # libraries that needs to be linked to fulfill libgdb.a symbol requirements
163 Requires:       binutils-devel >= 2.17.50
164 Requires:       expat-devel
165 Requires:       libselinux-devel
166 Requires:       libsepol-devel
167 Requires:       ncurses-devel
168 Requires:       python-devel
169 Requires:       readline-devel
170 Requires:       xz-devel
171 Requires:       zlib-devel
172
173 %description lib
174 GDB in the form of a static library.
175
176 %description lib -l pl.UTF-8
177 GDB w postaci biblioteki statycznej.
178
179 %prep
180 %setup -q
181
182 # Files have `# <number> <file>' statements breaking VPATH / find-debuginfo.sh .
183 %{__rm} gdb/ada-exp.c gdb/ada-lex.c gdb/c-exp.c gdb/cp-name-parser.c gdb/f-exp.c
184 %{__rm} gdb/m2-exp.c gdb/p-exp.c
185
186 %patch100 -p1
187 %patch101 -p1
188 %patch102 -p1
189 %patch103 -p1
190 %patch104 -p1
191 %patch105 -p1
192 %patch106 -p1
193 %patch110 -p1
194 %patch111 -p1
195 %patch112 -p1
196 %patch113 -p1
197 %patch114 -p1
198 %patch115 -p1
199 %patch116 -p1
200
201 %patch1000 -p1
202 %patch1001 -p1
203 %patch1002 -p1
204 %patch1005 -p1
205 %patch1006 -p1
206
207 # Change the version that gets printed at GDB startup, so it is PLD Linux specific.
208 cat > gdb/version.in << EOF
209 %{version}-%{release} (PLD Linux)
210 EOF
211
212 sed -i -e 's#_GCC_AUTOCONF_VERSION\], \[2\.64\]#_GCC_AUTOCONF_VERSION], [2.69]#g' config/override.m4
213
214 %build
215 # omit hand-written gdb/testsuite aclocal.m4
216 for dir in gdb gdb/gdbserver ; do
217         olddir=$(pwd)
218         cd $dir
219         %{__rm} aclocal.m4
220         %{__aclocal} $(grep '^ACLOCAL_AMFLAGS' Makefile.in | sed -e 's/.*=//')
221         cd $olddir
222 done
223 for dir in $(find gdb -name 'configure.in' -o -name 'configure.ac'); do
224         dir=$(dirname "$dir")
225         olddir=$(pwd)
226         cd $dir
227         %{__autoconf}
228         grep -q AC_CONFIG_HEADER configure.* && %{__autoheader}
229         cd $olddir
230 done
231 cp -f /usr/share/automake/config.* .
232 # don't --enable-shared here, there would be libs version mismatch with binutils
233 %configure \
234         --with-gdb-datadir=%{_datadir}/gdb \
235         --with-separate-debug-dir=/usr/lib/debug \
236 %if %{with python}
237         --with-python=yes \
238         --with-pythondir=%{py_sitescriptdir} \
239 %else
240         --without-python \
241 %endif
242 %if %{with guile}
243         --with-guile \
244 %else
245         --without-guile \
246 %endif
247         --disable-gdbtk \
248         --disable-shared \
249         --enable-gdbcli \
250         --enable-gdbmi \
251         --enable-multi-ice \
252         --enable-netrom \
253         --enable-nls \
254         --enable-tui \
255         --with-system-readline \
256         --with-cpu=%{_target_cpu} \
257 %ifnarch alpha
258         --with-mmalloc \
259 %endif
260         --without-included-gettext \
261         --without-included-regex \
262         --without-x
263
264 %{__make}
265 %{__make} -j1 info
266
267 # gdb/ChangeLog: Build gdb directly from *.o files not using libgdb.a.
268 %{__make} -C gdb libgdb.a
269
270 %install
271 rm -rf $RPM_BUILD_ROOT
272 install -d $RPM_BUILD_ROOT%{_infodir}
273
274 %{__make} -j1 install install-info \
275         DESTDIR=$RPM_BUILD_ROOT
276
277 cp -a gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
278
279 # gdbtui seems all identical to gdb except when invoked as gdbtui, ncurses
280 # window is created too.
281 echo ".so gdb.1" > $RPM_BUILD_ROOT%{_mandir}/man1/gdbtui.1
282 ln -f $RPM_BUILD_ROOT%{_bindir}/{gdb,gdbtui}
283
284 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
285 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.gdb-non-english-man-pages
286
287 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
288
289 %if %{with python}
290 # Temporarily now:
291 for LIB in lib lib64 libx32; do
292         LIBPATH="$RPM_BUILD_ROOT%{_datadir}/gdb/auto-load%{_prefix}/$LIB"
293         install -d $LIBPATH
294 done
295
296 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
297 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
298 %py_postclean
299 %endif
300
301 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/man1/gstack.1
302
303 install libdecnumber/libdecnumber.a $RPM_BUILD_ROOT%{_libdir}
304
305 # Remove the files that are part of a gdb build but that are owned and provided by other packages.
306 # These are part of binutils:
307 %{__rm} $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd,opcodes}.mo
308 %{__rm} $RPM_BUILD_ROOT%{_infodir}/bfd.info*
309 %{__rm} $RPM_BUILD_ROOT%{_includedir}/{ansidecl,bfd,bfdlink,dis-asm,symcat,plugin-api}.h
310 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.la
311 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.a
312
313 %clean
314 rm -rf $RPM_BUILD_ROOT
315
316 %post   -p /sbin/postshell
317 -/usr/sbin/fix-info-dir -c %{_infodir}
318
319 %postun -p /sbin/postshell
320 -/usr/sbin/fix-info-dir -c %{_infodir}
321
322 %files
323 %defattr(644,root,root,755)
324 %doc gdb/{ChangeLog,NEWS,PROBLEMS,README}
325 %attr(755,root,root) %{_bindir}/gdb
326 %attr(755,root,root) %{_bindir}/gdbtui
327 %attr(755,root,root) %{_bindir}/gdb-add-index
328 %attr(755,root,root) %{_bindir}/gstack
329 %attr(755,root,root) %{_bindir}/gcore
330 %dir %{_datadir}/gdb
331 %dir %{_datadir}/gdb/auto-load
332 %dir %{_datadir}/gdb/auto-load%{_prefix}
333 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib
334 %ifarch %{x8664} x32
335 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib64
336 %dir %{_datadir}/gdb/auto-load%{_prefix}/libx32
337 %endif
338 %{?with_guile:%{_datadir}/gdb/guile}
339 %{_datadir}/gdb/syscalls
340 %{_datadir}/gdb/system-gdbinit
341 %{_datadir}/gdb/python
342 %{_mandir}/man1/gdb.1*
343 %{_mandir}/man1/gdbtui.1*
344 %{_mandir}/man1/gdb-add-index.1*
345 %{_mandir}/man1/gstack.1*
346 %{_mandir}/man1/gcore.1*
347 %{_mandir}/man5/gdbinit.5*
348 %lang(es) %{_mandir}/es/man1/*
349 %lang(fr) %{_mandir}/fr/man1/*
350 %lang(hu) %{_mandir}/hu/man1/*
351 %lang(ja) %{_mandir}/ja/man1/*
352 %lang(pl) %{_mandir}/pl/man1/*
353 %{_infodir}/annotate.info*
354 %{_infodir}/gdb.info*
355 %{_infodir}/stabs.info*
356
357 %files gdbserver
358 %defattr(644,root,root,755)
359 %attr(755,root,root) %{_bindir}/gdbserver
360 %{_mandir}/man1/gdbserver.1*
361 %attr(755,root,root) %{_libdir}/libinproctrace.so
362
363 %files lib
364 %defattr(644,root,root,755)
365 %{_libdir}/libdecnumber.a
366 %{_libdir}/libgdb.a
367 %{_includedir}/gdb
This page took 0.046214 seconds and 3 git commands to generate.