]> git.pld-linux.org Git - packages/gdal.git/commitdiff
upstream patch to fix build with new poppler
authorJan Palus <atler@pld-linux.org>
Tue, 22 May 2018 20:54:40 +0000 (22:54 +0200)
committerJan Palus <atler@pld-linux.org>
Tue, 22 May 2018 20:54:40 +0000 (22:54 +0200)
gdal-poppler.patch [new file with mode: 0644]
gdal.spec

diff --git a/gdal-poppler.patch b/gdal-poppler.patch
new file mode 100644 (file)
index 0000000..c4d34d5
--- /dev/null
@@ -0,0 +1,26 @@
+From 2d789902ffb48251ec2ff632320d78ee088c2c5f Mon Sep 17 00:00:00 2001
+From: Even Rouault <even.rouault@spatialys.com>
+Date: Sat, 5 May 2018 22:18:37 +0200
+Subject: [PATCH] Fix build with recent Poppler (0.64) (fix #573)
+
+---
+ gdal/frmts/pdf/pdfobject.cpp | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/gdal/frmts/pdf/pdfobject.cpp b/gdal/frmts/pdf/pdfobject.cpp
+index ae734a74e4c..5eab5dd1546 100644
+--- a/gdal/frmts/pdf/pdfobject.cpp
++++ b/gdal/frmts/pdf/pdfobject.cpp
+@@ -1055,7 +1055,12 @@ const CPLString& GDALPDFObjectPoppler::GetString()
+ {
+     if (GetType() == PDFObjectType_String)
+     {
++#ifdef POPPLER_0_58_OR_LATER
++        // At least available since poppler 0.41
++        const GooString* gooString = m_po->getString();
++#else
+         GooString* gooString = m_po->getString();
++#endif
+         return (osStr = GDALPDFGetUTF8StringFromBytes(reinterpret_cast<const GByte*>(gooString->getCString()),
+                                                       static_cast<int>(gooString->getLength())));
+     }
index 77a3726e5ec78e864f583fb7ed754d86a91b8fe2..aa12bbfffca31083caf1c79c265c0bd8b8d7aee1 100644 (file)
--- a/gdal.spec
+++ b/gdal.spec
@@ -56,6 +56,7 @@ Group:                Libraries
 Source0:       http://download.osgeo.org/gdal/%{version}/%{name}-%{version}.tar.xz
 # Source0-md5: 51b1df61dbdf81473689fab3075e7a5e
 Patch0:                %{name}-perl.patch
+Patch1:                %{name}-poppler.patch
 Patch2:                %{name}-php.patch
 Patch3:                %{name}-fpic.patch
 Patch9:                %{name}-dds.patch
@@ -280,6 +281,7 @@ osr.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p2
 %patch2 -p1
 %patch3 -p1
 %patch9 -p1
This page took 0.045635 seconds and 4 git commands to generate.