]> git.pld-linux.org Git - packages/gdal.git/commitdiff
- updated to 1.11.1 auto/th/gdal-1.11.1-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 16 Nov 2014 20:55:11 +0000 (21:55 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 16 Nov 2014 20:55:11 +0000 (21:55 +0100)
- updated sse patch
- removed obsolete gif patch

gdal-gif.patch [deleted file]
gdal-sse.patch
gdal.spec

diff --git a/gdal-gif.patch b/gdal-gif.patch
deleted file mode 100644 (file)
index ddf9129..0000000
+++ /dev/null
@@ -1,136 +0,0 @@
---- gdal-1.11.0/frmts/gif/gifdataset.cpp.orig  2014-04-16 22:04:33.000000000 +0200
-+++ gdal-1.11.0/frmts/gif/gifdataset.cpp       2014-06-14 16:10:22.245009208 +0200
-@@ -386,13 +386,21 @@
-             CPLDebug( "GIF",
-                       "Due to limitations of the GDAL GIF driver we deliberately avoid\n"
-                       "opening large GIF files (larger than 100 megapixels).");
-+#if defined(GIFLIB_MAJOR) && ((GIFLIB_MAJOR > 5) || ((GIFLIB_MAJOR == 5) && defined(GIFLIB_MINOR) && (GIFLIB_MINOR >= 1)))
-+            DGifCloseFile( hGifFile, NULL );
-+#else
-             DGifCloseFile( hGifFile );
-+#endif
-             VSIFCloseL( fp );
-             return NULL;
-         }
-     }
-+#if defined(GIFLIB_MAJOR) && ((GIFLIB_MAJOR > 5) || ((GIFLIB_MAJOR == 5) && defined(GIFLIB_MINOR) && (GIFLIB_MINOR >= 1)))
-+    DGifCloseFile( hGifFile, NULL );
-+#else
-     DGifCloseFile( hGifFile );
-+#endif
-     VSIFSeekL( fp, 0, SEEK_SET);
-@@ -417,7 +425,11 @@
-     if( nGifErr != GIF_OK || hGifFile->SavedImages == NULL )
-     {
-         VSIFCloseL( fp );
-+#if defined(GIFLIB_MAJOR) && ((GIFLIB_MAJOR > 5) || ((GIFLIB_MAJOR == 5) && defined(GIFLIB_MINOR) && (GIFLIB_MINOR >= 1)))
-+        DGifCloseFile(hGifFile, NULL);
-+#else
-         DGifCloseFile(hGifFile);
-+#endif
-         if( nGifErr == D_GIF_ERR_DATA_TOO_BIG )
-         {
-@@ -649,7 +661,11 @@
-     {
-         GifFreeMapObject(psGifCT);
-         GDALPrintGifError(hGifFile, "Error writing gif file.");
-+#if defined(GIFLIB_MAJOR) && ((GIFLIB_MAJOR > 5) || ((GIFLIB_MAJOR == 5) && defined(GIFLIB_MINOR) && (GIFLIB_MINOR >= 1)))
-+        EGifCloseFile(hGifFile, NULL);
-+#else
-         EGifCloseFile(hGifFile);
-+#endif
-         VSIFCloseL( fp );
-         return NULL;
-     }
-@@ -673,7 +689,11 @@
-     if (EGifPutImageDesc(hGifFile, 0, 0, nXSize, nYSize, bInterlace, NULL) == GIF_ERROR )
-     {
-         GDALPrintGifError(hGifFile, "Error writing gif file.");
-+#if defined(GIFLIB_MAJOR) && ((GIFLIB_MAJOR > 5) || ((GIFLIB_MAJOR == 5) && defined(GIFLIB_MINOR) && (GIFLIB_MINOR >= 1)))
-+        EGifCloseFile(hGifFile, NULL);
-+#else
-         EGifCloseFile(hGifFile);
-+#endif
-         VSIFCloseL( fp );
-         return NULL;
-     }
-@@ -756,7 +776,11 @@
- /* -------------------------------------------------------------------- */
- /*      cleanup                                                         */
- /* -------------------------------------------------------------------- */
-+#if defined(GIFLIB_MAJOR) && ((GIFLIB_MAJOR > 5) || ((GIFLIB_MAJOR == 5) && defined(GIFLIB_MINOR) && (GIFLIB_MINOR >= 1)))
-+    if (EGifCloseFile(hGifFile, NULL) == GIF_ERROR)
-+#else
-     if (EGifCloseFile(hGifFile) == GIF_ERROR)
-+#endif
-     {
-         CPLError( CE_Failure, CPLE_AppDefined, 
-                   "EGifCloseFile() failed.\n" );
-@@ -807,7 +831,11 @@
- error:
-     if (hGifFile)
-+#if defined(GIFLIB_MAJOR) && ((GIFLIB_MAJOR > 5) || ((GIFLIB_MAJOR == 5) && defined(GIFLIB_MINOR) && (GIFLIB_MINOR >= 1)))
-+        EGifCloseFile(hGifFile, NULL);
-+#else
-         EGifCloseFile(hGifFile);
-+#endif
-     if (fp)
-         VSIFCloseL( fp );
-     if (pabyScanline)
---- gdal-1.11.0/frmts/gif/biggifdataset.cpp.orig       2014-04-16 22:04:33.000000000 +0200
-+++ gdal-1.11.0/frmts/gif/biggifdataset.cpp    2014-06-14 17:36:54.164900991 +0200
-@@ -339,7 +339,11 @@
- /*      If the file is already open, close it so we can restart.        */
- /* -------------------------------------------------------------------- */
-     if( hGifFile != NULL )
-+#if defined(GIFLIB_MAJOR) && ((GIFLIB_MAJOR > 5) || ((GIFLIB_MAJOR == 5) && defined(GIFLIB_MINOR) && (GIFLIB_MINOR >= 1)))
-+        DGifCloseFile( hGifFile, NULL );
-+#else
-         DGifCloseFile( hGifFile );
-+#endif
- /* -------------------------------------------------------------------- */
- /*      If we are actually reopening, then we assume that access to     */
-@@ -413,7 +417,11 @@
-     if( RecordType != IMAGE_DESC_RECORD_TYPE )
-     {
-+#if defined(GIFLIB_MAJOR) && ((GIFLIB_MAJOR > 5) || ((GIFLIB_MAJOR == 5) && defined(GIFLIB_MINOR) && (GIFLIB_MINOR >= 1)))
-+        DGifCloseFile( hGifFile, NULL );
-+#else
-         DGifCloseFile( hGifFile );
-+#endif
-         hGifFile = NULL;
-         CPLError( CE_Failure, CPLE_OpenFailed, 
-@@ -423,7 +431,11 @@
-     
-     if (DGifGetImageDesc(hGifFile) == GIF_ERROR)
-     {
-+#if defined(GIFLIB_MAJOR) && ((GIFLIB_MAJOR > 5) || ((GIFLIB_MAJOR == 5) && defined(GIFLIB_MINOR) && (GIFLIB_MINOR >= 1)))
-+        DGifCloseFile( hGifFile, NULL );
-+#else
-         DGifCloseFile( hGifFile );
-+#endif
-         hGifFile = NULL;
-         CPLError( CE_Failure, CPLE_OpenFailed, 
---- gdal-1.11.0/frmts/gif/gifabstractdataset.cpp.orig  2014-04-16 22:04:33.000000000 +0200
-+++ gdal-1.11.0/frmts/gif/gifabstractdataset.cpp       2014-06-14 18:52:07.828140246 +0200
-@@ -82,7 +82,11 @@
-     }
-     if( hGifFile )
-+#if defined(GIFLIB_MAJOR) && ((GIFLIB_MAJOR > 5) || ((GIFLIB_MAJOR == 5) && defined(GIFLIB_MINOR) && (GIFLIB_MINOR >= 1)))
-+        DGifCloseFile( hGifFile, NULL );
-+#else
-         DGifCloseFile( hGifFile );
-+#endif
-     if( fp != NULL )
-         VSIFCloseL( fp );
index 692affa2d1489e2092e1e03504c2a9c91193e567..f9f124b92274fb5f5afa80efa757ba678f203c8e 100644 (file)
 +GDALGridInverseDistanceToAPower2NoSmoothingNoSearchSSE(
 +                                        const void *poOptions,
 +                                        GUInt32 nPoints,
-+                                        const double *unused_padfX,
-+                                        const double *unused_padfY,
-+                                        const double *unused_padfZ,
++                                        CPL_UNUSED const double *unused_padfX,
++                                        CPL_UNUSED const double *unused_padfY,
++                                        CPL_UNUSED const double *unused_padfZ,
 +                                        double dfXPoint, double dfYPoint,
 +                                        double *pdfValue,
 +                                        void* hExtraParamsIn )
 -#include <xmmintrin.h>
 -#endif
 -
- CPL_CVSID("$Id: gdalgrid.cpp 27110 2014-03-28 21:29:20Z rouault $");
+ CPL_CVSID("$Id: gdalgrid.cpp 27729 2014-09-24 00:40:16Z goatbar $");
  
  #define TO_RADIANS (3.14159265358979323846 / 180.0)
 @@ -53,74 +49,6 @@
 -GDALGridInverseDistanceToAPower2NoSmoothingNoSearchSSE(
 -                                        const void *poOptions,
 -                                        GUInt32 nPoints,
--                                        const double *unused_padfX,
--                                        const double *unused_padfY,
--                                        const double *unused_padfZ,
+-                                        CPL_UNUSED const double *unused_padfX,
+-                                        CPL_UNUSED const double *unused_padfY,
+-                                        CPL_UNUSED const double *unused_padfZ,
 -                                        double dfXPoint, double dfYPoint,
 -                                        double *pdfValue,
 -                                        void* hExtraParamsIn )
  /*                        GDALGridMovingAverage()                       */
  /************************************************************************/
  
-@@ -1766,7 +1552,9 @@
-                             pabyX = pabyY = pabyZ = NULL;
-                         }
-                     }
-+#  ifdef HAVE_SSE_AT_COMPILE_TIME
-                     else
-+#  endif
- #endif
- #ifdef HAVE_SSE_AT_COMPILE_TIME
 --- gdal-1.11.0/alg/GNUmakefile.orig   2014-04-16 22:04:48.000000000 +0200
 +++ gdal-1.11.0/alg/GNUmakefile        2014-05-11 21:56:55.699137906 +0200
 @@ -16,6 +16,10 @@
index 3e194f5774131d712014ccef4f470d5dd22ba4f4..e8259b611b75371e9ea349b213791a5a06b999b7 100644 (file)
--- a/gdal.spec
+++ b/gdal.spec
 Summary:       Geospatial Data Abstraction Library
 Summary(pl.UTF-8):     Biblioteka abstrakcji danych dotyczÄ…cych powierzchni Ziemi
 Name:          gdal
-Version:       1.11.0
-Release:       9
+Version:       1.11.1
+Release:       1
 License:       BSD-like
 Group:         Libraries
 Source0:       http://download.osgeo.org/gdal/%{version}/%{name}-%{version}.tar.xz
-# Source0-md5: 31f2c4a7230b40e5fdc3cf12a100f96b
+# Source0-md5: 2e126d7c6605691d38f3e71b945f5c73
 Patch0:                %{name}-perl.patch
 Patch1:                %{name}-python_install.patch
 Patch2:                %{name}-php.patch
@@ -64,7 +64,6 @@ Patch6:               %{name}-sse.patch
 Patch7:                %{name}-link.patch
 Patch8:                %{name}-fyba.patch
 Patch9:                %{name}-dds.patch
-Patch10:       %{name}-gif.patch
 Patch11:       %{name}-armadillo.patch
 Patch12:       %{name}-oci.patch
 Patch13:       %{name}-rasdaman.patch
@@ -292,7 +291,6 @@ osr.
 %patch7 -p1
 %patch8 -p1
 %patch9 -p1
-%patch10 -p1
 %patch11 -p1
 %patch12 -p1
 %patch13 -p1
This page took 0.047721 seconds and 4 git commands to generate.