]> git.pld-linux.org Git - packages/gdal.git/commitdiff
- updated to 1.11.2
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 1 Mar 2015 09:36:42 +0000 (10:36 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 1 Mar 2015 09:36:42 +0000 (10:36 +0100)
- updated format-security patch
- removed obsolete oci patch

gdal-format-security.patch
gdal-oci.patch [deleted file]
gdal.spec

index 063e5711e846b104d8b951789aea0c23ef6c2044..49c33e53e2d701568441c30b671c844912b51660 100644 (file)
@@ -9,9 +9,9 @@
    }
  }
  
---- gdal-1.11.0/ogr/ogrsf_frmts/sxf/ogrsxfdatasource.cpp.orig  2014-04-16 22:04:02.000000000 +0200
-+++ gdal-1.11.0/ogr/ogrsf_frmts/sxf/ogrsxfdatasource.cpp       2014-05-10 17:33:52.404601057 +0200
-@@ -459,7 +459,7 @@
+--- gdal-1.11.2/ogr/ogrsf_frmts/sxf/ogrsxfdatasource.cpp.orig  2015-02-10 13:11:16.000000000 +0100
++++ gdal-1.11.2/ogr/ogrsf_frmts/sxf/ogrsxfdatasource.cpp       2015-02-28 12:20:28.595919291 +0100
+@@ -458,7 +458,7 @@
      if (nEPSG == 0)
      {
          CPLError( CE_Warning, CPLE_NotSupported,
          return;
      }
  
-@@ -468,14 +468,14 @@
+@@ -467,14 +467,14 @@
      if (eImportFromEPSGErr != OGRERR_NONE)
      {
          CPLError( CE_Warning, CPLE_None,
--                  CPLString().Printf("SXF. Vertical coordinate system (SXF index %ld, EPSG %d) import from EPSG error", iVCS, nEPSG) );
-+                  "SXF. Vertical coordinate system (SXF index %ld, EPSG %d) import from EPSG error", iVCS, nEPSG );
+-                  CPLString().Printf("SXF. Vertical coordinate system (SXF index %ld, EPSG %ld) import from EPSG error", iVCS, nEPSG) );
++                  "SXF. Vertical coordinate system (SXF index %ld, EPSG %ld) import from EPSG error", iVCS, nEPSG );
          return;
      }
  
      if (sr->IsVertical() != 1)
      {
          CPLError( CE_Warning, CPLE_None,
--                  CPLString().Printf("SXF. Coordinate system (SXF index %ld, EPSG %d) is not Vertical", iVCS, nEPSG) );
-+                  "SXF. Coordinate system (SXF index %ld, EPSG %d) is not Vertical", iVCS, nEPSG );
+-                  CPLString().Printf("SXF. Coordinate system (SXF index %ld, EPSG %ld) is not Vertical", iVCS, nEPSG) );
++                  "SXF. Coordinate system (SXF index %ld, EPSG %ld) is not Vertical", iVCS, nEPSG );
          return;
      }
  
-@@ -484,7 +484,7 @@
+@@ -483,7 +483,7 @@
      if (eSetVertCSErr != OGRERR_NONE)
      {
          CPLError( CE_Warning, CPLE_None,
--                  CPLString().Printf("SXF. Vertical coordinate system (SXF index %ld, EPSG %d) set error", iVCS, nEPSG) );
-+                  "SXF. Vertical coordinate system (SXF index %ld, EPSG %d) set error", iVCS, nEPSG );
+-                  CPLString().Printf("SXF. Vertical coordinate system (SXF index %ld, EPSG %ld) set error", iVCS, nEPSG) );
++                  "SXF. Vertical coordinate system (SXF index %ld, EPSG %ld) set error", iVCS, nEPSG );
          return;
      }
  }
+--- gdal-1.11.2/ogr/ogrsf_frmts/oci/ogrociwritablelayer.cpp.orig       2015-02-10 13:11:16.000000000 +0100
++++ gdal-1.11.2/ogr/ogrsf_frmts/oci/ogrociwritablelayer.cpp    2015-02-28 13:46:28.845702734 +0100
+@@ -321,7 +321,7 @@
+                           + strlen(oField.GetNameRef())
+                           + strlen(szFieldType) );
+-    snprintf( szFieldName, sizeof( szFieldName ), oField.GetNameRef());
++    snprintf( szFieldName, sizeof( szFieldName ), "%s", oField.GetNameRef());
+     szFieldName[sizeof( szFieldName )-1] = '\0';
+     if ( strlen(oField.GetNameRef()) > sizeof ( szFieldName ) )
+     {
diff --git a/gdal-oci.patch b/gdal-oci.patch
deleted file mode 100644 (file)
index 8495838..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
---- gdal-1.11.0/m4/ax_oracle_oci.m4.orig       2014-04-16 22:04:00.000000000 +0200
-+++ gdal-1.11.0/m4/ax_oracle_oci.m4    2014-06-14 17:01:57.071611368 +0200
-@@ -156,12 +156,14 @@
-         dnl Depending on later Oracle version detection,
-         dnl -lnnz10 flag might be removed for older Oracle < 10.x
-         saved_LDFLAGS="$LDFLAGS"
-+        saved_LIBS="$LIBS"
-       if test -n "$oracle_include_dir" ; then
--          oci_ldflags="-L$oracle_lib_dir -lclntsh"
-+          oci_ldflags="-L$oracle_lib_dir"
-         else
--          oci_ldflags="-L$oracle_lib_dir -L$oracle_lib_dir2 -lclntsh"
-+          oci_ldflags="-L$oracle_lib_dir -L$oracle_lib_dir2"
-         fi
-         LDFLAGS="$LDFLAGS $oci_ldflags"
-+      LIBS="$LIBS -lclntsh"
-         dnl
-         dnl Check OCI headers
-@@ -231,7 +233,7 @@
-                     ]]
-                 )],
-                 [
--                ORACLE_OCI_LDFLAGS="$oci_ldflags"
-+                ORACLE_OCI_LDFLAGS="$oci_ldflags -lclntsh"
-                 oci_lib_found="yes"
-                 AC_MSG_RESULT([yes])
-                 ],
-@@ -245,6 +247,7 @@
-         CPPFLAGS="$saved_CPPFLAGS"
-         LDFLAGS="$saved_LDFLAGS"
-+        LIBS="$saved_LIBS"
-     fi
-     dnl
index faa267fcdbb2bdbf37aae25a341d46169dccd38d..b2b7e0767edb0fc37f97d7ce97a581f4595f90c9 100644 (file)
--- a/gdal.spec
+++ b/gdal.spec
 Summary:       Geospatial Data Abstraction Library
 Summary(pl.UTF-8):     Biblioteka abstrakcji danych dotyczÄ…cych powierzchni Ziemi
 Name:          gdal
-Version:       1.11.1
-Release:       2
+Version:       1.11.2
+Release:       1
 License:       BSD-like
 Group:         Libraries
 Source0:       http://download.osgeo.org/gdal/%{version}/%{name}-%{version}.tar.xz
-# Source0-md5: 2e126d7c6605691d38f3e71b945f5c73
+# Source0-md5: 90221810dd9ca656ee23d434d4266ef6
 Patch0:                %{name}-perl.patch
 Patch1:                %{name}-python_install.patch
 Patch2:                %{name}-php.patch
@@ -65,8 +65,7 @@ Patch7:               %{name}-link.patch
 Patch8:                %{name}-fyba.patch
 Patch9:                %{name}-dds.patch
 Patch11:       %{name}-armadillo.patch
-Patch12:       %{name}-oci.patch
-Patch13:       %{name}-rasdaman.patch
+Patch12:       %{name}-rasdaman.patch
 URL:           http://www.gdal.org/
 %{?with_php:BuildRequires:     %{php_name}-devel}
 %{?with_opencl:BuildRequires:  OpenCL-devel >= 1.0}
@@ -293,7 +292,6 @@ osr.
 %patch9 -p1
 %patch11 -p1
 %patch12 -p1
-%patch13 -p1
 
 # need to regenerate (old ones don't support perl 5.10 or php 5.5)
 %{__rm} swig/{perl,php}/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
This page took 0.065552 seconds and 4 git commands to generate.