]> git.pld-linux.org Git - packages/gdal.git/commitdiff
- updated for 1.5.1
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 10 Jun 2008 19:59:46 +0000 (19:59 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    gdal-perl.patch -> 1.2
    gdal-ruby.patch -> 1.2

gdal-perl.patch
gdal-ruby.patch

index 7face086d8e24a73c711b21502982408dd7944d8..e0bec70e3e28637e3a85d9e641d97e15952dc786 100644 (file)
@@ -1,11 +1,11 @@
---- gdal-1.4.1/swig/perl/GNUmakefile.orig      2007-04-10 17:16:46.000000000 +0200
-+++ gdal-1.4.1/swig/perl/GNUmakefile   2007-06-16 19:40:39.158840342 +0200
-@@ -26,7 +26,7 @@
-       if [ -f OSR.pm ]; then mv OSR.pm lib/Geo; fi
+--- gdal-1.5.1/swig/perl/GNUmakefile.orig      2007-12-03 21:59:25.000000000 +0100
++++ gdal-1.5.1/swig/perl/GNUmakefile   2008-06-05 21:12:26.429445475 +0200
+@@ -30,7 +30,7 @@
  
  Makefile_Geo__GDAL:
--      PREFIX=${INST_PREFIX} perl Makefile.PL
-+      PREFIX=${INST_PREFIX} perl Makefile.PL INSTALLDIRS=vendor
+ #     PREFIX=${INST_PREFIX} perl Makefile.PL
+-      perl Makefile.PL
++      perl Makefile.PL INSTALLDIRS=vendor
  
  build: Makefile_Geo__GDAL
-       make -f Makefile_Geo__GDAL
+       $(MAKE) -f Makefile_Geo__GDAL
index fabd427a127dacbe8d40dd9bcdb05a1fc9f08e01..c0ca10fd1ee88a3f7a28e7010d7199301ce4995b 100644 (file)
@@ -1,20 +1,40 @@
---- gdal-1.4.1/swig/ruby/RubyMakefile.mk.orig  2007-04-10 17:16:43.000000000 +0200
-+++ gdal-1.4.1/swig/ruby/RubyMakefile.mk       2007-06-16 19:54:08.240947303 +0200
-@@ -45,13 +45,13 @@
+--- gdal-1.5.1/swig/ruby/RubyMakefile.mk.orig  2006-12-21 03:49:08.000000000 +0100
++++ gdal-1.5.1/swig/ruby/RubyMakefile.mk       2008-06-06 21:48:10.535282314 +0200
+@@ -17,7 +17,7 @@
+ include $(GDAL_ROOT)/GDALmake.opt
+-RUBY_MODULES = gdal.so ogr.so gdalconst.so osr.so
++RUBY_MODULES = gdal.la ogr.la gdalconst.la osr.la
+ RUBY_INCLUDE_DIR := $(shell ruby -rrbconfig -e "puts Config::CONFIG['archdir']")
+ RUBY_LIB_DIR := $(shell ruby -rrbconfig -e "puts Config::CONFIG['libdir']")
+ RUBY_SO_NAME := $(shell ruby -rrbconfig -e "puts Config::CONFIG['RUBY_SO_NAME']")
+@@ -25,7 +25,7 @@
+ INSTALL_DIR := $(RUBY_EXTENSIONS_DIR)/gdal
+ RUBY_INCLUDE = -I$(RUBY_INCLUDE_DIR)
+-LDFLAGS += -shared -L$(RUBY_LIB_DIR)
++LDFLAGS += -shared -module -avoid-version -rpath $(INSTALL_DIR) -L$(RUBY_LIB_DIR)
+ RUBY_LIB := -l$(RUBY_SO_NAME)
+ build: $(RUBY_MODULES)
+@@ -44,14 +44,14 @@
+ install: $(INSTALL_DIR)
        $(INSTALL) $(RUBY_MODULES) $(DESTDIR)$(INSTALL_DIR) 
  
- $(RUBY_MODULES): %.so: %_wrap.o
+-$(RUBY_MODULES): %.so: %_wrap.o
 -      $(LD) $(LDFLAGS) $(LIBS) $(GDAL_SLIB_LINK) $(RUBY_LIB) $< -o $@
++$(RUBY_MODULES): %.la: %_wrap.lo
 +      $(LD) $(GDAL_SLIB_LINK) $(LDFLAGS) $(LIBS) $(RUBY_LIB) $< -o $@
  
- %.o: %.cpp
--      $(CXX) $(CFLAGS) $(GDAL_INCLUDE) $(RUBY_INCLUDE)  -c $<
-+      $(CXX) $(CFLAGS) $(GDAL_INCLUDE) $(RUBY_INCLUDE) -fPIC -c $<
+-%.o: %.cpp
++%.lo: %.cpp
+       $(CXX) $(CFLAGS) $(GDAL_INCLUDE) $(RUBY_INCLUDE)  -c $<
  
- %.o: %.cxx
--      $(CXX) $(CFLAGS) $(GDAL_INCLUDE) $(RUBY_INCLUDE) -c $<
-+      $(CXX) $(CFLAGS) $(GDAL_INCLUDE) $(RUBY_INCLUDE) -fPIC -c $<
+-%.o: %.cxx
++%.lo: %.cxx
+       $(CXX) $(CFLAGS) $(GDAL_INCLUDE) $(RUBY_INCLUDE) -c $<
  
- %.o: %.c
--      $(CC) $(CFLAGS) $(GDAL_INCLUDE)  $(RUBY_INCLUDE) -c $<
-+      $(CC) $(CFLAGS) $(GDAL_INCLUDE)  $(RUBY_INCLUDE) -fPIC -c $<
+-%.o: %.c
++%.lo: %.c
+       $(CC) $(CFLAGS) $(GDAL_INCLUDE)  $(RUBY_INCLUDE) -c $<
This page took 0.127971 seconds and 4 git commands to generate.