]> git.pld-linux.org Git - packages/gdal.git/blobdiff - gdal.spec
Release 21 (by relup.sh)
[packages/gdal.git] / gdal.spec
index ad82eca79bc5975f9bb2b8bbad5d21bbbbaa05ff..b60a35f036e8131dbd056d0be7469b9a8a7b01d9 100644 (file)
--- a/gdal.spec
+++ b/gdal.spec
 %if %{with podofo}
 %undefine      with_poppler
 %endif
+
+%{?use_default_jdk}
+
 Summary:       Geospatial Data Abstraction Library
 Summary(pl.UTF-8):     Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
 Name:          gdal
-Version:       3.0.1
-Release:       1
+Version:       3.0.4
+Release:       21
 License:       BSD-like
 Group:         Libraries
 Source0:       https://github.com/OSGeo/gdal/releases/download/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 2b397c041e6b0b10ec7c49fd76e9fa99
+# Source0-md5: c6bbb5caca06e96bd97a32918e0aa9aa
 Patch0:                %{name}-perl.patch
 Patch1:                %{name}-pc.patch
 Patch2:                %{name}-dds.patch
 Patch3:                %{name}-rasdaman.patch
 Patch4:                %{name}-pluginsdir.patch
 Patch5:                libx32.patch
-Patch6:                poppler-0.82.patch
+Patch6:                %{name}-poppler.patch
+Patch7:                decl.patch
+Patch8:                %{name}_tirpcinc.patch
+Patch9:                jasper.patch
+Patch10:       gcc11.patch
 URL:           http://www.gdal.org/
 # 1.x or 2.x supported
 BuildRequires: CharLS-devel
@@ -85,7 +92,7 @@ BuildRequires:        giflib-devel >= 4.0
 BuildRequires: hdf-devel >= 4.2.5
 BuildRequires: hdf5-devel
 BuildRequires: jasper-devel
-%{?with_java:BuildRequires:    jdk}
+%{?with_java:%buildrequires_jdk}
 %{?with_java:BuildRequires:    jpackage-utils}
 BuildRequires: json-c-devel >= 0.11
 %{?with_kea:BuildRequires:     kealib-devel}
@@ -127,7 +134,7 @@ BuildRequires:      python-setuptools
 BuildRequires: qhull-devel >= 2012
 %{?with_rasdaman:BuildRequires:        rasdaman-devel}
 BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.344
+BuildRequires: rpmbuild(macros) >= 2.021
 BuildRequires: sed >= 4.0
 BuildRequires: sqlite3-devel >= 3.0.0
 BuildRequires: swig-perl
@@ -140,6 +147,7 @@ BuildRequires:      xz-devel
 BuildRequires: zlib-devel >= 1.1.4
 # for ZSTD compression in TIFF
 BuildRequires: zstd-devel
+%{?with_java:Requires:  %{?use_jdk:%{use_jdk}-jre-base}%{!?use_jdk:jre}}
 Requires:      freexl >= 1.0
 Requires:      geos >= 3.1.0
 Requires:      hdf >= 4.2.5
@@ -273,6 +281,10 @@ Moduł Pythona GDAL.
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
+%patch7 -p1
+%patch8 -p1
+%patch9 -p2
+%patch10 -p2
 
 # need to regenerate (old ones don't support perl 5.10)
 %{__rm} swig/perl/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
@@ -284,7 +296,39 @@ sed -i -e 's#^mandir=.*##g' configure.ac
 
 %{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.ac
 
+sed -E -i -e '1s,#!\s*/usr/bin/env\s+python2(\s|$),#!%{__python}\1,' \
+         -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python}\1,' \
+         -e '1s,#!\s*/usr/bin/python(\s|$),#!%{__python}\1,' \
+      swig/python/scripts/epsg_tr.py \
+      swig/python/scripts/esri2wkt.py \
+      swig/python/scripts/gcps2vec.py \
+      swig/python/scripts/gcps2wld.py \
+      swig/python/scripts/gdal2tiles.py \
+      swig/python/scripts/gdal2xyz.py \
+      swig/python/scripts/gdal_auth.py \
+      swig/python/scripts/gdal_calc.py \
+      swig/python/scripts/gdal_edit.py \
+      swig/python/scripts/gdal_fillnodata.py \
+      swig/python/scripts/gdal_merge.py \
+      swig/python/scripts/gdal_pansharpen.py \
+      swig/python/scripts/gdal_polygonize.py \
+      swig/python/scripts/gdal_proximity.py \
+      swig/python/scripts/gdal_retile.py \
+      swig/python/scripts/gdal_sieve.py \
+      swig/python/scripts/gdalchksum.py \
+      swig/python/scripts/gdalcompare.py \
+      swig/python/scripts/gdalident.py \
+      swig/python/scripts/gdalimport.py \
+      swig/python/scripts/gdalmove.py \
+      swig/python/scripts/mkgraticule.py \
+      swig/python/scripts/ogrmerge.py \
+      swig/python/scripts/pct2rgb.py \
+      swig/python/scripts/rgb2pct.py
+
 %build
+cp -f /usr/share/gettext/config.rpath .
+
+%if %{with java}
 %ifarch %{x8664}
 jvm_arch=amd64
 %endif
@@ -294,6 +338,21 @@ jvm_arch=i386
 %ifarch x32
 jvm_arch=x32
 %endif
+%ifarch aarch64
+jvm_arch=aarch64
+%endif
+%ifarch %{arm}
+jvm_arch=aarch32
+%endif
+for jvm_type in server client; do
+       for dir in lib jre/lib/$jvm_arch; do
+               if [ -f "%{java_home}/$dir/$jvm_type/libjvm.so" ]; then
+                       jvm_lib="%{java_home}/$dir/$jvm_type"
+                       break
+               fi
+       done
+done
+%endif
 
 %{__libtoolize}
 %{__aclocal} -I m4
@@ -312,7 +371,7 @@ jvm_arch=x32
        %{?with_java:--with-java=%{java_home}} \
        --with-liblzma \
        %{!?with_kea:--without-kea} \
-       %{?with_java:--with-mdb --with-jvm-lib-add-rpath --with-jvm-lib=%{java_home}/jre/lib/$jvm_arch/server} \
+       %{?with_java:--with-mdb --with-jvm-lib-add-rpath --with-jvm-lib="$jvm_lib"} \
        %{?with_mysql:--with-mysql} \
        %{?with_oci:--with-oci --with-oci-include=/usr/include/oracle/client --with-oci-lib=%{_libdir}} \
        %{?with_opencl:--with-opencl} \
This page took 0.062789 seconds and 4 git commands to generate.