]> git.pld-linux.org Git - packages/gdal.git/blobdiff - gdal.spec
- updated openjpeg2 patch to fix build also when size_t is not 32-bit
[packages/gdal.git] / gdal.spec
index 40449f9874ec08488ad065b435392b3a81ebc53b..c1f0adc3181b744f6e7b78e45773d65b09ed2d0b 100644 (file)
--- a/gdal.spec
+++ b/gdal.spec
@@ -2,15 +2,12 @@
 # - be reasonable about devel dependencies - you do not need all of them to
 #   use gdal (probably a gdal module or driver shall not imply devel
 #   dependency)
-# - spatialite (--with-spatialite; libspatialite: http://www.gaia-gis.it/gaia-sins/)
-# - freexl (http://www.gaia-gis.it/FreeXL/)
 # - rasdaman (--with-rasdaman; http://rasdaman.eecs.jacobs-university.de/trac/rasdaman/wiki/Download)
-# - armadillo (--with-armadillo; http://arma.sourceforge.net/)
 # - openjpeg (unreleased post-1.5 or 2? needs opj_decode_tile_data symbol, not available in 1.3-1.5)
-# - libjpeg12 (needs patching to use system one)
+# - libjpeg12 (needs patching to use system one, --with-jpeg12 is not sufficient as of 1.9.2)
 # - libkml (1.3.0 needed, not released yet)
 # - wait for newer pcidsk, switch to external again
-# - csharp, java, mysql
+# - csharp, java
 # - additional, proprietary(?) formats support:
 #   - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
 #   - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
 #   - Informix DB
 #   - DWGdirect (members only? http://www.opendwg.org/)
 #   - ESRI SDE (http://www.esri.com/software/arcgis/arcsde/index.html)
-#   - OpenCL (--with-opencl; no free Linux implementation yet?)
 #
 # Conditional build:
-%bcond_without epsilon # EPSILON wavelet compression support
-%bcond_without gta     # GTA format support
-%bcond_without odbc    # disable ODBC DB support
-%bcond_with    podofo  # PDF support via podofo instead of poppler
-%bcond_without poppler # PDF support via poppler
-%bcond_without xerces  # disable xerces support
-%bcond_without java    # disable Java and MDB support
-%bcond_without php     # disable PHP binding
-%bcond_without ruby    # disable ruby binding
+%bcond_without armadillo       # Armadillo support for faster TPS transform
+%bcond_without epsilon         # EPSILON wavelet compression support
+%bcond_without gta             # GTA format support
+%bcond_without mysql           # MySQL DB support
+%bcond_without odbc            # ODBC DB support
+%bcond_without opencl          # OpenCL (GPU) support
+%bcond_without openjpeg        # OpenJPEG 2 (JPEG2000) support
+%bcond_with    podofo          # PDF support via podofo instead of poppler
+%bcond_without poppler         # PDF support via poppler
+%bcond_without spatialite      # SpatiaLite support
+%bcond_without xerces          # Xerces support
+%bcond_without java            # Java and MDB support
+%bcond_without php             # PHP binding
+%bcond_without ruby            # ruby binding
 #
 %if %{with podofo}
 %undefine      with_poppler
 Summary:       Geospatial Data Abstraction Library
 Summary(pl.UTF-8):     Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
 Name:          gdal
-Version:       1.9.1
-Release:       2
+Version:       1.9.2
+Release:       6
 License:       BSD-like
 Group:         Libraries
 Source0:       ftp://ftp.remotesensing.org/gdal/%{name}-%{version}.tar.gz
-# Source0-md5: c5cf09b92dac1f5775db056e165b34f5
+# Source0-md5: 3f39db89f4710269b3a8bf94178e07aa
 Patch0:                %{name}-perl.patch
 Patch1:                %{name}-python_install.patch
-Patch2:                gdal-1.9.1-poppler020.patch
-
-Patch4:                %{name}-php.patch
-Patch5:                %{name}-fpic.patch
+Patch2:                %{name}-php.patch
+Patch3:                %{name}-fpic.patch
+Patch4:                %{name}-format-security.patch
+Patch5:                %{name}-openjpeg2.patch
+Patch6:                %{name}-hdf4-eos.patch
 URL:           http://www.gdal.org/
+%{?with_opencl:BuildRequires:  OpenCL-devel >= 1.0}
+%{?with_armadillo:BuildRequires:       armadillo-devel}
 BuildRequires: autoconf >= 2.52
 BuildRequires: automake
 BuildRequires: cfitsio-devel
@@ -62,6 +66,7 @@ BuildRequires:        curl-devel
 BuildRequires: doxygen >= 1.4.2
 %{?with_epsilon:BuildRequires: epsilon-compressor-devel}
 BuildRequires: expat-devel >= 1.95.0
+BuildRequires: freexl-devel >= 1.0
 BuildRequires: geos-devel >= 2.2.0
 BuildRequires: giflib-devel >= 4.0
 BuildRequires: hdf-devel >= 4.0
@@ -76,14 +81,17 @@ BuildRequires:      libgeotiff-devel >= 1.2.1
 BuildRequires: libjpeg-devel >= 6b
 #BuildRequires:        libkml-devel >= 1.3.0
 BuildRequires: libpng-devel >= 2:1.2.8
+%{?with_spatialite:BuildRequires:      libspatialite-devel}
 BuildRequires: libstdc++-devel
 BuildRequires: libtiff-devel >= 4.0
 BuildRequires: libtool
 BuildRequires: libuuid-devel
 BuildRequires: libwebp-devel
 BuildRequires: libxml2-devel
-BuildRequires: netcdf-devel >= 4
+%{?with_mysql:BuildRequires:   mysql-devel}
+BuildRequires: netcdf-devel >= 4.1
 BuildRequires: ogdi-devel >= 3.1
+%{?with_openjpeg:BuildRequires:        openjpeg2-devel >= 2.0.0-2}
 #BuildRequires:        pcidsk-devel > 0.3
 BuildRequires: perl-devel
 %{?with_php:BuildRequires:     php-devel}
@@ -104,17 +112,13 @@ BuildRequires:    sqlite3-devel >= 3.0.0
 BuildRequires: swig-perl
 BuildRequires: swig-python >= 1.3
 %{?with_ruby:BuildRequires:    swig-ruby}
-%if "%{pld_release}" == "ti"
-BuildRequires: tetex-format-latex
-BuildRequires: tetex-dvips
-%else
 BuildRequires: texlive-dvips
 BuildRequires: texlive-latex
-%endif
 %{?with_odbc:BuildRequires:    unixODBC-devel >= 2.2.15}
 %{?with_xerces:BuildRequires:  xerces-c-devel >= 2.7.0}
 BuildRequires: xz-devel
 BuildRequires: zlib-devel >= 1.1.4
+Requires:      freexl >= 1.0
 Requires:      geos >= 2.2.0
 Requires:      libgeotiff >= 1.2.1
 Requires:      libpng >= 2:1.2.8
@@ -142,10 +146,13 @@ Summary:  GDAL library header files
 Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki GDAL
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
+%{?with_opencl:Requires:       OpenCL-devel >= 1.0}
+%{?with_armadillo:Requires:    armadillo-devel}
 Requires:      cfitsio-devel
 Requires:      curl-devel
 %{?with_epsilon:Requires:      epsilon-compressor-devel}
 Requires:      expat-devel >= 1.95.0
+Requires:      freexl-devel >= 1.0
 Requires:      geos-devel >= 2.2.0
 Requires:      giflib-devel >= 4.0
 Requires:      hdf-devel >= 4.0
@@ -157,13 +164,16 @@ Requires: libgeotiff-devel >= 1.2.1
 %{?with_gta:Requires:  libgta-devel}
 Requires:      libjpeg-devel >= 6b
 Requires:      libpng-devel >= 2:1.2.8
+%{?with_spatialite:Requires:   libspatialite-devel}
 Requires:      libstdc++-devel
 Requires:      libtiff-devel >= 4.0
 Requires:      libuuid-devel
 Requires:      libwebp-devel
 Requires:      libxml2-devel
+%{?with_mysql:Requires:        mysql-devel}
 Requires:      netcdf-devel >= 4
 Requires:      ogdi-devel >= 3.1
+%{?with_openjpeg:Requires:     openjpeg2-devel >= 2.0.0-2}
 #Requires:     pcidsk-devel > 0.3
 %{?with_podofo:Requires:       podofo-devel}
 %{?with_poppler:Requires:      poppler-devel}
@@ -249,10 +259,11 @@ osr.
 %setup -q
 %patch0 -p1
 %patch1 -p1
-%patch2 -p4
-
+%patch2 -p1
+%patch3 -p1
 %patch4 -p1
 %patch5 -p1
+%patch6 -p1
 
 # need to regenerate (old ones don't support perl 5.10)
 %{__rm} swig/perl/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
@@ -269,18 +280,22 @@ osr.
 %configure \
        --datadir=%{_datadir}/gdal \
        --with-dods-root=/usr \
+       %{?with_armadillo:--with-armadillo} \
        %{?with_epsilon:--with-epsilon} \
        %{!?with_gta:--without-gta} \
        --with-hide-internal-symbols \
        %{?with_java:--with-java=%{java_home}} \
        --with-liblzma \
        %{?with_java:--with-mdb --with-jvm-lib-add-rpath} \
+       %{?with_mysql:--with-mysql} \
+       %{?with_opencl:--with-opencl} \
        --with-perl \
        %{?with_php:--with-php} \
        %{?with_podofo:--with-podofo} \
        %{?with_poppler:--with-poppler} \
        --with-python \
        %{?with_ruby:--with-ruby} \
+       %{?with_spatialite:--with-spatialite} \
        --with-sqlite3 \
        --with-webp \
        %{?with_xerces:--with-xerces} \
@@ -288,12 +303,15 @@ osr.
        --with-xerces-lib="-lxerces-c" \
        --without-grass \
        --without-libgrass
+#      --with-rasdaman
 #      --with-pcidsk=/usr (needs > 0.3)
 # csharp builds, but has no configure option
 
 # regenerate where needed
 %{__make} -j1 -C swig/perl generate
-%{?with_ruby:%{__make} -j1 -C swig/ruby generate}
+%if %{with ruby}
+%{__make} -j1 -C swig/ruby generate
+%endif
 
 %{__make} -j1
 
This page took 0.045275 seconds and 4 git commands to generate.