]> git.pld-linux.org Git - packages/gdal.git/blobdiff - gdal.spec
- release 6
[packages/gdal.git] / gdal.spec
index bb352e02ef327d64924d8c0b9a65feb3c48ef906..bf95d8a257dbdd0368163505b54d5d14876b47d0 100644 (file)
--- a/gdal.spec
+++ b/gdal.spec
@@ -1,3 +1,4 @@
+# TODO: csharp, java
 #
 # Conditional build:
 %bcond_without odbc    # disable odbc support
@@ -7,23 +8,28 @@
 Summary:       Geospatial Data Abstraction Library
 Summary(pl.UTF-8):     Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
 Name:          gdal
-Version:       1.4.2
-Release:       1
+Version:       1.6.1
+Release:       6
 License:       BSD-like
 Group:         Libraries
-#Source0:      http://download.osgeo.org/gdal/%{name}-%{version}.tar.gz
-Source0:       ftp://ftp.gdal.org/gdal/%{name}-%{version}.tar.gz
-# Source0-md5: dedf5ff6a766e85b9a2b5c54c1c59221
+Source0:       ftp://ftp.remotesensing.org/gdal/%{name}-%{version}.tar.gz
+# Source0-md5: 4059285a5cef41ff975ed0ec02a97009
 Patch0:                %{name}-dods.patch
 Patch1:                %{name}-perl.patch
 Patch2:                %{name}-ruby.patch
+Patch3:                %{name}-asneeded.patch
+Patch4:                %{name}-ogdi.patch
+Patch5:                %{name}-python_install.patch
 URL:           http://www.gdal.org/
-BuildRequires: autoconf
+BuildRequires: autoconf >= 2.52
+BuildRequires: automake
 BuildRequires: cfitsio-devel
 BuildRequires: doxygen
+BuildRequires: expat-devel >= 1.95.0
 BuildRequires: geos-devel >= 2.0
 BuildRequires: giflib-devel >= 4.0
 BuildRequires: hdf-devel >= 4.0
+BuildRequires: hdf5-devel
 BuildRequires: jasper-devel
 BuildRequires: libcsf-devel
 BuildRequires: libdap-devel >= 3.5
@@ -32,16 +38,27 @@ BuildRequires:      libjpeg-devel >= 6b
 BuildRequires: libpng-devel >= 2:1.2.8
 BuildRequires: libstdc++-devel
 BuildRequires: libtiff-devel >= 3.6.0
+BuildRequires: libtool
 BuildRequires: netcdf-devel
 BuildRequires: ogdi-devel >= 3.1
 BuildRequires: perl-devel
-BuildRequires: postgresql-devel
 BuildRequires: postgresql-backend-devel
-BuildRequires: python-numpy-devel
-BuildRequires: python-devel
+BuildRequires: postgresql-devel
+BuildRequires: python-devel >= 1:2.5
+BuildRequires: python-numpy-devel >= 1:1.0.0
+BuildRequires: rpm-pythonprov
 %{?with_ruby:BuildRequires:    ruby-devel}
 BuildRequires: sqlite3-devel >= 3
+BuildRequires: swig-perl
+BuildRequires: swig-python >= 1.3
 %{?with_ruby:BuildRequires:    swig-ruby}
+%if "%{pld_release}" == "ti"
+BuildRequires: tetex-format-latex
+BuildRequires: tetex-dvips
+%else
+BuildRequires: texlive-dvips
+BuildRequires: texlive-latex
+%endif
 %{?with_odbc:BuildRequires:    unixODBC-devel}
 %{?with_xerces:BuildRequires:  xerces-c-devel >= 2.2.0}
 BuildRequires: zlib-devel >= 1.1.4
@@ -73,9 +90,11 @@ Summary(pl.UTF-8):   Pliki nagłówkowe biblioteki GDAL
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 Requires:      cfitsio-devel
+Requires:      expat-devel >= 1.95.0
 Requires:      geos-devel >= 2.0
 Requires:      giflib-devel
 Requires:      hdf-devel >= 4.0
+Requires:      hdf5-devel
 Requires:      jasper-devel
 Requires:      libcsf-devel
 Requires:      libdap-devel >= 3.5
@@ -89,7 +108,7 @@ Requires:    ogdi-devel >= 3.1
 Requires:      postgresql-devel
 Requires:      sqlite3-devel >= 3
 %{?with_odbc:Requires: unixODBC-devel}
-%{?with_xerces:Requires:       xerces-c-devel >= 2.2.0}
+%{?with_xerces:Requires:       xerces-c-devel >= 2.7.0}
 
 %description devel
 GDAL library header files.
@@ -119,8 +138,7 @@ Requires:   %{name} = %{version}-%{release}
 Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
 
 %description -n perl-gdal -l pl.UTF-8
-Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR,
-Geo::OSR.
+Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
 
 %package -n python-gdal
 Summary:       GDAL Python module
@@ -146,52 +164,84 @@ Requires: %{name} = %{version}-%{release}
 Ruby bindings for GDAL - gdal, gdalconst, ogr and osr modules.
 
 %description -n ruby-gdal -l pl.UTF-8
-Wiązania języka Ruby do pakietu GDAL - moduły gdal, gdalconst, ogr
-osr.
+Wiązania języka Ruby do pakietu GDAL - moduły gdal, gdalconst, ogr i
+osr.
 
 %prep
 %setup -q
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
+%patch4 -p1
+%patch5 -p1
+
+# need to regenerate (old ones don't support perl 5.10)
+rm swig/perl/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
 
 %build
-# disable grass/libgrass here, it can be built from separate gdal-grass package
+# $PYTHON_INCLUDES is set only with --with-ogpython, but we have --with-python,
+# and $PYTHON_INCLUDES is needed to detect numpy properly
+export PYTHON_INCLUDES=-I%{py_incdir}
+
+%{__libtoolize}
+cp -f /usr/share/automake/config.* .
+%{__aclocal} -I m4
 %{__autoconf}
+# disable grass/libgrass here, it can be built from separate gdal-grass package
 %configure \
        --datadir=%{_datadir}/gdal \
        --with-dods-root=/usr \
+       --with-hide-internal-symbols \
        --with-perl \
-       --with-pymoddir=%{py_sitedir} \
+       --with-python \
        %{?with_ruby:--with-ruby} \
-       --with-sqlite \
+       --with-sqlite3 \
        %{?with_xerces:--with-xerces} \
        --with-xerces-inc=/usr/include/xercesc \
        --with-xerces-lib="-lxerces-c" \
        --without-grass \
-       --without-libgrass \
-       --with-ngpython
-# ngpython seems to be compatibile with old python bindings
+       --without-libgrass
 # --with-php needs Zend API update
-%{__make}
+# java broken, no configure option
+# csharp builds, but has no configure option
 
-%{__make} -C swig build \
-       OPTIMIZE="%{rpmcflags}"
+# regenerate where needed
+%{__make} -j1 -C swig/perl generate
 
-%{__make} docs
+%{__make} -j1
+
+%{__make} -j1 docs
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install \
+%{__make} -j1 install install-man \
        DESTDIR=$RPM_BUILD_ROOT
 
-mv -f ogr/html html/org
+rm -rf _html
+cp -a html _html
+cp -a ogr/html _html/ogr
 
 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
 %py_postclean
-rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{la,a}
+
+%{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
+%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
+%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
+%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
+%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
+
+# some doxygen trash
+%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/GDAL.dox
+%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/GDAL/Const.dox
+%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/OGR.dox
+%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/OSR.dox
+
+%if %{with ruby}
+%{__rm} $RPM_BUILD_ROOT%{ruby_sitearchdir}/gdal/*.la
+%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -205,13 +255,14 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/*
 %exclude %{_bindir}/gdal-config
 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libgdal.so.1
 %{_datadir}/gdal
 %{_mandir}/man1/*
 %exclude %{_mandir}/man1/gdal-config.1*
 
 %files devel
 %defattr(644,root,root,755)
-%doc html/*
+%doc _html/*
 %attr(755,root,root) %{_bindir}/gdal-config
 %attr(755,root,root) %{_libdir}/libgdal.so
 %{_libdir}/libgdal.la
@@ -246,9 +297,19 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n python-gdal
 %defattr(644,root,root,755)
-%attr(755,root,root) %{py_sitedir}/*.so
-%{py_sitedir}/*.py[co]
-%{py_sitedir}/*.egg-info
+%{py_sitedir}/gdal.py[co]
+%{py_sitedir}/gdalconst.py[co]
+%{py_sitedir}/gdalnumeric.py[co]
+%{py_sitedir}/ogr.py[co]
+%{py_sitedir}/osr.py[co]
+%{py_sitedir}/GDAL-*.egg-info
+%dir %{py_sitedir}/osgeo
+%attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
+%attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
+%attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
+%attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
+%attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
+%{py_sitedir}/osgeo/*.py[co]
 
 %if %{with ruby}
 %files -n ruby-gdal
This page took 0.03222 seconds and 4 git commands to generate.