]> git.pld-linux.org Git - packages/gdal.git/blobdiff - gdal.spec
add rpc patch from fedora
[packages/gdal.git] / gdal.spec
index a307a58e620a3615b996e69a0728982db8c787dd..8d365f000e56f508261d28cfc9ce4e1e46d0fedc 100644 (file)
--- a/gdal.spec
+++ b/gdal.spec
@@ -39,7 +39,7 @@
 %bcond_with    podofo          # PDF support via podofo instead of poppler
 %bcond_without poppler         # PDF support via poppler
 %bcond_with    rasdaman        # Rasdaman support
-%bcond_without spatialite      # SpatiaLite support
+%bcond_with    spatialite      # SpatiaLite support
 %bcond_without xerces          # Xerces support
 %bcond_without java            # Java and MDB support
 
 Summary:       Geospatial Data Abstraction Library
 Summary(pl.UTF-8):     Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
 Name:          gdal
-Version:       2.4.0
+Version:       3.0.4
 Release:       2
 License:       BSD-like
 Group:         Libraries
-Source0:       http://download.osgeo.org/gdal/%{version}/%{name}-%{version}.tar.xz
-# Source0-md5: 794096364a50df4bc7c5b710d997b6b4
+Source0:       https://github.com/OSGeo/gdal/releases/download/v%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: c6bbb5caca06e96bd97a32918e0aa9aa
 Patch0:                %{name}-perl.patch
-Patch1:                %{name}-poppler.patch
-Patch2:                %{name}-pc.patch
-Patch9:                %{name}-dds.patch
-Patch12:       %{name}-rasdaman.patch
-Patch13:       %{name}-pluginsdir.patch
-Patch15:       libx32.patch
+Patch1:                %{name}-pc.patch
+Patch2:                %{name}-dds.patch
+Patch3:                %{name}-rasdaman.patch
+Patch4:                %{name}-pluginsdir.patch
+Patch5:                libx32.patch
+Patch7:                decl.patch
+Patch8:                %{name}_tirpcinc.patch
 URL:           http://www.gdal.org/
 # 1.x or 2.x supported
 BuildRequires: CharLS-devel
@@ -99,6 +100,7 @@ BuildRequires:       libpng-devel >= 2:1.2.8
 %{?with_spatialite:BuildRequires:      libspatialite-devel}
 BuildRequires: libstdc++-devel
 BuildRequires: libtiff-devel >= 4.0
+BuildRequires: libtirpc-devel
 BuildRequires: libtool
 BuildRequires: libuuid-devel
 BuildRequires: libwebp-devel
@@ -268,10 +270,11 @@ Moduł Pythona GDAL.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%patch9 -p1
-%patch12 -p1
-%patch13 -p1
-%patch15 -p1
+%patch3 -p1
+%patch4 -p1
+%patch5 -p1
+%patch7 -p1
+%patch8 -p1
 
 # need to regenerate (old ones don't support perl 5.10)
 %{__rm} swig/perl/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
@@ -283,6 +286,35 @@ sed -i -e 's#^mandir=.*##g' configure.ac
 
 %{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.ac
 
+sed -E -i -e '1s,#!\s*/usr/bin/env\s+python2(\s|$),#!%{__python}\1,' \
+         -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python}\1,' \
+         -e '1s,#!\s*/usr/bin/python(\s|$),#!%{__python}\1,' \
+      swig/python/scripts/epsg_tr.py \
+      swig/python/scripts/esri2wkt.py \
+      swig/python/scripts/gcps2vec.py \
+      swig/python/scripts/gcps2wld.py \
+      swig/python/scripts/gdal2tiles.py \
+      swig/python/scripts/gdal2xyz.py \
+      swig/python/scripts/gdal_auth.py \
+      swig/python/scripts/gdal_calc.py \
+      swig/python/scripts/gdal_edit.py \
+      swig/python/scripts/gdal_fillnodata.py \
+      swig/python/scripts/gdal_merge.py \
+      swig/python/scripts/gdal_pansharpen.py \
+      swig/python/scripts/gdal_polygonize.py \
+      swig/python/scripts/gdal_proximity.py \
+      swig/python/scripts/gdal_retile.py \
+      swig/python/scripts/gdal_sieve.py \
+      swig/python/scripts/gdalchksum.py \
+      swig/python/scripts/gdalcompare.py \
+      swig/python/scripts/gdalident.py \
+      swig/python/scripts/gdalimport.py \
+      swig/python/scripts/gdalmove.py \
+      swig/python/scripts/mkgraticule.py \
+      swig/python/scripts/ogrmerge.py \
+      swig/python/scripts/pct2rgb.py \
+      swig/python/scripts/rgb2pct.py
+
 %build
 %ifarch %{x8664}
 jvm_arch=amd64
@@ -334,7 +366,7 @@ jvm_arch=x32
 # regenerate where needed
 %{__make} -j1 -C swig/perl generate
 
-%{__make} -j1 \
+%{__make} \
        %{?with_grass:GRASS_INCLUDE="-I/usr/include/grass64"} \
        %{?with_fyba:SOSI_INC="-I/usr/include/fyba"}
 
@@ -422,7 +454,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/rgb2pct.py
 %attr(755,root,root) %{_bindir}/testepsg
 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libgdal.so.20
+%attr(755,root,root) %ghost %{_libdir}/libgdal.so.26
 %dir %{_libdir}/gdalplugins
 %{_datadir}/gdal
 %{_mandir}/man1/gdal2tiles.1*
This page took 0.053363 seconds and 4 git commands to generate.