]> git.pld-linux.org Git - packages/gdal.git/blobdiff - gdal.spec
- make install re-entrant; typo (ogr not org)
[packages/gdal.git] / gdal.spec
index 840448a2545cd2864e34ef893008348e7ef9a6fd..618995919ae2ba20eb55b5a69cb28ede5ab6a696 100644 (file)
--- a/gdal.spec
+++ b/gdal.spec
@@ -1,20 +1,22 @@
+# TODO: fix LDFLAGS passing (to use as-needed)
 #
 # Conditional build:
 %bcond_without odbc    # disable odbc support
 %bcond_without xerces  # disable xerces support
+%bcond_without ruby    # disable ruby support
 #
 Summary:       Geospatial Data Abstraction Library
 Summary(pl.UTF-8):     Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
 Name:          gdal
-Version:       1.4.1
-Release:       0.1
+Version:       1.4.3
+Release:       1
 License:       BSD-like
 Group:         Libraries
-#Source0:      http://download.osgeo.org/gdal/%{name}-%{version}.tar.gz
-Source0:       ftp://ftp.gdal.org/gdal/%{name}-%{version}.tar.gz
-# Source0-md5: 688cf651c6f6efc2851b12f2e9c2e0d1
+Source0:       ftp://ftp.remotesensing.org/gdal/%{name}-%{version}.tar.gz
+# Source0-md5: d2b0d428edab7895aa53c7d827094a09
 Patch0:                %{name}-dods.patch
-Patch1:                %{name}-ac.patch
+Patch1:                %{name}-perl.patch
+Patch2:                %{name}-ruby.patch
 URL:           http://www.gdal.org/
 BuildRequires: autoconf
 BuildRequires: cfitsio-devel
@@ -32,10 +34,15 @@ BuildRequires:      libstdc++-devel
 BuildRequires: libtiff-devel >= 3.6.0
 BuildRequires: netcdf-devel
 BuildRequires: ogdi-devel >= 3.1
+BuildRequires: perl-devel
 BuildRequires: postgresql-devel
 BuildRequires: postgresql-backend-devel
-BuildRequires: python-devel
+BuildRequires: python-numpy-devel >= 1.0.0
+BuildRequires: python-devel >= 1:2.5
+%{?with_ruby:BuildRequires:    ruby-devel}
 BuildRequires: sqlite3-devel >= 3
+%{?with_ruby:BuildRequires:    swig-ruby}
+BuildRequires: swig-python >= 1.3
 %{?with_odbc:BuildRequires:    unixODBC-devel}
 %{?with_xerces:BuildRequires:  xerces-c-devel >= 2.2.0}
 BuildRequires: zlib-devel >= 1.1.4
@@ -103,6 +110,19 @@ GDAL static libraries.
 %description static -l pl.UTF-8
 Statyczne biblioteki GDAL.
 
+%package -n perl-gdal
+Summary:       Perl bindings for GDAL
+Summary(pl.UTF-8):     Wiązania Perla do pakietu GDAL
+Group:         Development/Languages/Perl
+Requires:      %{name} = %{version}-%{release}
+
+%description -n perl-gdal
+Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
+
+%description -n perl-gdal -l pl.UTF-8
+Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR,
+Geo::OSR.
+
 %package -n python-gdal
 Summary:       GDAL Python module
 Summary(pl.UTF-8):     Moduł Pythona GDAL
@@ -116,10 +136,25 @@ GDAL Python module.
 %description -n python-gdal -l pl.UTF-8
 Moduł Pythona GDAL.
 
+%package -n ruby-gdal
+Summary:       Ruby bindings for GDAL
+Summary(pl.UTF-8):     Wiązania języka Ruby do pakietu GDAL
+Group:         Development/Languages
+Requires:      %{name} = %{version}-%{release}
+%{?ruby_mod_ver_requires_eq}
+
+%description -n ruby-gdal
+Ruby bindings for GDAL - gdal, gdalconst, ogr and osr modules.
+
+%description -n ruby-gdal -l pl.UTF-8
+Wiązania języka Ruby do pakietu GDAL - moduły gdal, gdalconst, ogr
+i osr.
+
 %prep
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %build
 # disable grass/libgrass here, it can be built from separate gdal-grass package
@@ -127,16 +162,23 @@ Moduł Pythona GDAL.
 %configure \
        --datadir=%{_datadir}/gdal \
        --with-dods-root=/usr \
+       --with-perl \
        --with-pymoddir=%{py_sitedir} \
+       %{?with_ruby:--with-ruby} \
        --with-sqlite \
        %{?with_xerces:--with-xerces} \
        --with-xerces-inc=/usr/include/xercesc \
        --with-xerces-lib="-lxerces-c" \
        --without-grass \
-       --without-libgrass
-
+       --without-libgrass \
+       --with-ngpython
+# ngpython seems to be compatibile with old python bindings
+# --with-php needs Zend API update
 %{__make}
 
+%{__make} -C swig build \
+       OPTIMIZE="%{rpmcflags}"
+
 %{__make} docs
 
 %install
@@ -145,7 +187,9 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-mv -f ogr/html html/org
+rm -rf _html
+cp -a html _html
+cp -a ogr/html _html/ogr
 
 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
@@ -170,7 +214,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files devel
 %defattr(644,root,root,755)
-%doc html/*
+%doc _html/*
 %attr(755,root,root) %{_bindir}/gdal-config
 %attr(755,root,root) %{_libdir}/libgdal.so
 %{_libdir}/libgdal.la
@@ -181,7 +225,49 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_libdir}/libgdal.a
 
+%files -n perl-gdal
+%defattr(644,root,root,755)
+%dir %{perl_vendorarch}/Geo
+%{perl_vendorarch}/Geo/GDAL.pm
+%dir %{perl_vendorarch}/Geo/GDAL
+%{perl_vendorarch}/Geo/GDAL/Const.pm
+%{perl_vendorarch}/Geo/OGR.pm
+%{perl_vendorarch}/Geo/OSR.pm
+%dir %{perl_vendorarch}/auto/Geo
+%dir %{perl_vendorarch}/auto/Geo/GDAL
+%{perl_vendorarch}/auto/Geo/GDAL/GDAL.bs
+%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
+%dir %{perl_vendorarch}/auto/Geo/GDAL/Const
+%{perl_vendorarch}/auto/Geo/GDAL/Const/Const.bs
+%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
+%dir %{perl_vendorarch}/auto/Geo/OGR
+%{perl_vendorarch}/auto/Geo/OGR/OGR.bs
+%attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
+%dir %{perl_vendorarch}/auto/Geo/OSR
+%{perl_vendorarch}/auto/Geo/OSR/OSR.bs
+%attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
+
 %files -n python-gdal
 %defattr(644,root,root,755)
-%attr(755,root,root) %{py_sitedir}/_gdalmodule.so
-%{py_sitedir}/*.py[co]
+%attr(755,root,root) %{py_sitedir}/_gdal.so
+%attr(755,root,root) %{py_sitedir}/_gdalconst.so
+%attr(755,root,root) %{py_sitedir}/_gdal_array.so
+%attr(755,root,root) %{py_sitedir}/_ogr.so
+%attr(755,root,root) %{py_sitedir}/_osr.so
+%{py_sitedir}/gdal.py[co]
+%{py_sitedir}/gdalconst.py[co]
+%{py_sitedir}/gdalnumeric.py[co]
+%{py_sitedir}/gdal_array.py[co]
+%{py_sitedir}/ogr.py[co]
+%{py_sitedir}/osr.py[co]
+%{py_sitedir}/Gdal_Wrapper-*.egg-info
+
+%if %{with ruby}
+%files -n ruby-gdal
+%defattr(644,root,root,755)
+%dir %{ruby_sitearchdir}/gdal
+%attr(755,root,root) %{ruby_sitearchdir}/gdal/gdal.so
+%attr(755,root,root) %{ruby_sitearchdir}/gdal/gdalconst.so
+%attr(755,root,root) %{ruby_sitearchdir}/gdal/ogr.so
+%attr(755,root,root) %{ruby_sitearchdir}/gdal/osr.so
+%endif
This page took 0.573424 seconds and 4 git commands to generate.