]> git.pld-linux.org Git - packages/gdal.git/blobdiff - gdal.spec
- updated patches, removed obsolete
[packages/gdal.git] / gdal.spec
index df35a492f158979393baf5e868916548a6fa6c9b..4daa99f550083d77c90ee0a45ee487afb2f09b1e 100644 (file)
--- a/gdal.spec
+++ b/gdal.spec
@@ -25,6 +25,7 @@
 %bcond_without fyba            # SOSI geodata support using FYBA
 %bcond_with    grass           # GRASS support (note: dependency loop; use gdal-grass.spec instead)
 %bcond_without gta             # GTA format support
+%bcond_without kea             # KEA format support
 %bcond_without mysql           # MySQL DB support
 %bcond_with    oci             # ORACLE OCI DB and Georaster support
 %bcond_without odbc            # ODBC DB support
@@ -36,8 +37,8 @@
 %bcond_without spatialite      # SpatiaLite support
 %bcond_without xerces          # Xerces support
 %bcond_without java            # Java and MDB support
-%bcond_without php             # PHP binding
-%bcond_with    ruby            # Ruby binding
+%bcond_with    php             # PHP binding [PHP 7 not supported by swig 3.0.x]
+%bcond_with    ruby            # Ruby binding [not available as of 2.0.2]
 
 %if %{with podofo}
 %undefine      with_poppler
 Summary:       Geospatial Data Abstraction Library
 Summary(pl.UTF-8):     Biblioteka abstrakcji danych dotyczÄ…cych powierzchni Ziemi
 Name:          gdal
-Version:       2.0.1
-Release:       4
+Version:       2.2.4
+Release:       0.1
 License:       BSD-like
 Group:         Libraries
 Source0:       http://download.osgeo.org/gdal/%{version}/%{name}-%{version}.tar.xz
-# Source0-md5: 27022cc4a3e0819ab02a69c2d0867437
+# Source0-md5: 51b1df61dbdf81473689fab3075e7a5e
 Patch0:                %{name}-perl.patch
-Patch1:                %{name}-python_install.patch
 Patch2:                %{name}-php.patch
 Patch3:                %{name}-fpic.patch
-Patch5:                %{name}-grass.patch
-Patch7:                %{name}-link.patch
-Patch8:                %{name}-fyba.patch
 Patch9:                %{name}-dds.patch
 Patch11:       %{name}-armadillo.patch
 Patch12:       %{name}-rasdaman.patch
 Patch13:       %{name}-pluginsdir.patch
+Patch15:       libx32.patch
 URL:           http://www.gdal.org/
 %{?with_php:BuildRequires:     %{php_name}-devel}
 %{?with_opencl:BuildRequires:  OpenCL-devel >= 1.0}
@@ -89,6 +87,7 @@ BuildRequires:        jasper-devel
 %{?with_java:BuildRequires:    jdk}
 %{?with_java:BuildRequires:    jpackage-utils}
 BuildRequires: json-c-devel >= 0.11
+%{?with_kea:BuildRequires:     kealib-devel}
 BuildRequires: libcsf-devel >= 2.0-0.041111.6
 BuildRequires: libdap-devel >= 3.10
 BuildRequires: libgeotiff-devel >= 1.2.1
@@ -103,7 +102,7 @@ BuildRequires:      libtool
 BuildRequires: libuuid-devel
 BuildRequires: libwebp-devel
 BuildRequires: libxml2-devel >= 2
-%{?with_mysql:BuildRequires:   mysql-devel}
+%{?with_mysql:BuildRequires:   /usr/bin/mysql_config}
 BuildRequires: netcdf-devel >= 4.1
 BuildRequires: ogdi-devel >= 3.1
 %{?with_openjpeg:BuildRequires:        openjpeg2-devel >= 2.0.0-2}
@@ -180,6 +179,7 @@ Requires:   hdf-devel >= 4.0
 Requires:      hdf5-devel
 Requires:      jasper-devel
 Requires:      json-c-devel >= 0.11
+%{?with_kea:Requires:  kealib-devel}
 Requires:      libcsf-devel
 Requires:      libdap-devel >= 3.10
 Requires:      libgeotiff-devel >= 1.2.1
@@ -192,7 +192,7 @@ Requires:   libtiff-devel >= 4.0
 Requires:      libuuid-devel
 Requires:      libwebp-devel
 Requires:      libxml2-devel >= 2
-%{?with_mysql:Requires:        mysql-devel}
+%{?with_mysql:Requires:        /usr/bin/mysql_config}
 Requires:      netcdf-devel >= 4
 Requires:      ogdi-devel >= 3.1
 %{?with_openjpeg:Requires:     openjpeg2-devel >= 2.0.0-2}
@@ -280,16 +280,13 @@ osr.
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
 %patch2 -p1
 %patch3 -p1
-%patch5 -p1
-%patch7 -p1
-%patch8 -p1
 %patch9 -p1
 %patch11 -p1
 %patch12 -p1
-%patch13 -p1
+#%patch13 -p1
+%patch15 -p1
 
 # need to regenerate (old ones don't support perl 5.10 or php 5.5)
 %{__rm} swig/{perl,php}/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
@@ -312,11 +309,11 @@ sed -i -e 's|^$(INSTALL_DIR):|$(DESTDIR)$(INSTALL_DIR):|' swig/ruby/RubyMakefile
 sed -i -e 's|^install: $(INSTALL_DIR)|install: $(DESTDIR)$(INSTALL_DIR)|' swig/ruby/RubyMakefile.mk
 
 # our man path
-sed -i -e 's#^mandir=.*##g' configure.in
+sed -i -e 's#^mandir=.*##g' configure.ac
 
 %{__rm} -r man
 
-%{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.in
+%{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.ac
 
 %build
 %ifarch %{x8664}
@@ -338,13 +335,14 @@ jvm_arch=x32
        --datadir=%{_datadir}/gdal \
        --with-dods-root=/usr \
        %{?with_armadillo:--with-armadillo} \
-       %{?with_crnlib:--with-dds} \
+       %{?with_crnlib:--with-dds=/usr} \
        %{?with_epsilon:--with-epsilon} \
        %{?with_grass:--with-grass} \
        %{!?with_gta:--without-gta} \
        --with-hide-internal-symbols \
        %{?with_java:--with-java=%{java_home}} \
        --with-liblzma \
+       %{!?with_kea:--without-kea} \
        %{?with_java:--with-mdb --with-jvm-lib-add-rpath --with-jvm-lib=%{java_home}/jre/lib/$jvm_arch/server} \
        %{?with_mysql:--with-mysql} \
        %{?with_oci:--with-oci --with-oci-include=/usr/include/oracle/client --with-oci-lib=%{_libdir}} \
@@ -363,7 +361,6 @@ jvm_arch=x32
        %{?with_xerces:--with-xerces} \
        --with-xerces-inc=/usr/include/xercesc \
        --with-xerces-lib="-lxerces-c" \
-       --with-autoload=%{_libdir}/gdalplugins \
        --without-libgrass
 #      --with-pcidsk=/usr (needs > 0.3)
 # csharp builds, but has no configure option nor install target
This page took 0.379576 seconds and 4 git commands to generate.