]> git.pld-linux.org Git - packages/gdal.git/blobdiff - gdal.spec
- ver. 1.4.1
[packages/gdal.git] / gdal.spec
index ac4c26f3e52c9ffeb99bf10f106ea6e143c5c185..38903930ce132b83c869726eb28751a56404fc34 100644 (file)
--- a/gdal.spec
+++ b/gdal.spec
@@ -1,17 +1,20 @@
+#
+# Conditional build:
+%bcond_without odbc    # disable odbc support
+%bcond_without xerces  # disable xerces support
+#
 Summary:       Geospatial Data Abstraction Library
-Summary(pl):   Biblioteka abstrakcji danych dotycz±cych powierzchni Ziemi
+Summary(pl.UTF-8):     Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
 Name:          gdal
-Version:       1.3.2
-Release:       1
+Version:       1.4.1
+Release:       0.1
 License:       BSD-like
 Group:         Libraries
-Source0:       ftp://ftp.remotesensing.org/pub/gdal/%{name}-%{version}.tar.gz
-# Source0-md5: 67ed02dcea21e93f5e123bb0d322898a
-Patch0:                %{name}-pgsql.patch
-Patch1:                %{name}-DESTDIR.patch
-Patch2:                %{name}-dods.patch
-Patch3:                %{name}-gcc4.patch
-URL:           http://www.remotesensing.org/gdal/
+Source0:       ftp://ftp.gdal.org/gdal/%{name}-%{version}.tar.gz
+# Source0-md5: 688cf651c6f6efc2851b12f2e9c2e0d1
+Patch0:                %{name}-dods.patch
+Patch1:                %{name}-ac.patch
+URL:           http://www.gdal.org/
 BuildRequires: autoconf
 BuildRequires: cfitsio-devel
 BuildRequires: doxygen
@@ -32,8 +35,8 @@ BuildRequires:        postgresql-devel
 BuildRequires: postgresql-backend-devel
 BuildRequires: python-devel
 BuildRequires: sqlite3-devel >= 3
-BuildRequires: unixODBC-devel
-BuildRequires: xerces-c-devel >= 2.2.0
+%{?with_odbc:BuildRequires:    unixODBC-devel}
+%{?with_xerces:BuildRequires:  xerces-c-devel >= 2.2.0}
 BuildRequires: zlib-devel >= 1.1.4
 Requires:      geos >= 2.0
 Requires:      libgeotiff >= 1.2.1
@@ -49,17 +52,17 @@ supported formats. The related OGR library (which lives within the
 GDAL source tree) provides a similar capability for simple features
 vector data.
 
-%description -l pl
-GDAL to biblioteka konwertuj±ca miêdzy formatami rastrowych danych
-dotycz±cych powierzchni Ziemi, udostêpniona na licencji Open Source.
-Jako biblioteka udostêpnia aplikacjom jeden abstrakcyjny model danych
-do wszystkich obs³ugiwanych formatów. Powi±zana z ni± biblioteka OGR
-(której ¼ród³a s± do³±czone do drzewa ¼róde³ GDAL) daje podobne
-mo¿liwo¶ci dla danych wektorowych.
+%description -l pl.UTF-8
+GDAL to biblioteka konwertująca między formatami rastrowych danych
+dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
+Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
+do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
+(której źródła są dołączone do drzewa źródeł GDAL) daje podobne
+możliwości dla danych wektorowych.
 
 %package devel
 Summary:       GDAL library header files
-Summary(pl):   Pliki nag³ówkowe biblioteki GDAL
+Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki GDAL
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 Requires:      cfitsio-devel
@@ -78,30 +81,30 @@ Requires:   netcdf-devel
 Requires:      ogdi-devel >= 3.1
 Requires:      postgresql-devel
 Requires:      sqlite3-devel >= 3
-Requires:      unixODBC-devel
-Requires:      xerces-c-devel >= 2.2.0
+%{?with_odbc:Requires: unixODBC-devel}
+%{?with_xerces:Requires:       xerces-c-devel >= 2.2.0}
 
 %description devel
 GDAL library header files.
 
-%description devel -l pl
-Pliki nag³ówkowe biblioteki GDAL.
+%description devel -l pl.UTF-8
+Pliki nagłówkowe biblioteki GDAL.
 
 %package static
 Summary:       GDAL static libraries
-Summary(pl):   Statyczne biblioteki GDAL
+Summary(pl.UTF-8):     Statyczne biblioteki GDAL
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 GDAL static libraries.
 
-%description static -l pl
+%description static -l pl.UTF-8
 Statyczne biblioteki GDAL.
 
 %package -n python-gdal
 Summary:       GDAL Python module
-Summary(pl):   Modu³ Pythona GDAL
+Summary(pl.UTF-8):     Moduł Pythona GDAL
 Group:         Libraries/Python
 Requires:      %{name} = %{version}-%{release}
 %pyrequires_eq python-libs
@@ -109,17 +112,13 @@ Requires: %{name} = %{version}-%{release}
 %description -n python-gdal
 GDAL Python module.
 
-%description -n python-gdal -l pl
-Modu³ Pythona GDAL.
+%description -n python-gdal -l pl.UTF-8
+Moduł Pythona GDAL.
 
 %prep
 %setup -q
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
-%patch3 -p1
-
-%{__perl} -pi -e "s/PYLIB=lib/PYLIB=%{_lib}/" aclocal.m4
 
 %build
 # disable grass/libgrass here, it can be built from separate gdal-grass package
@@ -129,7 +128,7 @@ Modu
        --with-dods-root=/usr \
        --with-pymoddir=%{py_sitedir} \
        --with-sqlite \
-       --with-xerces \
+       %{?with_xerces:--with-xerces} \
        --with-xerces-inc=/usr/include/xercesc \
        --with-xerces-lib="-lxerces-c" \
        --without-grass \
@@ -147,6 +146,9 @@ rm -rf $RPM_BUILD_ROOT
 
 mv -f ogr/html html/org
 
+%py_comp $RPM_BUILD_ROOT%{py_sitedir}
+%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
+%py_postclean
 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{la,a}
 
 %clean
@@ -176,9 +178,9 @@ rm -rf $RPM_BUILD_ROOT
 
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/*.a
+%{_libdir}/libgdal.a
 
 %files -n python-gdal
 %defattr(644,root,root,755)
 %attr(755,root,root) %{py_sitedir}/_gdalmodule.so
-%{py_sitedir}/*.py
+%{py_sitedir}/*.py[co]
This page took 0.059522 seconds and 4 git commands to generate.