]> git.pld-linux.org Git - packages/gdal.git/blobdiff - gdal.spec
- release 14 (by relup.sh)
[packages/gdal.git] / gdal.spec
index ff0b8f393d496a15ed91bf7750cd26a8e0fae6b3..10e349823b65aa7b16c5dc84ecd856f54c121dfe 100644 (file)
--- a/gdal.spec
+++ b/gdal.spec
@@ -3,7 +3,6 @@
 #   use gdal (probably a gdal module or driver shall not imply devel
 #   dependency)
 # - rasdaman (--with-rasdaman; http://rasdaman.eecs.jacobs-university.de/trac/rasdaman/wiki/Download)
-# - openjpeg (unreleased post-1.5 or 2? needs opj_decode_tile_data symbol, not available in 1.3-1.5)
 # - libjpeg12 (needs patching to use system one, --with-jpeg12 is not sufficient as of 1.9.2)
 # - libkml (1.3.0 needed, not released yet)
 # - wait for newer pcidsk, switch to external again
 %bcond_without mysql           # MySQL DB support
 %bcond_without odbc            # ODBC DB support
 %bcond_without opencl          # OpenCL (GPU) support
+%bcond_without openjpeg        # OpenJPEG 2 (JPEG2000) support
 %bcond_with    podofo          # PDF support via podofo instead of poppler
 %bcond_without poppler         # PDF support via poppler
 %bcond_without spatialite      # SpatiaLite support
 %bcond_without xerces          # Xerces support
 %bcond_without java            # Java and MDB support
 %bcond_without php             # PHP binding
-%bcond_without ruby            # ruby binding
-#
+%bcond_without ruby            # Ruby binding
+
 %if %{with podofo}
 %undefine      with_poppler
 %endif
@@ -43,7 +43,7 @@ Summary:      Geospatial Data Abstraction Library
 Summary(pl.UTF-8):     Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
 Name:          gdal
 Version:       1.9.2
-Release:       6
+Release:       14
 License:       BSD-like
 Group:         Libraries
 Source0:       ftp://ftp.remotesensing.org/gdal/%{name}-%{version}.tar.gz
@@ -53,6 +53,9 @@ Patch1:               %{name}-python_install.patch
 Patch2:                %{name}-php.patch
 Patch3:                %{name}-fpic.patch
 Patch4:                %{name}-format-security.patch
+Patch5:                %{name}-openjpeg2.patch
+Patch6:                %{name}-hdf4-eos.patch
+Patch7:                %{name}-poppler.patch
 URL:           http://www.gdal.org/
 %{?with_opencl:BuildRequires:  OpenCL-devel >= 1.0}
 %{?with_armadillo:BuildRequires:       armadillo-devel}
@@ -88,11 +91,12 @@ BuildRequires:      libxml2-devel
 %{?with_mysql:BuildRequires:   mysql-devel}
 BuildRequires: netcdf-devel >= 4.1
 BuildRequires: ogdi-devel >= 3.1
+%{?with_openjpeg:BuildRequires:        openjpeg2-devel >= 2.0.0-2}
 #BuildRequires:        pcidsk-devel > 0.3
 BuildRequires: perl-devel
 %{?with_php:BuildRequires:     php-devel}
 %{?with_podofo:BuildRequires:  podofo-devel}
-%{?with_poppler:BuildRequires: poppler-devel}
+%{?with_poppler:BuildRequires: poppler-devel >= 0.24}
 # ensure it's compiled with PQescapeStringConn support
 BuildRequires: postgresql-backend-devel >= 8.1.4
 BuildRequires: postgresql-devel >= 8.1.4
@@ -101,6 +105,7 @@ BuildRequires:      python-devel >= 1:2.5
 BuildRequires: python-numpy-devel >= 1:1.0.0
 BuildRequires: python-setuptools
 BuildRequires: rpm-pythonprov
+%{?with_ruby:BuildRequires:    rpm-rubyprov}
 BuildRequires: rpmbuild(macros) >= 1.344
 %{?with_ruby:BuildRequires:    ruby-devel}
 BuildRequires: sed >= 4.0
@@ -169,9 +174,10 @@ Requires:  libxml2-devel
 %{?with_mysql:Requires:        mysql-devel}
 Requires:      netcdf-devel >= 4
 Requires:      ogdi-devel >= 3.1
+%{?with_openjpeg:Requires:     openjpeg2-devel >= 2.0.0-2}
 #Requires:     pcidsk-devel > 0.3
 %{?with_podofo:Requires:       podofo-devel}
-%{?with_poppler:Requires:      poppler-devel}
+%{?with_poppler:Requires:      poppler-devel >= 0.24}
 Requires:      postgresql-devel
 Requires:      proj-devel >= 4
 Requires:      sqlite3-devel >= 3.0.0
@@ -228,7 +234,7 @@ Summary:    GDAL Python module
 Summary(pl.UTF-8):     Moduł Pythona GDAL
 Group:         Libraries/Python
 Requires:      %{name} = %{version}-%{release}
-%pyrequires_eq python-libs
+Requires:      python-libs
 
 %description -n python-gdal
 GDAL Python module.
@@ -241,7 +247,6 @@ Summary:    Ruby bindings for GDAL
 Summary(pl.UTF-8):     Wiązania języka Ruby do pakietu GDAL
 Group:         Development/Languages
 Requires:      %{name} = %{version}-%{release}
-%{?ruby_mod_ver_requires_eq}
 
 %description -n ruby-gdal
 Ruby bindings for GDAL - gdal, gdalconst, ogr and osr modules.
@@ -256,10 +261,25 @@ osr.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
+%patch5 -p1
+%patch6 -p1
+%patch7 -p1
 
 # need to regenerate (old ones don't support perl 5.10)
 %{__rm} swig/perl/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
 
+# Build with fPIC to allow Ruby bindings
+# Xcompiler should normally achieve that -- http://trac.osgeo.org/gdal/ticket/3978
+# http://trac.osgeo.org/gdal/ticket/1994
+sed -i 's|\$(CFLAGS)|$(CFLAGS) -fPIC|g' swig/ruby/RubyMakefile.mk
+# Install Ruby bindings to distribution specific directory
+sed -i 's|RUBY_EXTENSIONS_DIR :=.*|RUBY_EXTENSIONS_DIR := %{ruby_vendorarchdir}|' swig/ruby/RubyMakefile.mk
+
+# Install Ruby bindings into the proper place
+sed -i -e 's|^$(INSTALL_DIR):|$(DESTDIR)$(INSTALL_DIR):|' swig/ruby/RubyMakefile.mk
+sed -i -e 's|^install: $(INSTALL_DIR)|install: $(DESTDIR)$(INSTALL_DIR)|' swig/ruby/RubyMakefile.mk
+
 %{__rm} -r man
 
 %{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.in
@@ -303,7 +323,6 @@ osr.
 %{__make} -j1 -C swig/perl generate
 %if %{with ruby}
 %{__make} -j1 -C swig/ruby generate
-%patch4 -p1
 %endif
 
 %{__make} -j1
@@ -504,9 +523,9 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with ruby}
 %files -n ruby-gdal
 %defattr(644,root,root,755)
-%dir %{ruby_sitearchdir}/gdal
-%attr(755,root,root) %{ruby_sitearchdir}/gdal/gdal.so
-%attr(755,root,root) %{ruby_sitearchdir}/gdal/gdalconst.so
-%attr(755,root,root) %{ruby_sitearchdir}/gdal/ogr.so
-%attr(755,root,root) %{ruby_sitearchdir}/gdal/osr.so
+%dir %{ruby_vendorarchdir}/gdal
+%attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdal.so
+%attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdalconst.so
+%attr(755,root,root) %{ruby_vendorarchdir}/gdal/ogr.so
+%attr(755,root,root) %{ruby_vendorarchdir}/gdal/osr.so
 %endif
This page took 0.110665 seconds and 4 git commands to generate.