]> git.pld-linux.org Git - packages/gdal.git/blob - gdal.spec
de3e09e82b75cfa9e6773c041cfa1840e1b18788
[packages/gdal.git] / gdal.spec
1 # TODO:
2 # - be reasonable about devel dependencies - you do not need all of them to
3 #   use gdal (probably a gdal module or driver shall not imply devel
4 #   dependency)
5 # - MongoCXX (mongo/client/dbclient.h, -lmongoclient -lboost_system -lboost_thread -lboost_regex)
6 # - rasterlite2
7 # - sfcgal >= 1.2.2
8 # - libjpeg12 (needs patching to use system one, --with-jpeg12 is not sufficient as of 1.9.2)
9 # - libkml (1.3.0 needed, not released yet)
10 # - wait for newer pcidsk, switch to external again
11 # - csharp, java
12 # - additional, proprietary(?) formats support:
13 #   - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
14 #   - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
15 #   - ECW (http://www.erdas.com/products/ecw/ERDASECWJPEG2000SDK/Details.aspx)
16 #   - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
17 #   - MrSID (http://www.lizardtech.com/developer/)
18 #   - LuraTech JP2Lura 
19 #   - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
20 #   - Ingres (--with-ingres=/path)
21 #   - Informix DB (--with-idb)
22 #   - DWGdirect (members only? http://www.opendwg.org/)
23 #   - ESRI SDE (http://www.esri.com/software/arcgis/arcsde/index.html)
24 #   - Teigha DWG/DGN (https://www.opendesign.com/products/drawings?)
25 #
26 # Conditional build:
27 %bcond_without  armadillo       # Armadillo support for faster TPS transform
28 %bcond_without  crnlib          # DDS support via crunch/crnlib
29 %bcond_without  epsilon         # EPSILON wavelet compression support
30 %bcond_without  fyba            # SOSI geodata support using FYBA
31 %bcond_with     grass           # GRASS support (note: dependency loop; use gdal-grass.spec instead)
32 %bcond_without  gta             # GTA format support
33 %bcond_without  kea             # KEA format support
34 %bcond_without  mysql           # MySQL DB support
35 %bcond_with     oci             # ORACLE OCI DB and Georaster support
36 %bcond_without  odbc            # ODBC DB support
37 %bcond_without  opencl          # OpenCL (GPU) support
38 %bcond_without  openjpeg        # OpenJPEG 2 (JPEG2000) support
39 %bcond_with     podofo          # PDF support via podofo instead of poppler
40 %bcond_without  poppler         # PDF support via poppler
41 %bcond_with     rasdaman        # Rasdaman support
42 %bcond_with     spatialite      # SpatiaLite support
43 %bcond_without  xerces          # Xerces support
44 %bcond_without  java            # Java and MDB support
45
46 %if %{with podofo}
47 %undefine       with_poppler
48 %endif
49 Summary:        Geospatial Data Abstraction Library
50 Summary(pl.UTF-8):      Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
51 Name:           gdal
52 Version:        3.0.4
53 Release:        2
54 License:        BSD-like
55 Group:          Libraries
56 Source0:        https://github.com/OSGeo/gdal/releases/download/v%{version}/%{name}-%{version}.tar.gz
57 # Source0-md5:  c6bbb5caca06e96bd97a32918e0aa9aa
58 Patch0:         %{name}-perl.patch
59 Patch1:         %{name}-pc.patch
60 Patch2:         %{name}-dds.patch
61 Patch3:         %{name}-rasdaman.patch
62 Patch4:         %{name}-pluginsdir.patch
63 Patch5:         libx32.patch
64 Patch7:         decl.patch
65 URL:            http://www.gdal.org/
66 # 1.x or 2.x supported
67 BuildRequires:  CharLS-devel
68 %{?with_opencl:BuildRequires:   OpenCL-devel >= 1.0}
69 %{?with_armadillo:BuildRequires:        armadillo-devel}
70 BuildRequires:  autoconf >= 2.52
71 BuildRequires:  automake
72 BuildRequires:  cfitsio-devel
73 %{?with_crnlib:BuildRequires:   crnlib-devel}
74 BuildRequires:  cryptopp-devel
75 BuildRequires:  curl-devel
76 BuildRequires:  doxygen >= 1.4.2
77 %{?with_epsilon:BuildRequires:  epsilon-compressor-devel}
78 BuildRequires:  expat-devel >= 1.95.0
79 %{?with_fyba:BuildRequires:     fyba-devel}
80 BuildRequires:  freexl-devel >= 1.0
81 BuildRequires:  gcc >= 6:4.1
82 BuildRequires:  geos-devel >= 3.1.0
83 BuildRequires:  giflib-devel >= 4.0
84 %{?with_grass:BuildRequires:    grass-devel >= 6.4}
85 BuildRequires:  hdf-devel >= 4.2.5
86 BuildRequires:  hdf5-devel
87 BuildRequires:  jasper-devel
88 %{?with_java:BuildRequires:     jdk}
89 %{?with_java:BuildRequires:     jpackage-utils}
90 BuildRequires:  json-c-devel >= 0.11
91 %{?with_kea:BuildRequires:      kealib-devel}
92 BuildRequires:  libcsf-devel >= 2.0-0.041111.6
93 BuildRequires:  libdap-devel >= 3.10
94 BuildRequires:  libgeotiff-devel >= 1.2.1
95 %{?with_gta:BuildRequires:      libgta-devel}
96 BuildRequires:  libjpeg-devel >= 6b
97 #BuildRequires: libkml-devel >= 1.3.0
98 BuildRequires:  libpng-devel >= 2:1.2.8
99 %{?with_spatialite:BuildRequires:       libspatialite-devel}
100 BuildRequires:  libstdc++-devel
101 BuildRequires:  libtiff-devel >= 4.0
102 BuildRequires:  libtirpc-devel
103 BuildRequires:  libtool
104 BuildRequires:  libuuid-devel
105 BuildRequires:  libwebp-devel
106 BuildRequires:  libxml2-devel >= 2
107 #%{?with_mysql:BuildRequires:   mysql-devel >= 4}
108 %{?with_mysql:BuildRequires:    /usr/bin/mysql_config}
109 BuildRequires:  netcdf-devel >= 4.1
110 BuildRequires:  ogdi-devel >= 3.1
111 %{?with_openjpeg:BuildRequires: openjpeg2-devel >= 2.1.0}
112 # 8.1.7 for DB support, 10.0.1 for georaster
113 %{?with_oci:BuildRequires:      oracle-instantclient-devel >= 10.0.1}
114 #BuildRequires: pcidsk-devel > 0.3
115 BuildRequires:  pcre-devel
116 BuildRequires:  perl-devel
117 BuildRequires:  pkgconfig >= 1:0.21
118 %{?with_podofo:BuildRequires:   podofo-devel}
119 %{?with_poppler:BuildRequires:  poppler-devel >= 0.24}
120 # ensure it's compiled with PQescapeStringConn support
121 BuildRequires:  postgresql-backend-devel >= 8.1.4
122 BuildRequires:  postgresql-devel >= 8.1.4
123 BuildRequires:  proj-devel >= 4
124 BuildRequires:  python-devel >= 1:2.5
125 BuildRequires:  python-numpy-devel >= 1:1.0.0
126 BuildRequires:  python-setuptools
127 BuildRequires:  qhull-devel >= 2012
128 %{?with_rasdaman:BuildRequires: rasdaman-devel}
129 BuildRequires:  rpm-pythonprov
130 BuildRequires:  rpmbuild(macros) >= 1.344
131 BuildRequires:  sed >= 4.0
132 BuildRequires:  sqlite3-devel >= 3.0.0
133 BuildRequires:  swig-perl
134 BuildRequires:  swig-python >= 1.3
135 BuildRequires:  texlive-dvips
136 BuildRequires:  texlive-latex
137 %{?with_odbc:BuildRequires:     unixODBC-devel >= 2.2.15}
138 %{?with_xerces:BuildRequires:   xerces-c-devel >= 3.1.0}
139 BuildRequires:  xz-devel
140 BuildRequires:  zlib-devel >= 1.1.4
141 # for ZSTD compression in TIFF
142 BuildRequires:  zstd-devel
143 Requires:       freexl >= 1.0
144 Requires:       geos >= 3.1.0
145 Requires:       hdf >= 4.2.5
146 Requires:       libgeotiff >= 1.2.1
147 Requires:       libpng >= 2:1.2.8
148 Requires:       libtiff >= 4.0
149 %{?with_openjpeg:Requires:      openjpeg2 >= 2.1.0}
150 Requires:       qhull >= 2012
151 %{?with_xerces:Requires:        xerces-c >= 3.1.0}
152 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
153
154 %description
155 GDAL is a translator library for raster geospatial data formats that
156 is released under an Open Source license. As a library, it presents a
157 single abstract data model to the calling application for all
158 supported formats. The related OGR library (which lives within the
159 GDAL source tree) provides a similar capability for simple features
160 vector data.
161
162 %description -l pl.UTF-8
163 GDAL to biblioteka konwertująca między formatami rastrowych danych
164 dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
165 Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
166 do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
167 (której źródła są dołączone do drzewa źródeł GDAL) daje podobne
168 możliwości dla danych wektorowych.
169
170 %package devel
171 Summary:        GDAL library header files
172 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GDAL
173 Group:          Development/Libraries
174 Requires:       %{name} = %{version}-%{release}
175 Requires:       CharLS-devel
176 %{?with_opencl:Requires:        OpenCL-devel >= 1.0}
177 %{?with_armadillo:Requires:     armadillo-devel}
178 Requires:       cfitsio-devel
179 %{?with_crnlib:Requires:        crnlib-devel}
180 Requires:       cryptopp-devel
181 Requires:       curl-devel
182 %{?with_epsilon:Requires:       epsilon-compressor-devel}
183 %{?with_fyba:Requires:  fyba-devel}
184 Requires:       expat-devel >= 1.95.0
185 Requires:       freexl-devel >= 1.0
186 Requires:       geos-devel >= 3.1.0
187 Requires:       giflib-devel >= 4.0
188 Requires:       hdf-devel >= 4.2.5
189 Requires:       hdf5-devel
190 Requires:       jasper-devel
191 Requires:       json-c-devel >= 0.11
192 %{?with_kea:Requires:   kealib-devel}
193 Requires:       libcsf-devel
194 Requires:       libdap-devel >= 3.10
195 Requires:       libgeotiff-devel >= 1.2.1
196 %{?with_gta:Requires:   libgta-devel}
197 Requires:       libjpeg-devel >= 6b
198 Requires:       libpng-devel >= 2:1.2.8
199 %{?with_spatialite:Requires:    libspatialite-devel}
200 Requires:       libstdc++-devel
201 Requires:       libtiff-devel >= 4.0
202 Requires:       libuuid-devel
203 Requires:       libwebp-devel
204 Requires:       libxml2-devel >= 2
205 %{?with_mysql:Requires: /usr/bin/mysql_config}
206 Requires:       netcdf-devel >= 4
207 Requires:       ogdi-devel >= 3.1
208 %{?with_openjpeg:Requires:      openjpeg2-devel >= 2.1.0}
209 #Requires:      pcidsk-devel > 0.3
210 Requires:       pcre-devel
211 %{?with_podofo:Requires:        podofo-devel}
212 %{?with_poppler:Requires:       poppler-devel >= 0.24}
213 Requires:       postgresql-devel
214 Requires:       proj-devel >= 4
215 Requires:       qhull-devel >= 2012
216 %{?with_rasdaman:Requires:      rasdaman-devel}
217 Requires:       sqlite3-devel >= 3.0.0
218 %{?with_odbc:Requires:  unixODBC-devel}
219 %{?with_xerces:Requires:        xerces-c-devel >= 3.1.0}
220 Requires:       xz-devel
221 Requires:       zlib-devel >= 1.1.4
222 Requires:       zstd-devel
223
224 %description devel
225 GDAL library header files.
226
227 %description devel -l pl.UTF-8
228 Pliki nagłówkowe biblioteki GDAL.
229
230 %package static
231 Summary:        GDAL static libraries
232 Summary(pl.UTF-8):      Statyczne biblioteki GDAL
233 Group:          Development/Libraries
234 Requires:       %{name}-devel = %{version}-%{release}
235
236 %description static
237 GDAL static libraries.
238
239 %description static -l pl.UTF-8
240 Statyczne biblioteki GDAL.
241
242 %package -n perl-gdal
243 Summary:        Perl bindings for GDAL
244 Summary(pl.UTF-8):      Wiązania Perla do pakietu GDAL
245 Group:          Development/Languages/Perl
246 Requires:       %{name} = %{version}-%{release}
247
248 %description -n perl-gdal
249 Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
250
251 %description -n perl-gdal -l pl.UTF-8
252 Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
253
254 %package -n python-gdal
255 Summary:        GDAL Python module
256 Summary(pl.UTF-8):      Moduł Pythona GDAL
257 Group:          Libraries/Python
258 Requires:       %{name} = %{version}-%{release}
259 Requires:       python-libs
260
261 %description -n python-gdal
262 GDAL Python module.
263
264 %description -n python-gdal -l pl.UTF-8
265 Moduł Pythona GDAL.
266
267 %prep
268 %setup -q
269 %patch0 -p1
270 %patch1 -p1
271 %patch2 -p1
272 %patch3 -p1
273 %patch4 -p1
274 %patch5 -p1
275 %patch7 -p1
276
277 # need to regenerate (old ones don't support perl 5.10)
278 %{__rm} swig/perl/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
279
280 # our man path
281 sed -i -e 's#^mandir=.*##g' configure.ac
282
283 %{__rm} -r man
284
285 %{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.ac
286
287 sed -E -i -e '1s,#!\s*/usr/bin/env\s+python2(\s|$),#!%{__python}\1,' \
288           -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python}\1,' \
289           -e '1s,#!\s*/usr/bin/python(\s|$),#!%{__python}\1,' \
290       swig/python/scripts/epsg_tr.py \
291       swig/python/scripts/esri2wkt.py \
292       swig/python/scripts/gcps2vec.py \
293       swig/python/scripts/gcps2wld.py \
294       swig/python/scripts/gdal2tiles.py \
295       swig/python/scripts/gdal2xyz.py \
296       swig/python/scripts/gdal_auth.py \
297       swig/python/scripts/gdal_calc.py \
298       swig/python/scripts/gdal_edit.py \
299       swig/python/scripts/gdal_fillnodata.py \
300       swig/python/scripts/gdal_merge.py \
301       swig/python/scripts/gdal_pansharpen.py \
302       swig/python/scripts/gdal_polygonize.py \
303       swig/python/scripts/gdal_proximity.py \
304       swig/python/scripts/gdal_retile.py \
305       swig/python/scripts/gdal_sieve.py \
306       swig/python/scripts/gdalchksum.py \
307       swig/python/scripts/gdalcompare.py \
308       swig/python/scripts/gdalident.py \
309       swig/python/scripts/gdalimport.py \
310       swig/python/scripts/gdalmove.py \
311       swig/python/scripts/mkgraticule.py \
312       swig/python/scripts/ogrmerge.py \
313       swig/python/scripts/pct2rgb.py \
314       swig/python/scripts/rgb2pct.py
315
316 %build
317 %ifarch %{x8664}
318 jvm_arch=amd64
319 %endif
320 %ifarch %{ix86}
321 jvm_arch=i386
322 %endif
323 %ifarch x32
324 jvm_arch=x32
325 %endif
326
327 %{__libtoolize}
328 %{__aclocal} -I m4
329 %{__autoconf}
330 %{__autoheader}
331 %configure \
332         --includedir=%{_includedir}/gdal \
333         --datadir=%{_datadir}/gdal \
334         --with-dods-root=/usr \
335         %{?with_armadillo:--with-armadillo} \
336         %{?with_crnlib:--with-dds} \
337         %{?with_epsilon:--with-epsilon} \
338         %{?with_grass:--with-grass} \
339         %{!?with_gta:--without-gta} \
340         --with-hide-internal-symbols \
341         %{?with_java:--with-java=%{java_home}} \
342         --with-liblzma \
343         %{!?with_kea:--without-kea} \
344         %{?with_java:--with-mdb --with-jvm-lib-add-rpath --with-jvm-lib=%{java_home}/jre/lib/$jvm_arch/server} \
345         %{?with_mysql:--with-mysql} \
346         %{?with_oci:--with-oci --with-oci-include=/usr/include/oracle/client --with-oci-lib=%{_libdir}} \
347         %{?with_opencl:--with-opencl} \
348         --with-perl \
349         %{?with_podofo:--with-podofo} \
350         %{?with_poppler:--with-poppler} \
351         --with-python \
352         %{?with_rasdaman:--with-rasdaman=%{_libdir}/rasdaman} \
353         %{?with_fyba:--with-sosi} \
354         %{?with_spatialite:--with-spatialite} \
355         --with-sqlite3 \
356         --with-webp \
357         %{?with_xerces:--with-xerces} \
358         --with-xerces-inc=/usr/include \
359         --with-xerces-lib="-lxerces-c" \
360         --without-libgrass
361 #       --with-pcidsk=/usr (needs > 0.3)
362 # csharp builds, but has no configure option nor install target
363
364 # regenerate where needed
365 %{__make} -j1 -C swig/perl generate
366
367 %{__make} \
368         %{?with_grass:GRASS_INCLUDE="-I/usr/include/grass64"} \
369         %{?with_fyba:SOSI_INC="-I/usr/include/fyba"}
370
371 %{__make} -j1 docs
372
373 %{__make} -j1 man
374
375 %install
376 rm -rf $RPM_BUILD_ROOT
377
378 %{__make} -j1 install install-man \
379         DESTDIR=$RPM_BUILD_ROOT
380
381 # TODO: remove libgdal.la when gdal.pc gets maintained Requires.private/Libs.private list
382
383 rm -rf _html
384 cp -a html _html
385
386 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
387 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
388 %py_postclean
389
390 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
391 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
392 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
393 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
394 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
395
396 %clean
397 rm -rf $RPM_BUILD_ROOT
398
399 %post   -p /sbin/ldconfig
400 %postun -p /sbin/ldconfig
401
402 %files
403 %defattr(644,root,root,755)
404 %doc NEWS PROVENANCE.TXT
405 %attr(755,root,root) %{_bindir}/epsg_tr.py
406 %attr(755,root,root) %{_bindir}/esri2wkt.py
407 %attr(755,root,root) %{_bindir}/gcps2vec.py
408 %attr(755,root,root) %{_bindir}/gcps2wld.py
409 %attr(755,root,root) %{_bindir}/gdal2tiles.py
410 %attr(755,root,root) %{_bindir}/gdal2xyz.py
411 %attr(755,root,root) %{_bindir}/gdaladdo
412 %attr(755,root,root) %{_bindir}/gdal_auth.py
413 %attr(755,root,root) %{_bindir}/gdalbuildvrt
414 %attr(755,root,root) %{_bindir}/gdal_calc.py
415 %attr(755,root,root) %{_bindir}/gdalchksum.py
416 %attr(755,root,root) %{_bindir}/gdalcompare.py
417 %attr(755,root,root) %{_bindir}/gdal_contour
418 %attr(755,root,root) %{_bindir}/gdaldem
419 %attr(755,root,root) %{_bindir}/gdal_edit.py
420 %attr(755,root,root) %{_bindir}/gdalenhance
421 %attr(755,root,root) %{_bindir}/gdal_fillnodata.py
422 %attr(755,root,root) %{_bindir}/gdal_grid
423 %attr(755,root,root) %{_bindir}/gdalident.py
424 %attr(755,root,root) %{_bindir}/gdalimport.py
425 %attr(755,root,root) %{_bindir}/gdalinfo
426 %attr(755,root,root) %{_bindir}/gdallocationinfo
427 %attr(755,root,root) %{_bindir}/gdalmanage
428 %attr(755,root,root) %{_bindir}/gdal_merge.py
429 %attr(755,root,root) %{_bindir}/gdalmove.py
430 %attr(755,root,root) %{_bindir}/gdal_pansharpen.py
431 %attr(755,root,root) %{_bindir}/gdal_polygonize.py
432 %attr(755,root,root) %{_bindir}/gdal_proximity.py
433 %attr(755,root,root) %{_bindir}/gdal_rasterize
434 %attr(755,root,root) %{_bindir}/gdal_retile.py
435 %attr(755,root,root) %{_bindir}/gdalserver
436 %attr(755,root,root) %{_bindir}/gdal_sieve.py
437 %attr(755,root,root) %{_bindir}/gdalsrsinfo
438 %attr(755,root,root) %{_bindir}/gdaltindex
439 %attr(755,root,root) %{_bindir}/gdaltransform
440 %attr(755,root,root) %{_bindir}/gdal_translate
441 %attr(755,root,root) %{_bindir}/gdalwarp
442 %attr(755,root,root) %{_bindir}/gnmanalyse
443 %attr(755,root,root) %{_bindir}/gnmmanage
444 %attr(755,root,root) %{_bindir}/mkgraticule.py
445 %attr(755,root,root) %{_bindir}/nearblack
446 %attr(755,root,root) %{_bindir}/ogr2ogr
447 %attr(755,root,root) %{_bindir}/ogrinfo
448 %attr(755,root,root) %{_bindir}/ogrlineref
449 %attr(755,root,root) %{_bindir}/ogrmerge.py
450 %attr(755,root,root) %{_bindir}/ogrtindex
451 %attr(755,root,root) %{_bindir}/pct2rgb.py
452 %attr(755,root,root) %{_bindir}/rgb2pct.py
453 %attr(755,root,root) %{_bindir}/testepsg
454 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
455 %attr(755,root,root) %ghost %{_libdir}/libgdal.so.26
456 %dir %{_libdir}/gdalplugins
457 %{_datadir}/gdal
458 %{_mandir}/man1/gdal2tiles.1*
459 %{_mandir}/man1/gdal_calc.1*
460 %{_mandir}/man1/gdal_contour.1*
461 %{_mandir}/man1/gdal_edit.1*
462 %{_mandir}/man1/gdal_fillnodata.1*
463 %{_mandir}/man1/gdal_grid.1*
464 %{_mandir}/man1/gdal_merge.1*
465 %{_mandir}/man1/gdal_polygonize.1*
466 %{_mandir}/man1/gdal_proximity.1*
467 %{_mandir}/man1/gdal_rasterize.1*
468 %{_mandir}/man1/gdal_retile.1*
469 %{_mandir}/man1/gdal_sieve.1*
470 %{_mandir}/man1/gdal_translate.1*
471 %{_mandir}/man1/gdal_utilities.1*
472 %{_mandir}/man1/gdaladdo.1*
473 %{_mandir}/man1/gdalbuildvrt.1*
474 %{_mandir}/man1/gdalcompare.1*
475 %{_mandir}/man1/gdaldem.1*
476 %{_mandir}/man1/gdalinfo.1*
477 %{_mandir}/man1/gdallocationinfo.1*
478 %{_mandir}/man1/gdalmanage.1*
479 %{_mandir}/man1/gdalmove.1*
480 %{_mandir}/man1/gdalsrsinfo.1*
481 %{_mandir}/man1/gdaltindex.1*
482 %{_mandir}/man1/gdaltransform.1*
483 %{_mandir}/man1/gdalwarp.1*
484 %{_mandir}/man1/nearblack.1*
485 %{_mandir}/man1/ogr2ogr.1*
486 %{_mandir}/man1/ogr_utilities.1*
487 %{_mandir}/man1/ogrinfo.1*
488 %{_mandir}/man1/ogrlineref.1*
489 %{_mandir}/man1/ogrtindex.1*
490 %{_mandir}/man1/pct2rgb.1*
491 %{_mandir}/man1/rgb2pct.1*
492 %{_mandir}/man1/gdal_pansharpen.1*
493 %{_mandir}/man1/gnm_utilities.1*
494 %{_mandir}/man1/gnmanalyse.1*
495 %{_mandir}/man1/gnmmanage.1*
496 %{_mandir}/man1/ogrmerge.1*
497
498 %files devel
499 %defattr(644,root,root,755)
500 %doc _html/*
501 %attr(755,root,root) %{_bindir}/gdal-config
502 %attr(755,root,root) %{_libdir}/libgdal.so
503 %{_libdir}/libgdal.la
504 %{_pkgconfigdir}/gdal.pc
505 %{_includedir}/gdal
506 %{_mandir}/man1/gdal-config.1*
507
508 %files static
509 %defattr(644,root,root,755)
510 %{_libdir}/libgdal.a
511
512 %files -n perl-gdal
513 %defattr(644,root,root,755)
514 %dir %{perl_vendorarch}/Geo
515 %{perl_vendorarch}/Geo/GDAL.pm
516 %dir %{perl_vendorarch}/Geo/GDAL
517 %{perl_vendorarch}/Geo/GDAL/Const.pm
518 %{perl_vendorarch}/Geo/OGR.pm
519 %{perl_vendorarch}/Geo/OSR.pm
520 %dir %{perl_vendorarch}/auto/Geo
521 %dir %{perl_vendorarch}/auto/Geo/GDAL
522 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
523 %dir %{perl_vendorarch}/auto/Geo/GDAL/Const
524 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
525 %dir %{perl_vendorarch}/auto/Geo/GNM
526 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GNM/GNM.so
527 %dir %{perl_vendorarch}/auto/Geo/OGR
528 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
529 %dir %{perl_vendorarch}/auto/Geo/OSR
530 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
531 %{_mandir}/man3/Geo::GDAL.3pm*
532 %{perl_vendorarch}/Geo/GNM.pm
533
534 %files -n python-gdal
535 %defattr(644,root,root,755)
536 %{py_sitedir}/gdal.py[co]
537 %{py_sitedir}/gdalconst.py[co]
538 %{py_sitedir}/gdalnumeric.py[co]
539 %{py_sitedir}/ogr.py[co]
540 %{py_sitedir}/osr.py[co]
541 %{py_sitedir}/GDAL-*.egg-info
542 %dir %{py_sitedir}/osgeo
543 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
544 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
545 %attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
546 %attr(755,root,root) %{py_sitedir}/osgeo/_gnm.so
547 %attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
548 %attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
549 %{py_sitedir}/osgeo/*.py[co]
This page took 0.095941 seconds and 2 git commands to generate.