]> git.pld-linux.org Git - packages/gd.git/commitdiff
- 2.0.1, updated ac_am patch; uses freetype2 now
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 12 Jul 2001 23:40:37 +0000 (23:40 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- BuildRequires: libtiff-devel
php seems to be ready for gd2; need to check perl-GD, webalizer etc.

Changed files:
    gd-ac_am.patch -> 1.6
    gd.spec -> 1.51

gd-ac_am.patch
gd.spec

index ecd309739f9e3947e19c60951f9c70531f0c4715..ebfbc77afcd4145d95675aa842ec2f1d546ffd47 100644 (file)
@@ -1,12 +1,12 @@
-diff -Nru gd-1.8.4/Makefile.am gd-1.8.4.new/Makefile.am
---- gd-1.8.4/Makefile.am       Thu Jan  1 01:00:00 1970
-+++ gd-1.8.4.new/Makefile.am   Fri Feb  2 00:52:03 2001
-@@ -0,0 +1,93 @@
+diff -Nru gd-2.0.1/Makefile.am gd-2.0.1.new/Makefile.am
+--- gd-2.0.1/Makefile.am       Thu Jan  1 01:00:00 1970
++++ gd-2.0.1.new/Makefile.am   Fri Feb  2 00:52:03 2001
+@@ -0,0 +1,96 @@
 +## Process this file with automake to produce Makefile.in
 +
 +AUTOMAKE_OPTIONS = 1.4
 +
-+INCLUDES = -I$(includedir)/freetype
++INCLUDES = -I$(includedir)/freetype2
 +
 +lib_LTLIBRARIES = libgd.la
 +
@@ -27,20 +27,21 @@ diff -Nru gd-1.8.4/Makefile.am gd-1.8.4.new/Makefile.am
 +      gdfontmb.c \
 +      gdfontl.c \
 +      gdfontg.c \
-+      gdft.c \
 +      gdtables.c \
-+      gdttf.c \
++      gdft.c \
 +      gdcache.c \
 +      gdkanji.c \
 +      wbmp.c \
 +      gd_wbmp.c \
++      gdhelpers.c \
++      gd_topal.c \
 +      gd.h \
 +      gdfontt.h \
 +      gdfonts.h \
 +      gdfontmb.h \
 +      gdfontl.h \
 +      gdfontg.h \
-+      gdhelpers.c
++      gdhelpers.h
 +
 +include_HEADERS = \
 +      gd.h \
@@ -50,24 +51,26 @@ diff -Nru gd-1.8.4/Makefile.am gd-1.8.4.new/Makefile.am
 +      gdfontl.h \
 +      gdfontmb.h \
 +      gdfonts.h \
-+      gdfontt.h \
-+      gdhelpers.h
++      gdfontt.h
 +
-+libgd_la_LDFLAGS = -version-info 1:8:0
++libgd_la_LDFLAGS = -version-info 2:0:0
 +
 +bin_PROGRAMS = pngtogd pngtogd2 gdtopng gd2topng gd2copypal gdparttopng webpng
 +
-+noinst_PROGRAMS = gdtest gddemo gd2time gdtestttf
++noinst_PROGRAMS = gdtest gddemo gd2time gdtestft testac
 +
 +gdtest_SOURCES = gdtest.c gd.h
 +gdtest_LDADD = libgd.la
 +
-+gdtestttf_SOURCES = gdtestttf.c gd.h
-+gdtestttf_LDADD = libgd.la
++gdtestft_SOURCES = gdtestft.c gd.h
++gdtestft_LDADD = libgd.la
 +
 +gddemo_SOURCES = gddemo.c gd.h gdfonts.h gdfontg.h
 +gddemo_LDADD = libgd.la
 +
++testac_SOURCES = testac.c gd.h
++testac_LDADD = libgd.la
++
 +pngtogd_SOURCES = pngtogd.c gd.h
 +pngtogd_LDADD = libgd.la
 +
@@ -95,9 +98,9 @@ diff -Nru gd-1.8.4/Makefile.am gd-1.8.4.new/Makefile.am
 +EXTRA_DIST = demoin.png index.html test/*
 +
 +CLEANFILES = demoout.png
-diff -Nru gd-1.8.4/configure.in gd-1.8.4.new/configure.in
---- gd-1.8.4/configure.in      Thu Jan  1 01:00:00 1970
-+++ gd-1.8.4.new/configure.in  Fri Feb  2 00:45:23 2001
+diff -Nru gd-2.0.1/configure.in gd-2.0.1.new/configure.in
+--- gd-2.0.1/configure.in      Thu Jan  1 01:00:00 1970
++++ gd-2.0.1.new/configure.in  Fri Feb  2 00:45:23 2001
 @@ -0,0 +1,47 @@
 +dnl Process this file with autoconf to produce a configure script
 +
@@ -105,7 +108,7 @@ diff -Nru gd-1.8.4/configure.in gd-1.8.4.new/configure.in
 +
 +AC_CANONICAL_SYSTEM
 +
-+AM_INIT_AUTOMAKE(gd, 1.8.3)
++AM_INIT_AUTOMAKE(gd, 2.0.1)
 +
 +AM_MAINTAINER_MODE
 +
@@ -126,8 +129,8 @@ diff -Nru gd-1.8.4/configure.in gd-1.8.4.new/configure.in
 +AC_CHECK_LIB(fff, main)
 +dnl Replace `main' with a function in -lpng:
 +AC_CHECK_LIB(png, main, ,AC_MSG_ERROR(libpng not found.))
-+dnl Replace `main' with a function in -lttf:
-+AC_CHECK_LIB(ttf, main)
++dnl Replace `main' with a function in -lfreetype:
++AC_CHECK_LIB(freetype, main, [CFLAGS="$CFLAGS -DHAVE_LIBFREETYPE"; LIBS="$LIBS -lfreetype"])
 +dnl Replace `main' with a function in -lm:
 +AC_CHECK_LIB(m, main)
 +dnl Replace `main' with a function in -lz:
diff --git a/gd.spec b/gd.spec
index c1ae674cb210cb6230496a6ef2d5b40a77abbb07..7edc750742494d022802f6527bf4d433a6f1b2dd 100644 (file)
--- a/gd.spec
+++ b/gd.spec
@@ -1,11 +1,12 @@
 Summary:       Library for PNG, JPEG creation
 Summary(pl):   Biblioteka do tworzenia grafiki w formacie PNG, JPEG
 Name:          gd
-Version:       1.8.4
-Release:       6
+Version:       2.0.1
+Release:       1
 License:       BSD-style
 Group:         Libraries
 Group(de):     Libraries
+Group(es):     Bibliotecas
 Group(fr):     Librairies
 Group(pl):     Biblioteki
 Source0:       ftp://ftp.boutell.com/pub/boutell/gd/%{name}-%{version}.tar.gz
@@ -13,11 +14,11 @@ Patch0:             %{name}-ac_am.patch
 URL:           http://www.boutell.com/gd/
 BuildRequires: autoconf
 BuildRequires: automake
-BuildRequires: libtool
 BuildRequires: zlib-devel
 BuildRequires: libpng-devel
 BuildRequires: libjpeg-devel
-BuildRequires: freetype1-devel
+BuildRequires: libtiff-devel
+BuildRequires: freetype-devel >= 2.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define shlibver %(echo %{version} | cut -f-2 -d.)
This page took 0.12291 seconds and 4 git commands to generate.